aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Wagin <dmitry.wagin@ya.ru>2023-07-31 08:04:20 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-08-02 06:28:11 +0000
commit712443840eae9a35cb5260baba5d6e841b78a63b (patch)
tree9844b5f912e996fceee4fa5767d8c8404e6bc30d
parenta57ad84e7b5685e6e46867d2361f73e95ae50fd4 (diff)
downloadports-712443840eae9a35cb5260baba5d6e841b78a63b.tar.gz
ports-712443840eae9a35cb5260baba5d6e841b78a63b.zip
devel/jetbrains-phpstorm: Update to 2023.1.4
-rw-r--r--devel/jetbrains-phpstorm/Makefile16
-rw-r--r--devel/jetbrains-phpstorm/distinfo6
-rw-r--r--devel/jetbrains-phpstorm/pkg-plist8
3 files changed, 16 insertions, 14 deletions
diff --git a/devel/jetbrains-phpstorm/Makefile b/devel/jetbrains-phpstorm/Makefile
index 2053700940c8..15aabff681d1 100644
--- a/devel/jetbrains-phpstorm/Makefile
+++ b/devel/jetbrains-phpstorm/Makefile
@@ -1,5 +1,5 @@
PORTNAME= phpstorm
-PORTVERSION= 2023.1.3
+PORTVERSION= 2023.1.4
CATEGORIES= devel java
MASTER_SITES= https://download-cdn.jetbrains.com/webide/
PKGNAMEPREFIX= jetbrains-
@@ -17,7 +17,7 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
BUILD_DEPENDS= jna>0:devel/jna
RUN_DEPENDS= intellij-fsnotifier>0:java/intellij-fsnotifier \
- jetbrains-pty4j>=0.12.10:devel/jetbrains-pty4j \
+ jetbrains-pty4j>=0.12.13:devel/jetbrains-pty4j \
lsof:sysutils/lsof
USES= cpe python:run shebangfix
@@ -28,13 +28,14 @@ JAVA_VERSION= 17+
SHEBANG_FILES= bin/restart.py
+DATADIR= ${PREFIX}/share/jetbrains/${PORTNAME}
NO_ARCH= yes
NO_ARCH_IGNORE= libjnidispatch.so
NO_BUILD= yes
SUB_FILES= ${PORTNAME} ${PORTNAME}.desktop pkg-message
SUB_LIST= JAVA_HOME=${JAVA_HOME}
-WRKSRC= ${WRKDIR}/PhpStorm-231.9161.47
+WRKSRC= ${WRKDIR}/PhpStorm-231.9225.18
do-install:
# Linux/Windows/OS X only so remove them
@@ -43,12 +44,12 @@ do-install:
${WRKSRC}/bin/remote-dev-server.sh \
${WRKSRC}/bin/repair \
${WRKSRC}/jbr \
+ ${WRKSRC}/lib/jna \
${WRKSRC}/lib/native \
${WRKSRC}/lib/pty4j \
${WRKSRC}/plugins/cwm-plugin \
+ ${WRKSRC}/plugins/cwm-plugin-projector \
${WRKSRC}/plugins/gateway-plugin/lib/remote-dev-workers \
- ${WRKSRC}/plugins/performanceTesting \
- ${WRKSRC}/plugins/performanceTesting-async \
${WRKSRC}/plugins/performanceTesting-yourkit \
${WRKSRC}/plugins/remote-dev-server \
${WRKSRC}/plugins/webp/lib/libwebp
@@ -61,13 +62,14 @@ do-install:
${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/
# Use fsnotifier replacement provided by java/intellij-fsnotifier
- ${ECHO} "idea.filewatcher.executable.path=${PREFIX}/intellij/bin/fsnotifier" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
+ ${ECHO} "idea.filewatcher.executable.path=${PREFIX}/bin/fsnotifier" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
# Install FreeBSD native lib provided by devel/jna
@${MKDIR} ${WRKDIR}/jna
@(cd ${WRKDIR}/jna && ${JAR} xf ${JAVAJARDIR}/jna.jar com/sun/jna/freebsd-x86-64/libjnidispatch.so)
${MKDIR} ${STAGEDIR}${DATADIR}/lib/jna/amd64
${INSTALL_LIB} ${WRKDIR}/jna/com/sun/jna/freebsd-x86-64/libjnidispatch.so ${STAGEDIR}${DATADIR}/lib/jna/amd64/
# Use pty4j replacement provided by devel/jetbrains-pty4j
- ${LN} -sf ../../../lib/pty4j ${STAGEDIR}${DATADIR}/lib/pty4j
+ ${MKDIR} ${STAGEDIR}${DATADIR}/lib/pty4j/freebsd/x86-64
+ ${LN} -sf ../../../../../pty4j/amd64/libpty.so ${STAGEDIR}${DATADIR}/lib/pty4j/freebsd/x86-64/libpty.so
.include <bsd.port.mk>
diff --git a/devel/jetbrains-phpstorm/distinfo b/devel/jetbrains-phpstorm/distinfo
index 340509ef8fe2..05172191b967 100644
--- a/devel/jetbrains-phpstorm/distinfo
+++ b/devel/jetbrains-phpstorm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1687791984
-SHA256 (jetbrains/PhpStorm-2023.1.3.tar.gz) = c12c99b39615bd2d37eec93ed29faee2387294624eaed7fabd5c7cc8de9faf9f
-SIZE (jetbrains/PhpStorm-2023.1.3.tar.gz) = 648927078
+TIMESTAMP = 1690740639
+SHA256 (jetbrains/PhpStorm-2023.1.4.tar.gz) = 7b44d704641c6015ce49e12e82c8866e9fdd8e8d421590235e536b3b1312b180
+SIZE (jetbrains/PhpStorm-2023.1.4.tar.gz) = 648953340
diff --git a/devel/jetbrains-phpstorm/pkg-plist b/devel/jetbrains-phpstorm/pkg-plist
index acf139ec84cb..cc29bb79b67a 100644
--- a/devel/jetbrains-phpstorm/pkg-plist
+++ b/devel/jetbrains-phpstorm/pkg-plist
@@ -30,7 +30,7 @@ share/applications/phpstorm.desktop
%%DATADIR%%/lib/app.jar
%%DATADIR%%/lib/async-profiler-windows.jar
%%DATADIR%%/lib/async-profiler.jar
-%%DATADIR%%/lib/build-marker-PS-231.9161.47
+%%DATADIR%%/lib/build-marker-PS-231.9225.18
%%DATADIR%%/lib/byte-buddy-agent.jar
%%DATADIR%%/lib/cds/classesLogAgent.jar
%%DATADIR%%/lib/error-prone-annotations.jar
@@ -46,7 +46,7 @@ share/applications/phpstorm.desktop
%%DATADIR%%/lib/jsch-agent.jar
%%DATADIR%%/lib/junit4.jar
%%DATADIR%%/lib/protobuf.jar
-%%DATADIR%%/lib/pty4j
+%%DATADIR%%/lib/pty4j/freebsd/x86-64/libpty.so
%%DATADIR%%/lib/rd.jar
%%DATADIR%%/lib/stats.jar
%%DATADIR%%/lib/testFramework.jar
@@ -97,8 +97,6 @@ share/applications/phpstorm.desktop
%%DATADIR%%/plugins/configurationScript/lib/configurationScript.jar
%%DATADIR%%/plugins/copyright/lib/copyright.jar
%%DATADIR%%/plugins/css-impl/lib/css-impl.jar
-%%DATADIR%%/plugins/cwm-plugin-projector/lib/cwm-plugin-projector.jar
-%%DATADIR%%/plugins/cwm-plugin-projector/lib/projector/projector.jar
%%DATADIR%%/plugins/dev/lib/dev.jar
%%DATADIR%%/plugins/dql/lib/dql.jar
%%DATADIR%%/plugins/drupal/lib/drupal.jar
@@ -347,6 +345,8 @@ share/applications/phpstorm.desktop
%%DATADIR%%/plugins/nodeJS/js/mocha-intellij/package.json
%%DATADIR%%/plugins/nodeJS/js/nodeunit/nodeunit-intellij-starter.js
%%DATADIR%%/plugins/nodeJS/lib/nodeJS.jar
+%%DATADIR%%/plugins/performanceTesting-async/lib/performanceTesting-async.jar
+%%DATADIR%%/plugins/performanceTesting/lib/performanceTesting.jar
%%DATADIR%%/plugins/phing/lib/phing.jar
%%DATADIR%%/plugins/php-architecture/lib/php-architecture.jar
%%DATADIR%%/plugins/php-commandLineTool/lib/php-commandLineTool.jar