aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-08-13 17:20:29 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-08-13 18:51:25 +0000
commit714af13781970db3ec794eab4627d585b63df00a (patch)
treea40830e7f5f093db4df283edc9b2e9b02b53c331
parent875d7c7d1985049af69dcafec40b6669c562781c (diff)
downloadports-714af13781970db3ec794eab4627d585b63df00a.tar.gz
ports-714af13781970db3ec794eab4627d585b63df00a.zip
archivers/py-borgbackup: use fixed xxhash instead of avoiding it
This reverts commit 9db903a89b3d1d7c0be2a56059542f3fdb412908 because it does not fix the situation for lack of a PORTREVISION bump. Let us use the opportunity to fix the real bug instead. Now with xxhash fixed as of 0.8.1_2, drop 9db903a89, and bump PORTREVISION so we flush out the old garbage packages. A simple web search would have brought up that static_assert() is a C11 convenience macro defined in <assert.h>, and a detailed search would have turned up that this had been fixed in xxhash before. While here, add a smoke test to post-install. Proper fix was Reported by: Thierry Dussuet <thierry.dussuet@protonmail.com> PR: 265060 MFH: 2022Q3
-rw-r--r--archivers/py-borgbackup/Makefile3
-rw-r--r--archivers/py-borgbackup/files/patch-setup.py11
2 files changed, 2 insertions, 12 deletions
diff --git a/archivers/py-borgbackup/Makefile b/archivers/py-borgbackup/Makefile
index 0638addb75a3..ec020d2659a9 100644
--- a/archivers/py-borgbackup/Makefile
+++ b/archivers/py-borgbackup/Makefile
@@ -13,7 +13,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.7:devel/py-setuptools_scm@${PY_FLAVOR}
LIB_DEPENDS= liblz4.so:archivers/liblz4 \
- libzstd.so:archivers/zstd
+ libzstd.so:archivers/zstd \
+ libxxhash.so:devel/xxhash
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=19.0:devel/py-packaging@${PY_FLAVOR}
USES= python ssl
diff --git a/archivers/py-borgbackup/files/patch-setup.py b/archivers/py-borgbackup/files/patch-setup.py
deleted file mode 100644
index 399dc0b58daa..000000000000
--- a/archivers/py-borgbackup/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2022-07-16 16:20:52 UTC
-+++ setup.py
-@@ -23,7 +23,7 @@ prefer_system_libzstd = True
- prefer_system_libb2 = True
-
- # True: use the shared libxxhash (>= 0.6.5 [>= 0.7.2 on ARM]) from the system, False: use the bundled xxhash code
--prefer_system_libxxhash = True
-+prefer_system_libxxhash = False
-
- # prefer_system_msgpack is another option, but you need to set it in src/borg/helpers.py.
-