aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2022-04-13 18:22:48 +0000
committerDon Lewis <truckman@FreeBSD.org>2022-04-13 20:40:38 +0000
commit71cf25e7ab619a447a00de0d3d8a3c459f956c83 (patch)
tree614cd37e8f2ad6ab1701b5dd0826bca07bb3ae13
parent8a7c8d4fe93912676521c2e8eea89db638c7e599 (diff)
downloadports-71cf25e7ab619a447a00de0d3d8a3c459f956c83.tar.gz
ports-71cf25e7ab619a447a00de0d3d8a3c459f956c83.zip
editors/openoffice-devel: Fix dependency issues
Fix an incorrect coinmp-related dependency that was causing spurious rebuilds. It was also reported to break the build of openoffice-4, though I was unable to reproduce the problem, and it did not seem to break the official package build. Add another missing dependency. Both issues were reported by stage-qa. PR: 263238 (cherry picked from commit db0d93edd89c424bcb722cf7851d256fedf666db)
-rw-r--r--editors/openoffice-devel/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 2156f4e76f42..cd5147c818c0 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${TIMESTAMP}
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 4
CATEGORIES= editors java
MASTER_SITES= https://dist.apache.org/repos/dist/dev/openoffice/${AOOVERSION}-${AOORC}-${TIMESTAMP}/source/ \
@@ -85,7 +85,7 @@ LIB_DEPENDS= \
libClpSolver.so:math/clp \
libCoinMP.so:math/coinmp \
libCoinUtils.so:math/coinutils \
- libcoinmumps.so:math/ipopt \
+ libcoinmumps.so:math/coin-or-mumps \
libnauty.so:math/nauty \
libopenblas.so:math/openblas \
libOsi.so:math/osi \
@@ -115,7 +115,7 @@ USES= autoreconf bison compiler:c++11-lib cpe desktop-file-utils \
gettext-runtime gl gmake gnome iconv jpeg perl5 pkgconfig \
python:3.7 shared-mime-info ssl tar:${TARTYPE} xorg
USE_GL= gl glu
-USE_GNOME= gtk20 libxslt libidl glib20
+USE_GNOME= gdkpixbuf2 gtk20 libxslt libidl glib20
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_RUN= jdk