aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-03-18 13:52:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-03-18 13:52:54 +0000
commit723d568e7a416cbd8315cc62ac9fa0a79b938610 (patch)
tree8c3d6d76efe04b1bd10a1422b10c1bf2d65f5a4f
parentca5b02ff85cef77a5058592d9b41dc33222dd0b7 (diff)
downloadports-723d568e7a416cbd8315cc62ac9fa0a79b938610.tar.gz
ports-723d568e7a416cbd8315cc62ac9fa0a79b938610.zip
Add CPE.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=381551
-rw-r--r--irc/unreal/Makefile4
-rw-r--r--net-mgmt/nagios/Makefile2
-rw-r--r--net-mgmt/nagios4/Makefile2
-rw-r--r--net/quagga/Makefile2
-rw-r--r--sysutils/munin-common/Makefile2
-rw-r--r--sysutils/munin-common/munin.mk2
-rw-r--r--sysutils/munin-master/Makefile2
-rw-r--r--sysutils/munin-node/Makefile2
-rw-r--r--www/ikiwiki/Makefile2
-rw-r--r--www/lighttpd/Makefile4
10 files changed, 16 insertions, 8 deletions
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index c2505a059d0d..77f1b51f3b9c 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -28,8 +28,10 @@ USE_RC_SUBR= unrealircd
USERS= ircd
GROUPS= ircd
+CPE_VENDOR= unrealircd
+CPE_PRODUCT= unrealircd
-USES= pkgconfig
+USES= pkgconfig cpe
SUB_LIST+= RUNDIR=${RUNDIR}
SUB_LIST+= USERS=${USERS}
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 68e0e66ef0d0..d456ecda0b40 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
PORTSCOUT= limit:^3.
-USES= iconv perl5
+USES= iconv perl5 cpe
USE_PERL5= build
USE_PHP= yes
USE_RC_SUBR= nagios
diff --git a/net-mgmt/nagios4/Makefile b/net-mgmt/nagios4/Makefile
index a54f52adfa53..2b256b37bddb 100644
--- a/net-mgmt/nagios4/Makefile
+++ b/net-mgmt/nagios4/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
libgd.so:${PORTSDIR}/graphics/gd
-USES= gmake iconv perl5
+USES= gmake iconv perl5 cpe
USE_PERL5= build
USE_PHP= xml
USE_RC_SUBR= nagios
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 84c73c1327cd..3d9b975a6ed6 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= openbgpd-[0-9]* openospfd-[0-9]* zebra-0* quagga-re-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-exampledir=${PREFIX}/share/examples/quagga
INSTALL_TARGET= install-strip
-USES= gmake libtool makeinfo perl5 readline compiler:c11 tar:xz autoreconf
+USES= gmake libtool makeinfo perl5 readline compiler:c11 tar:xz autoreconf cpe
USE_LDCONFIG= yes
USE_PERL5= build
diff --git a/sysutils/munin-common/Makefile b/sysutils/munin-common/Makefile
index 2773851d271f..b30ad42beef1 100644
--- a/sysutils/munin-common/Makefile
+++ b/sysutils/munin-common/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= p5-Module-Build>=0:${PORTSDIR}/devel/p5-Module-Build \
p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
RUN_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
-USES= gmake perl5
+USES= gmake perl5 cpe
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
.include "${.CURDIR}/../munin-common/munin.mk"
diff --git a/sysutils/munin-common/munin.mk b/sysutils/munin-common/munin.mk
index b7cc6d73ac9e..724706f606d5 100644
--- a/sysutils/munin-common/munin.mk
+++ b/sysutils/munin-common/munin.mk
@@ -29,3 +29,5 @@ MAKE_ARGS= ${MUNIN_DIRS} \
USERS= munin
GROUPS= munin
PLIST_SUB= ${MUNIN_DIRS} USER=${USERS} GROUP=${GROUPS}
+
+CPE_VENDOR= munin-monitoring
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 5f48066a8205..6813daca9e57 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -42,7 +42,7 @@ RUN_DEPENDS= munin-common>=0:${PORTSDIR}/sysutils/munin-common \
p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
p5-FCGI>=0:${PORTSDIR}/www/p5-FCGI
-USES= gmake perl5
+USES= gmake perl5 cpe
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 931f3ababeb0..e84dcb40ddb8 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
bash:${PORTSDIR}/shells/bash
-USES= gmake perl5 shebangfix
+USES= gmake perl5 shebangfix cpe
PKGMESSAGE= ${WRKDIR}/pkg-message
REINPLACE_ARGS= -i ""
SHEBANG_FILES= node/sbin/munin-node node/sbin/munin-sched \
diff --git a/www/ikiwiki/Makefile b/www/ikiwiki/Makefile
index 7100d4d53864..15f597e8699f 100644
--- a/www/ikiwiki/Makefile
+++ b/www/ikiwiki/Makefile
@@ -36,7 +36,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= gettext perl5 gmake
+USES= gettext perl5 gmake cpe
USE_PERL5= configure
CONFIGURE_ARGS= PERL=${PERL} FULLPERL=${PERL}
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index da092abf5c26..ea6b7fd786b2 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -20,6 +20,10 @@ LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
USES= gmake libtool pkgconfig tar:xz
+.if !defined(_BUILDING_LIGHTTPD_MODULE)
+USES+= cpe
+.endif
+
USE_AUTOTOOLS= autoconf autoheader aclocal automake
AUTOMAKE_ARGS= -a -c -f
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/lighttpd