aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2022-12-09 17:02:29 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2022-12-09 17:06:53 +0000
commit73084fa85ffdf454d0a1348d17a6e772c22e7b28 (patch)
tree36e599515d93e912e7bf4319128a33977c9c8c01
parent9671e42b93fb8f1cf8e8e53d8253348479979b3c (diff)
downloadports-73084fa85ffdf454d0a1348d17a6e772c22e7b28.tar.gz
ports-73084fa85ffdf454d0a1348d17a6e772c22e7b28.zip
sysutils/pftop: Fix build with clang 15
PR: 268209
-rw-r--r--sysutils/pftop/Makefile1
-rw-r--r--sysutils/pftop/files/extra-patch-pftop.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index 9794f4a81acf..73cf4707a070 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pftop
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= sysutils net
MAINTAINER= grembo@FreeBSD.org
diff --git a/sysutils/pftop/files/extra-patch-pftop.c b/sysutils/pftop/files/extra-patch-pftop.c
index 0ce7c8ffd2b4..e22198745b33 100644
--- a/sysutils/pftop/files/extra-patch-pftop.c
+++ b/sysutils/pftop/files/extra-patch-pftop.c
@@ -343,7 +343,7 @@ $OpenBSD: patch-pftop_c,v 1.12 2009/12/02 21:16:10 sthen Exp $
#endif
#ifdef HAVE_RULE_STATES
+#ifdef HAVE_PFSYNC_KEY
-+ print_fld_size(FLD_STATS, pr->states_tot);
++ print_fld_size(FLD_STATS, *pr->states_tot);
+#else
print_fld_size(FLD_STATS, pr->states);
#endif