aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-03-10 23:19:27 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-03-11 05:52:33 +0000
commit731a1350fde4a5efe0cc5141f0c64dbbc9ff770f (patch)
tree7a4db9b08d5b86bc13872de527f6a44bce604966
parent5cfd193e26487d4e7bbac792a62e237c436d922e (diff)
downloadports-731a1350fde4a5efe0cc5141f0c64dbbc9ff770f.tar.gz
ports-731a1350fde4a5efe0cc5141f0c64dbbc9ff770f.zip
graphics/yacreader: prefer Qt6 after 163e26d8c6d7
-rw-r--r--graphics/yacreader/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/yacreader/Makefile b/graphics/yacreader/Makefile
index ef18f42a7726..bcd20e93a9ab 100644
--- a/graphics/yacreader/Makefile
+++ b/graphics/yacreader/Makefile
@@ -1,6 +1,6 @@
PORTNAME= yacreader
DISTVERSION= 9.14.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MAINTAINER= jbeich@FreeBSD.org
@@ -10,21 +10,21 @@ WWW= https://www.yacreader.com/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-FLAVORS= qt5 qt6
+FLAVORS= qt6 qt5
-USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake qt:5
+USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake qt:6
USE_GITHUB= yes
+USE_QT= 5compat base declarative multimedia svg tools:build
+
+.if ${FLAVOR:U} == qt5
+PKGNAMESUFFIX= -${FLAVOR}
+USES:= ${USES:S/qt:6/qt:5/}
USE_QT= qmake:build buildtools:build core concurrent:build declarative \
gui linguisttools:build multimedia network quickcontrols2 \
sql sql-sqlite3:run svg testlib:build widgets
-
-.if ${FLAVOR:U} == qt6
-PKGNAMESUFFIX= -${FLAVOR}
-USES:= ${USES:S/qt:5/qt:6/}
-USE_QT= 5compat base declarative multimedia svg tools:build
CONFLICTS_INSTALL= ${PORTNAME}
.else
-CONFLICTS_INSTALL= ${PORTNAME}-qt6
+CONFLICTS_INSTALL= ${PORTNAME}-qt5
.endif
OPTIONS_DEFINE= ARCHIVE OPENGL POPPLER