aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-03-01 18:47:07 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-03-01 18:47:07 +0000
commit73643406704f7bb612a7b178fa4426e2705aa17b (patch)
tree55cf50ce3d78e18d1307f9a44fea98a800ad3476
parentc9bdb0ca7d0fc6cec1d815d3d9b8e1d68888083a (diff)
downloadports-73643406704f7bb612a7b178fa4426e2705aa17b.tar.gz
ports-73643406704f7bb612a7b178fa4426e2705aa17b.zip
devel/love5: fix build on ARM / POWER
Add -fsigned-char to fix build. c++ -DPACKAGE_NAME=\"love\" -DPACKAGE_TARNAME=\"love\" -DPACKAGE_VERSION=\"0.5-0\" -DPACKAGE_STRING=\"love\ 0.5-0\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"love\" -DVERSION=\"0.5-0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -I. -I/usr/include/freetype2 -I/usr/include/lua-5.1 -I/usr/include/SDL -Iliblove/include -Ibox2d/Include -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include/lua51 -I/usr/local/include/SDL -I/usr/local/include -D_REENTRANT -D_THREAD_SAFE -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -MT opengl/resources.o -MD -MP -MF $depbase.Tpo -c -o opengl/resources.o opengl/resources.cpp &&\ mv -f $depbase.Tpo $depbase.Po opengl/resources.cpp:5:76: error: constant expression evaluates to -76 which cannot be narrowed to type 'char' [-Wc++11-narrowing] static char Vera_ttf_data[65932] = {0,1,0,0,0,17,1,0,0,4,0,16,79,83,47,50,-76,95,-12,99,0,0,-21,112,0,0,0,86,80,67,76, ^~~
-rw-r--r--devel/love5/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/love5/Makefile b/devel/love5/Makefile
index 5778dec677a6..bb5e82aa7c11 100644
--- a/devel/love5/Makefile
+++ b/devel/love5/Makefile
@@ -19,6 +19,7 @@ USE_GL= gl glu
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
-I${LUA_INCDIR} `${SDL_CONFIG} --cflags`
+CXXFLAGS+= -fsigned-char
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib \
--program-suffix=5