aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-26 23:51:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-26 23:51:37 +0000
commit737dbbb2a6a3349ef807fe091aa543311fe46632 (patch)
treeb3c9f901f5cda1227eeca15468916f11732c24f6
parente2641662d618fe725aa4539a3a2a0830383114ba (diff)
downloadports-737dbbb2a6a3349ef807fe091aa543311fe46632.tar.gz
ports-737dbbb2a6a3349ef807fe091aa543311fe46632.zip
graphics/matplotplusplus: New port: C++ graphics library for data visualization
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/matplotplusplus/Makefile27
-rw-r--r--graphics/matplotplusplus/distinfo3
-rw-r--r--graphics/matplotplusplus/pkg-descr10
-rw-r--r--graphics/matplotplusplus/pkg-plist48
5 files changed, 89 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9426d2d081d8..ead72b211277 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -542,6 +542,7 @@
SUBDIR += mapcache
SUBDIR += mapserver
SUBDIR += mapyrus
+ SUBDIR += matplotplusplus
SUBDIR += megapov
SUBDIR += meh
SUBDIR += mesa-demos
diff --git a/graphics/matplotplusplus/Makefile b/graphics/matplotplusplus/Makefile
new file mode 100644
index 000000000000..44a0a3a7919b
--- /dev/null
+++ b/graphics/matplotplusplus/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= matplotplusplus
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.0
+CATEGORIES= graphics devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ graphics library for data visualization
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfftw3.so:math/fftw3 \
+ libfftw3f.so:math/fftw3-float \
+ libopenblas.so:math/openblas \
+ libpng16.so:graphics/png \
+ libtiff.so:graphics/tiff
+RUN_DEPENDS= gnuplot:math/gnuplot
+
+USES= cmake compiler:c++17-lang jpeg
+
+USE_GITHUB= yes
+GH_ACCOUNT= alandefreitas
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_TESTS
+
+.include <bsd.port.mk>
diff --git a/graphics/matplotplusplus/distinfo b/graphics/matplotplusplus/distinfo
new file mode 100644
index 000000000000..4e0643680726
--- /dev/null
+++ b/graphics/matplotplusplus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643233092
+SHA256 (alandefreitas-matplotplusplus-v1.1.0_GH0.tar.gz) = 5c3a1bdfee12f5c11fd194361040fe4760f57e334523ac125ec22b2cb03f27bb
+SIZE (alandefreitas-matplotplusplus-v1.1.0_GH0.tar.gz) = 38996293
diff --git a/graphics/matplotplusplus/pkg-descr b/graphics/matplotplusplus/pkg-descr
new file mode 100644
index 000000000000..c0ca48a4d544
--- /dev/null
+++ b/graphics/matplotplusplus/pkg-descr
@@ -0,0 +1,10 @@
+Matplot++ is a graphics library for data visualization that provides
+interactive plotting, means for exporting plots in high-quality
+formats for scientific publications, a compact syntax consistent with
+similar libraries, dozens of plot categories with specialized
+algorithms, multiple coding styles, and supports generic backends.
+
+Matplot++ renders graphics using gnuplot and shows graphics in
+gnuplot standalone windows.
+
+WWW: https://alandefreitas.github.io/matplotplusplus/
diff --git a/graphics/matplotplusplus/pkg-plist b/graphics/matplotplusplus/pkg-plist
new file mode 100644
index 000000000000..623d23cca5c7
--- /dev/null
+++ b/graphics/matplotplusplus/pkg-plist
@@ -0,0 +1,48 @@
+include/matplot/axes_objects/bars.h
+include/matplot/axes_objects/box_chart.h
+include/matplot/axes_objects/circles.h
+include/matplot/axes_objects/contours.h
+include/matplot/axes_objects/error_bar.h
+include/matplot/axes_objects/filled_area.h
+include/matplot/axes_objects/function_line.h
+include/matplot/axes_objects/histogram.h
+include/matplot/axes_objects/labels.h
+include/matplot/axes_objects/line.h
+include/matplot/axes_objects/matrix.h
+include/matplot/axes_objects/network.h
+include/matplot/axes_objects/parallel_lines.h
+include/matplot/axes_objects/stair.h
+include/matplot/axes_objects/string_function.h
+include/matplot/axes_objects/surface.h
+include/matplot/axes_objects/vectors.h
+include/matplot/backend/backend_interface.h
+include/matplot/backend/backend_registry.h
+include/matplot/backend/gnuplot.h
+include/matplot/backend/opengl.h
+include/matplot/backend/opengl_embed.h
+include/matplot/core/axes_object.h
+include/matplot/core/axes_type.h
+include/matplot/core/axis_type.h
+include/matplot/core/figure_registry.h
+include/matplot/core/figure_type.h
+include/matplot/core/legend.h
+include/matplot/core/line_spec.h
+include/matplot/freestanding/axes_functions.h
+include/matplot/freestanding/axes_lim.h
+include/matplot/freestanding/figure_functions.h
+include/matplot/freestanding/histcounts.h
+include/matplot/freestanding/plot.h
+include/matplot/matplot.h
+include/matplot/util/colors.h
+include/matplot/util/common.h
+include/matplot/util/concepts.h
+include/matplot/util/contourc.h
+include/matplot/util/geodata.h
+include/matplot/util/handle_types.h
+include/matplot/util/keywords.h
+include/matplot/util/popen.h
+include/matplot/util/type_traits.h
+lib/cmake/Matplot++/Matplot++Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Matplot++/Matplot++Targets.cmake
+lib/cmake/Matplot++/matplot++-config.cmake
+lib/libmatplot.so