aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 18:39:56 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:48 +0000
commit73ab07c25a09345a265680ab55de2e5cebebcd6a (patch)
treef14226135156f3e90a36ba5e8269d2579a7bafc3
parent15e60bd31ebaf401bf1e71bd90ea6232fb3b6d72 (diff)
downloadports-73ab07c25a09345a265680ab55de2e5cebebcd6a.tar.gz
ports-73ab07c25a09345a265680ab55de2e5cebebcd6a.zip
chase library renames for OpenEXR/Imath 3.0
-rw-r--r--cad/PrusaSlicer/Makefile4
-rw-r--r--devel/synfig/Makefile6
-rw-r--r--editors/calligra/Makefile6
-rw-r--r--graphics/enblend/Makefile4
-rw-r--r--graphics/exrtools/Makefile6
-rw-r--r--graphics/fyre/Makefile4
-rw-r--r--graphics/gimp-app/Makefile4
-rw-r--r--graphics/gimp-gmic-plugin/Makefile4
-rw-r--r--graphics/gmic/Makefile5
-rw-r--r--graphics/hdr_tools/Makefile4
-rw-r--r--graphics/nvidia-texture-tools/Makefile4
-rw-r--r--graphics/opencv/Makefile4
-rw-r--r--graphics/photoflow/Makefile5
-rw-r--r--graphics/synfigstudio/Makefile6
-rw-r--r--graphics/vips/Makefile6
-rw-r--r--math/curv/Makefile2
16 files changed, 37 insertions, 37 deletions
diff --git a/cad/PrusaSlicer/Makefile b/cad/PrusaSlicer/Makefile
index b3daaed3fed6..9161dfdb072d 100644
--- a/cad/PrusaSlicer/Makefile
+++ b/cad/PrusaSlicer/Makefile
@@ -1,7 +1,7 @@
PORTNAME= PrusaSlicer
DISTVERSIONPREFIX=version_
DISTVERSION= 2.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MAINTAINER= teodorsigaev@gmail.com
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libtbb.so:devel/tbb \
libboost_log.so:devel/boost-libs \
- libHalf.so:graphics/ilmbase \
+ libImath.so:math/Imath \
libnlopt.so:math/nlopt \
libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
diff --git a/devel/synfig/Makefile b/devel/synfig/Makefile
index fdc6ea1aa843..011937a99a5c 100644
--- a/devel/synfig/Makefile
+++ b/devel/synfig/Makefile
@@ -3,7 +3,7 @@
PORTNAME= synfig
PORTVERSION= 1.2.2
DISTVERSIONPREFIX=v
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= devel graphics multimedia
MAINTAINER= woodsb02@FreeBSD.org
@@ -13,8 +13,8 @@ LICENSE= GPLv2+
BUILD_DEPENDS= etl>=1.2.2:devel/etl \
gsed:textproc/gsed
-LIB_DEPENDS= libHalf.so:graphics/ilmbase \
- libIlmImf.so:graphics/openexr \
+LIB_DEPENDS= libImath.so:math/Imath \
+ libOpenEXR.so:graphics/openexr \
libMagickWand-6.so:graphics/ImageMagick6 \
libavcodec.so:multimedia/ffmpeg \
libboost_program_options.so:devel/boost-libs \
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 4e2ed1966f4e..a3afa71e89d1 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -1,6 +1,6 @@
PORTNAME= calligra
DISTVERSION= 3.2.1
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= editors kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -11,7 +11,7 @@ COMMENT= KDE office suite
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libImath.so:graphics/ilmbase \
+LIB_DEPENDS= libImath.so:math/Imath \
libKPropertyCore3.so:x11-toolkits/kproperty \
libKReport3.so:textproc/kreport \
libboost_thread.so:devel/boost-libs \
@@ -56,7 +56,7 @@ USE_LDCONFIG= yes
OPTIONS_DEFINE= OPENEXR
OPTIONS_DEFAULT= OPENEXR
-OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr
+OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr
OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index b140a7936c69..83dad623cc6e 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -2,7 +2,7 @@
PORTNAME= enblend
PORTVERSION= 4.2
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= graphics
MASTER_SITES= SF/enblend/enblend-enfuse/enblend-enfuse-${PORTVERSION}
DISTNAME= enblend-enfuse-${PORTVERSION}
@@ -19,7 +19,7 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libtiff.so:graphics/tiff \
libvigraimpex.so:graphics/vigra \
libgsl.so:math/gsl \
- libIlmImf.so:graphics/openexr \
+ libOpenEXR.so:graphics/openexr \
libpng.so:graphics/png
USES= compiler:features gmake jpeg localbase pkgconfig
diff --git a/graphics/exrtools/Makefile b/graphics/exrtools/Makefile
index e92fb4d05b3c..2b3a41f4ddfd 100644
--- a/graphics/exrtools/Makefile
+++ b/graphics/exrtools/Makefile
@@ -2,7 +2,7 @@
PORTNAME= exrtools
PORTVERSION= 0.4
-PORTREVISION= 24
+PORTREVISION= 25
CATEGORIES= graphics
MASTER_SITES= http://scanline.ca/exrtools/ \
LOCAL/ehaupt
@@ -12,9 +12,9 @@ COMMENT= Utilities for manipulating with HDR images in OpenEXR format
LICENSE= GPLv2
-LIB_DEPENDS= libImath.so:graphics/ilmbase \
+LIB_DEPENDS= libImath.so:math/Imath \
libpng.so:graphics/png \
- libIlmImf.so:graphics/openexr
+ libOpenEXR.so:graphics/openexr
USES= compiler:c++11-lang gmake jpeg localbase:ldflags pkgconfig
diff --git a/graphics/fyre/Makefile b/graphics/fyre/Makefile
index 2bde34a21360..a104b0a1ef4a 100644
--- a/graphics/fyre/Makefile
+++ b/graphics/fyre/Makefile
@@ -2,7 +2,7 @@
PORTNAME= fyre
PORTVERSION= 1.0.1
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= graphics
MASTER_SITES= http://releases.navi.cx/fyre/
@@ -22,7 +22,7 @@ OPTIONS_DEFINE= OPTIMIZED_CFLAGS OPENEXR GNET DOCS
OPTIONS_DEFAULT= OPENEXR GNET
OPENEXR_CONFIGURE_ENABLE= openexr
-OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr
+OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr
GNET_DESC= Networking support via GNet
GNET_CONFIGURE_ENABLE= gnet
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 4083df205b43..7b9b94bb1791 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -2,6 +2,7 @@
PORTNAME?= gimp-app
PORTVERSION= 2.10.24
+PORTREVISION= 1
PORTEPOCH?= 1
CATEGORIES?= graphics gnome
MASTER_SITES= GIMP/gimp/v${PORTVERSION:R}
@@ -116,8 +117,7 @@ LIBMNG_LIB_DEPENDS= libmng.so:graphics/libmng
LIBMNG_CONFIGURE_WITH= libmng
OPENEXR_CONFIGURE_WITH= openexr
-OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr \
- libIex.so:graphics/ilmbase
+OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr
OPENJPEG_DESC= Enhanced JPEG (jpeg2000) graphics support
OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index 8e43a2c6b5f5..a1b9c580c116 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gmic
PORTVERSION= 1.6.9
-PORTREVISION= 30
+PORTREVISION= 31
CATEGORIES= graphics
MASTER_SITES= http://gmic.eu/files/source/
PKGNAMEPREFIX= gimp-
@@ -13,7 +13,7 @@ COMMENT= GREYC's Magic Image Converter
BROKEN= OpenCV4 no longer ships OpencCV-1.0 headers
LIB_DEPENDS= libGraphicsMagick++.so:graphics/GraphicsMagick \
- libIlmImf.so:graphics/openexr \
+ libOpenEXR.so:graphics/openexr \
libopencv_video.so:graphics/opencv \
libMagick++-6.so:graphics/ImageMagick6 \
libavcodec.so:multimedia/ffmpeg \
diff --git a/graphics/gmic/Makefile b/graphics/gmic/Makefile
index 910e85ee9179..95ae05e26c1b 100644
--- a/graphics/gmic/Makefile
+++ b/graphics/gmic/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gmic
DISTVERSION= 2.9.6
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= https://gmic.eu/files/source/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -17,8 +18,8 @@ BROKEN_i386= error: "c++ crashes, clang-5 and 6 fail: undefined reference to `__
LIB_DEPENDS= libcurl.so:ftp/curl \
libfftw3.so:math/fftw3 \
libGraphicsMagick++.so:graphics/GraphicsMagick \
- libIlmImf.so:graphics/openexr \
- libImath.so:graphics/ilmbase \
+ libOpenEXR.so:graphics/openexr \
+ libImath.so:math/Imath \
libopencv_core.so:graphics/opencv \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
diff --git a/graphics/hdr_tools/Makefile b/graphics/hdr_tools/Makefile
index eec097847201..180f6a239f6f 100644
--- a/graphics/hdr_tools/Makefile
+++ b/graphics/hdr_tools/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hdr_tools
PORTVERSION= 0.0.2010.11.23 # unspecified by the author, so use the date
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= graphics
MASTER_SITES= http://ttic.uchicago.edu/~cotter/projects/hdr_tools/archives/ \
http://freebsd.nsu.ru/distfiles/
@@ -15,7 +15,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libpopt.so:devel/popt \
libtiff.so:graphics/tiff \
- libIlmImf.so:graphics/openexr \
+ libOpenEXR.so:graphics/openexr \
libMagick++-6.so:graphics/ImageMagick6
USES= compiler:c++11-lang gmake pkgconfig tar:tgz
diff --git a/graphics/nvidia-texture-tools/Makefile b/graphics/nvidia-texture-tools/Makefile
index adb85424b8dc..bbfbcf509abf 100644
--- a/graphics/nvidia-texture-tools/Makefile
+++ b/graphics/nvidia-texture-tools/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nvidia-texture-tools
PORTVERSION= 2.0.8.1 # needed to not bump PORTEPOCH; remove on next update
-PORTREVISION= 21
+PORTREVISION= 22
CATEGORIES= graphics
MAINTAINER= amdmi3@FreeBSD.org
@@ -14,7 +14,7 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 powerpc64le
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
- libIlmImf.so:graphics/openexr
+ libOpenEXR.so:graphics/openexr
USE_GITHUB= yes
GH_ACCOUNT= castano
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 4b8bf4586d9d..54fd430557f7 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -1,6 +1,6 @@
PORTNAME= opencv
DISTVERSION= 4.5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MAINTAINER= tcberner@FreeBSD.org
@@ -13,7 +13,7 @@ BUILD_DEPENDS= vulkan-headers>0:graphics/vulkan-headers \
opencl>=0:devel/opencl
RUN_DEPENDS= opencl>=0:devel/opencl
LIB_DEPENDS= \
- libIlmImf.so:graphics/openexr \
+ libOpenEXR.so:graphics/openexr \
libavcodec.so:multimedia/ffmpeg \
libfreetype.so:print/freetype2 \
libgflags.so:devel/gflags \
diff --git a/graphics/photoflow/Makefile b/graphics/photoflow/Makefile
index c997598f441e..003f5d8e3391 100644
--- a/graphics/photoflow/Makefile
+++ b/graphics/photoflow/Makefile
@@ -1,6 +1,6 @@
PORTNAME= photoflow
DISTVERSION= 0.2.8.20200828
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MAINTAINER= yuri@FreeBSD.org
@@ -15,8 +15,7 @@ LIB_DEPENDS= libexiv2.so:graphics/exiv2 \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
libiptcdata.so:graphics/libiptcdata \
- libIex.so:graphics/ilmbase \
- libIlmImf.so:graphics/openexr \
+ libOpenEXR.so:graphics/openexr \
liblcms2.so:graphics/lcms2 \
liblensfun.so:graphics/lensfun \
libtiff.so:graphics/tiff \
diff --git a/graphics/synfigstudio/Makefile b/graphics/synfigstudio/Makefile
index d9d0ca91bc9d..a89bdf371618 100644
--- a/graphics/synfigstudio/Makefile
+++ b/graphics/synfigstudio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= synfigstudio
PORTVERSION= 1.2.2
DISTVERSIONPREFIX=v
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= graphics multimedia
MAINTAINER= woodsb02@FreeBSD.org
@@ -13,8 +13,8 @@ LICENSE= GPLv2+
BUILD_DEPENDS= etl>=1.2.2:devel/etl \
gsed:textproc/gsed
-LIB_DEPENDS= libHalf.so:graphics/ilmbase \
- libIlmImf.so:graphics/openexr \
+LIB_DEPENDS= libImath.so:math/Imath \
+ libOpenEXR.so:graphics/openexr \
libMagick++-6.so:graphics/ImageMagick6 \
libfftw3.so:math/fftw3 \
libfontconfig.so:x11-fonts/fontconfig \
diff --git a/graphics/vips/Makefile b/graphics/vips/Makefile
index 85502b8e5b5d..e6801f4a80e4 100644
--- a/graphics/vips/Makefile
+++ b/graphics/vips/Makefile
@@ -2,7 +2,7 @@
PORTNAME= vips
PORTVERSION= 8.10.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= https://github.com/libvips/libvips/releases/download/v${PORTVERSION}/
@@ -65,8 +65,8 @@ LCMS2_CONFIGURE_WITH= lcms
LCMS2_LIB_DEPENDS= liblcms2.so:graphics/lcms2
OPENEXR_CONFIGURE_WITH= OpenEXR
-OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr \
- libImath.so:graphics/ilmbase
+OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr \
+ libImath.so:math/Imath
HEIF_DESC= HEIF image format support
HEIF_CONFIGURE_WITH= heif
diff --git a/math/curv/Makefile b/math/curv/Makefile
index 046d2fed4e61..57e4e076b23a 100644
--- a/math/curv/Makefile
+++ b/math/curv/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= glm>0:math/glm
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libdouble-conversion.so:devel/double-conversion \
libglfw.so:graphics/glfw \
- libHalf.so:graphics/ilmbase \
+ libImath.so:math/Imath \
libopenvdb.so:misc/openvdb \
libtbb.so:devel/tbb