aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-09-13 18:58:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-09-13 18:58:29 +0000
commit73f610542bed9341956183f672237a6189a126f1 (patch)
treea50be0873cba839097680b09ebfa46539c31cd4f
parentd59c43836a66a3f4b508193270ad00bd3ad8dbba (diff)
downloadports-73f610542bed9341956183f672237a6189a126f1.tar.gz
ports-73f610542bed9341956183f672237a6189a126f1.zip
Enforce unicode version of wxGTK
Notes
Notes: svn path=/head/; revision=396852
-rw-r--r--devel/codeblocks/Makefile2
-rw-r--r--editors/madedit/Makefile2
-rw-r--r--games/glest/Makefile2
-rw-r--r--games/vavoom/Makefile9
-rw-r--r--graphics/libreatlas/Makefile2
-rw-r--r--math/py-matplotlib/Makefile1
-rw-r--r--math/wxMaxima/Makefile2
-rw-r--r--multimedia/libkate/Makefile1
-rw-r--r--net-p2p/amule-devel/Makefile13
-rw-r--r--security/webshag/Makefile1
10 files changed, 17 insertions, 18 deletions
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index 4af8b0c08f6e..190768826a29 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
USES= compiler desktop-file-utils fam:gamin libtool pathfix \
pkgconfig shared-mime-info
USE_WX= 2.8
-WANT_UNICODE= yes
+WX_UNICODE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG} --with-contrib-plugins=all \
--disable-pch
diff --git a/editors/madedit/Makefile b/editors/madedit/Makefile
index caf1679430a2..5ebbb3f74e21 100644
--- a/editors/madedit/Makefile
+++ b/editors/madedit/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
USES= gettext pkgconfig dos2unix desktop-file-utils
USE_WX= 2.8+
-WANT_UNICODE= yes
+WX_UNICODE= yes
USE_XORG= x11
GNU_CONFIGURE= yes
diff --git a/games/glest/Makefile b/games/glest/Makefile
index e241eeceacaf..69aefdf6939a 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -40,7 +40,7 @@ EXTRACT_AFTER_ARGS= -d ${WRKDIR}/${DISTNAME}
.if ${PORT_OPTIONS:MEDITOR}
USE_WX= 2.6+
WX_CONF_ARGS= relative
-WANT_UNICODE= yes
+WX_UNICODE= yes
HAVE_EDITOR= true
.endif
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 9c7f4f5631cc..5e26adcebcf7 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vavoom
PORTVERSION= 1.33
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Vavoom-source/${PORTVERSION}
@@ -19,12 +19,11 @@ DOS2UNIX_REGEX= ((.*\.(c|cpp|h|s|asm|inc|vc|ls|acs|cfg|txt|vs|mak|mgw"))$$|\/(ma
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL WXUNICODE DOCS
-OPTIONS_DEFAULT= OPENGL SDL WXUNICODE
+OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
+OPTIONS_DEFAULT= OPENGL SDL
LAUNCHER_DESC= Build GUI launcher
OPENAL_DESC= Enable OpenAL support
SDL_DESC= Use SDL for OpenGL support
-WXUNICODE_DESC= Enable Unicode support
SUB_FILES= pkg-message
@@ -44,6 +43,7 @@ CMAKE_ARGS+= -DWITH_FLAC=N
.if ${PORT_OPTIONS:MLAUNCHER}
USE_WX= 2.8+
+WX_UNICODE= yes
CMAKE_ARGS+= -DENABLE_LAUNCHER=Y \
-DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
PLIST_SUB+= LAUNCHER=""
@@ -95,7 +95,6 @@ CMAKE_ARGS+= -DWITH_OPENGL=N
.endif
.if ${PORT_OPTIONS:MWXUNICODE}
-WX_UNICODE=yes
.endif
post-patch:
diff --git a/graphics/libreatlas/Makefile b/graphics/libreatlas/Makefile
index 0f13f6762808..6ba2ac8fe10a 100644
--- a/graphics/libreatlas/Makefile
+++ b/graphics/libreatlas/Makefile
@@ -36,7 +36,7 @@ USE_XORG= ice pixman sm x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xrandr xrender xxf86vm
USE_GNOME= atk gdkpixbuf2 glib20 gtk20 pango
USE_WX= 2.8
-WANT_UNICODE= yes
+WX_UNICODE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 3c15c38e5a7c..44ab1dcbcdfc 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -83,6 +83,7 @@ PLIST_SUB+= TKAGGBACKEND="@comment "
.if ${PORT_OPTIONS:MWXAGGBACKEND}
USE_WX= 2.8+
WX_COMPS= python:lib
+WX_UNICODE= yes
CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
WXAGG_BACKEND= True
diff --git a/math/wxMaxima/Makefile b/math/wxMaxima/Makefile
index cb446e31420b..76420b0390ea 100644
--- a/math/wxMaxima/Makefile
+++ b/math/wxMaxima/Makefile
@@ -24,7 +24,7 @@ PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
USES= desktop-file-utils gettext
USE_WX= 2.8
-WANT_UNICODE= yes
+WX_UNICODE= yes
WRKSRC= ${WRKDIR}/${PORTNAME:tl}-${PORTVERSION}
WX_COMPS= wx
WX_CONF_ARGS= absolute
diff --git a/multimedia/libkate/Makefile b/multimedia/libkate/Makefile
index e6f3de912ad9..69a855d7438e 100644
--- a/multimedia/libkate/Makefile
+++ b/multimedia/libkate/Makefile
@@ -42,6 +42,7 @@ CONFIGURE_ARGS+= --disable-doc
RUN_DEPENDS= ${LOCALBASE}/bin/oggz:${PORTSDIR}/audio/liboggz
USES+= python
USE_WX= 2.8
+WX_UNICODE= yes
WX_COMPS= wx contrib python:lib
MANPAGE+= KateDJ.1
PLIST_SUB+= KATEDJ=""
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index 43ffe63ed9f9..5acbf0fdf4cd 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= amule
PORTVERSION= 10834
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-p2p
MASTER_SITES= http://amule.sourceforge.net/tarballs/
PKGNAMESUFFIX= -devel
@@ -24,6 +24,8 @@ USES= bison gmake pkgconfig perl5 shebangfix tar:bzip2 \
USE_PERL5= build
USE_WX= 2.8
WX_CONF_ARGS= absolute
+WX_UNICODE= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-denoise-level=0
@@ -35,7 +37,7 @@ LDFLAGS+= -lpthread -L${LOCALBASE}/lib
OPTIONS_DEFINE= ALC ALCC AMULECMD AMULEDAEMON AMULEGUI CAS DEBUG DOCS ED2K \
FILEVIEW GEOIP MMAP MONOLITHIC NLS OPTIMIZED_CFLAGS PLASMAMULE UPNP \
- WEBSERVER WXCAS WXUNICODE XAS
+ WEBSERVER WXCAS XAS
ALC_DESC= Compile aMule Link Creator for GUI
ALCC_DESC= Compile aMule Link Creator for console
AMULECMD_DESC= Compile aMule command line client
@@ -48,10 +50,9 @@ MMAP_DESC= Use mapped memory
MONOLITHIC_DESC= Compile monolithic aMule
PLASMAMULE_DESC= Compile aMule plasma applet and engine
WXCAS_DESC= Compile aMule Statistics for GUI
-WXUNICODE_DESC= Unicode support
XAS_DESC= Install XChat2 plugin
OPTIONS_DEFAULT=ALC ALCC AMULECMD AMULEDAEMON AMULEGUI CAS ED2K \
- FILEVIEW MONOLITHIC WEBSERVER WXCAS WXUNICODE XAS
+ FILEVIEW MONOLITHIC WEBSERVER WXCAS XAS
OPTIONS_SUB= yes
@@ -120,10 +121,6 @@ CONFLICTS+= ed2k-hash*
CONFIGURE_ARGS+= --enable-optimize
.endif
-.if ${PORT_OPTIONS:MWXUNICODE}
-WX_UNICODE= yes
-.endif
-
post-patch: .SILENT
${REINPLACE_CMD} -e 's/test.*-print-file-name.*`/true/' \
-e '/if.*test/s/==/=/' \
diff --git a/security/webshag/Makefile b/security/webshag/Makefile
index 549131fb5b17..5dbe877b0736 100644
--- a/security/webshag/Makefile
+++ b/security/webshag/Makefile
@@ -29,6 +29,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
.if ${PORT_OPTIONS:MWXGTK}
USE_WX= 2.6+
+WX_UNICODE= yes
WX_COMPS= python:run
.endif