aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-03-24 17:00:17 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-03-24 18:23:25 +0000
commit747f0ed37d67d247825e861df9581ddf5ebb2e97 (patch)
treea0e8d8e7b49b3c4eeed31cd204757081ad97266e
parent9fc3b59703eb091358732838100f729ef93bd1f5 (diff)
downloadports-747f0ed37d67d247825e861df9581ddf5ebb2e97.tar.gz
ports-747f0ed37d67d247825e861df9581ddf5ebb2e97.zip
*/php: Switch dependency of tidy
As tidy-lib has been deprecated switch the dependencies of php8*-tidy to www/tidy-html5.
-rw-r--r--lang/php81/Makefile2
-rw-r--r--lang/php82/Makefile2
-rw-r--r--lang/php83/Makefile2
-rw-r--r--www/php81-tidy/Makefile1
-rw-r--r--www/php82-tidy/Makefile1
-rw-r--r--www/php83-tidy/Makefile1
6 files changed, 6 insertions, 3 deletions
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 49e612fc4c63..5e614b7d0118 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -553,7 +553,7 @@ CONFIGURE_ARGS+= --enable-sysvshm
.if ${PHP_MODNAME} == "tidy"
CONFIGURE_ARGS+= --with-tidy=${LOCALBASE}
-LIB_DEPENDS+= libtidy.so:www/tidy-lib
+LIB_DEPENDS+= libtidy5.so:www/tidy-html5
.endif
.if ${PHP_MODNAME} == "tokenizer"
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index 9cbfd125de7e..d369b5e27e4c 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -546,7 +546,7 @@ CONFIGURE_ARGS+= --enable-sysvshm
.if ${PHP_MODNAME} == "tidy"
CONFIGURE_ARGS+= --with-tidy=${LOCALBASE}
-LIB_DEPENDS+= libtidy.so:www/tidy-lib
+LIB_DEPENDS+= libtidy5.so:www/tidy-html5
.endif
.if ${PHP_MODNAME} == "tokenizer"
diff --git a/lang/php83/Makefile b/lang/php83/Makefile
index 4cbf72fe137a..50dc521cbac7 100644
--- a/lang/php83/Makefile
+++ b/lang/php83/Makefile
@@ -564,7 +564,7 @@ CONFIGURE_ARGS+= --enable-sysvshm
.if ${PHP_MODNAME} == "tidy"
CONFIGURE_ARGS+= --with-tidy=${LOCALBASE}
-LIB_DEPENDS+= libtidy.so:www/tidy-lib
+LIB_DEPENDS+= libtidy5.so:www/tidy-html5
.endif
.if ${PHP_MODNAME} == "tokenizer"
diff --git a/www/php81-tidy/Makefile b/www/php81-tidy/Makefile
index 9b3aed822ddb..e5d423609516 100644
--- a/www/php81-tidy/Makefile
+++ b/www/php81-tidy/Makefile
@@ -1,3 +1,4 @@
+PORTREVISION= 1
CATEGORIES= www
MASTERDIR= ${.CURDIR}/../../lang/php81
diff --git a/www/php82-tidy/Makefile b/www/php82-tidy/Makefile
index 3f907ae319b4..cd2825d897fc 100644
--- a/www/php82-tidy/Makefile
+++ b/www/php82-tidy/Makefile
@@ -1,3 +1,4 @@
+PORTREVISION= 1
CATEGORIES= www
MASTERDIR= ${.CURDIR}/../../lang/php82
diff --git a/www/php83-tidy/Makefile b/www/php83-tidy/Makefile
index ee01c71c663a..b7d1a33160c5 100644
--- a/www/php83-tidy/Makefile
+++ b/www/php83-tidy/Makefile
@@ -1,3 +1,4 @@
+PORTEVISION= 1
CATEGORIES= www
MASTERDIR= ${.CURDIR}/../../lang/php83