aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 15:05:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 15:38:53 +0000
commit74ac6153b61beabb5ef443287e52fe3e12879e6f (patch)
treec1c454414a138c6d660c709c380629d706a7bab6
parent07f25c9c9f5bcca469999a0458092376ba5a41be (diff)
downloadports-74ac6153b61beabb5ef443287e52fe3e12879e6f.tar.gz
ports-74ac6153b61beabb5ef443287e52fe3e12879e6f.zip
net/py-smbpasswd: Fix build on llvm15
- Pet portclippy - Adopt port
-rw-r--r--net/py-smbpasswd/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/net/py-smbpasswd/Makefile b/net/py-smbpasswd/Makefile
index 2c56a531d8a0..4c1bf8132bbc 100644
--- a/net/py-smbpasswd/Makefile
+++ b/net/py-smbpasswd/Makefile
@@ -2,11 +2,10 @@ PORTNAME= smbpasswd
PORTVERSION= 1.0.2
PORTREVISION= 1
CATEGORIES= net python
-MASTER_SITES= http://barryp.org/static/media/software/download/py-${PORTNAME}/${PORTVERSION}/ \
- PYPI
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= SMB/CIFS password generation utility for Python
WWW= https://barryp.org/software/py-smbpasswd
@@ -16,4 +15,10 @@ LICENSE= GPLv2
USES= python:3.6+ tar:tgz
USE_PYTHON= autoplist distutils
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
+.include <bsd.port.post.mk>