aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-12-16 01:56:14 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-12-16 22:44:28 +0000
commit74b5dc56e7a548066a1ece1dc32b6cb0e6df33b8 (patch)
treefb382b906d689301837523785d623578acb8b8c0
parent492294aea03406668e144d17f22041cb5310323a (diff)
downloadports-74b5dc56e7a548066a1ece1dc32b6cb0e6df33b8.tar.gz
ports-74b5dc56e7a548066a1ece1dc32b6cb0e6df33b8.zip
devel/build2: Fix build on i386
The powerpc build progresses much further with the same flag set, but now segfaults when the do-install target is run. ===> Staging for build2-0.16.0 ===> Generating temporary packing list Invalid data memory access: 0xf2e018b8 Invalid data memory access: 0x81390500 Invalid data memory access: 0x00000048 *** Signal 11 Approved by: portmgr (blanket)
-rw-r--r--devel/build2/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/build2/Makefile b/devel/build2/Makefile
index 2484ed3bba36..5644b30aa334 100644
--- a/devel/build2/Makefile
+++ b/devel/build2/Makefile
@@ -11,11 +11,14 @@ WWW= https://build2.org
LICENSE= BSD2CLAUSE BSD3CLAUSE MIT
LICENSE_COMB= multi
-BROKEN_i386= error: timestamp is not lock-free on this architecture
-BROKEN_powerpc= error: timestamp is not lock-free on this architecture
+BROKEN_powerpc= fails in stage: Invalid data memory access
USES= gmake pkgconfig sqlite tar:xz
+# Fix build on i386/powerpc: error: timestamp is not lock-free on this architecture
+CXXFLAGS_i386= -DLIBBUILD2_ATOMIC_NON_LOCK_FREE
+CXXFLAGS_powerpc= -DLIBBUILD2_ATOMIC_NON_LOCK_FREE
+
# warning: clang@/usr/local/libexec/ccache/clang looks like a ccache wrapper
# info: ccache cannot be used as a C compiler
# info: use config.c to override