aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-02-28 17:57:53 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-02-28 18:35:53 +0000
commit74b7656c6770250db4d6385863ae73e75ce7664c (patch)
treecec20bc3bf76695f258a29b936b54fbbdba9effd
parentda9d203a3b0f91ba0295a9346f0ed1c6858a1f54 (diff)
downloadports-74b7656c6770250db4d6385863ae73e75ce7664c.tar.gz
ports-74b7656c6770250db4d6385863ae73e75ce7664c.zip
audio/ocp: Update to 0.2.94
-rw-r--r--audio/ocp/Makefile2
-rw-r--r--audio/ocp/distinfo10
-rw-r--r--audio/ocp/files/patch-config.h.in14
-rw-r--r--audio/ocp/files/patch-filesel_cdfs_audio.c13
-rw-r--r--audio/ocp/files/patch-filesel_cdfs_iso9660.c31
-rw-r--r--audio/ocp/pkg-plist1
6 files changed, 53 insertions, 18 deletions
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index c2c50475b3b2..d125c2c59888 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -1,7 +1,7 @@
# Created by: Emanuel Haupt <ehaupt@critical.ch>
PORTNAME= ocp
-PORTVERSION= 0.2.93
+PORTVERSION= 0.2.94
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= https://github.com/mywave82/opencubicplayer/releases/download/v${PORTVERSION}/
diff --git a/audio/ocp/distinfo b/audio/ocp/distinfo
index 4508579358d7..8dc27e7a6a14 100644
--- a/audio/ocp/distinfo
+++ b/audio/ocp/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1642959284
-SHA256 (ocp-0.2.93.tar.bz2) = 8a93a980cdf6cc274abd470bed8e17253521c7cf849cd1805626b07401147425
-SIZE (ocp-0.2.93.tar.bz2) = 3071816
+TIMESTAMP = 1646068115
+SHA256 (ocp-0.2.94.tar.bz2) = 307c3bb057b03514ed018ca2cca57e1b669f7b1cc95cd5f37e315ef2e9cda6e7
+SIZE (ocp-0.2.94.tar.bz2) = 3059881
+SHA256 (becedb6186234b6fb3baf9db0f25b62055e65cdd.patch) = e0c2affdc1c265c3d0b7763141915d7052ef72a4a2692b965b59c50fa2e1a585
+SIZE (becedb6186234b6fb3baf9db0f25b62055e65cdd.patch) = 1637
+SHA256 (ad24360fe92475a18c0ba1d44da6e5d060319176.patch) = 21d8407187042cefb4ff53fbe75e40e58897e1dc5a7bb670f1bb6dd13dadceb0
+SIZE (ad24360fe92475a18c0ba1d44da6e5d060319176.patch) = 731
diff --git a/audio/ocp/files/patch-config.h.in b/audio/ocp/files/patch-config.h.in
deleted file mode 100644
index 9341babdae59..000000000000
--- a/audio/ocp/files/patch-config.h.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- config.h.in.orig 2019-11-26 21:41:02 UTC
-+++ config.h.in
-@@ -160,9 +160,11 @@
-
- #undef HAVE_RESIZE_TERM
-
-+/*
- #if (defined(_X86) || defined(__i386__)) && !defined(__APPLE__)
- #define I386_ASM 1
- #endif
-+*/
-
- /* #define I386_ASM_EMU 1 */
-
diff --git a/audio/ocp/files/patch-filesel_cdfs_audio.c b/audio/ocp/files/patch-filesel_cdfs_audio.c
new file mode 100644
index 000000000000..c62382950fbb
--- /dev/null
+++ b/audio/ocp/files/patch-filesel_cdfs_audio.c
@@ -0,0 +1,13 @@
+--- filesel/cdfs/audio.c.orig 2022-02-28 13:08:06 UTC
++++ filesel/cdfs/audio.c
+@@ -131,9 +131,8 @@ void __attribute__ ((visibility ("internal"))) Check_A
+ }
+ failout:
+ discid_free (did);
+-postfailout:
+ }
+-
++postfailout:
+ AudioDir = CDFS_Directory_add (disc, 0, "AUDIO");
+
+ {
diff --git a/audio/ocp/files/patch-filesel_cdfs_iso9660.c b/audio/ocp/files/patch-filesel_cdfs_iso9660.c
new file mode 100644
index 000000000000..ba99de52d163
--- /dev/null
+++ b/audio/ocp/files/patch-filesel_cdfs_iso9660.c
@@ -0,0 +1,31 @@
+--- filesel/cdfs/iso9660.c.orig 2022-02-28 13:33:37 UTC
++++ filesel/cdfs/iso9660.c
+@@ -1140,8 +1140,7 @@ static void CDFS_Render_RockRidge_directory (struct cd
+ }
+
+ if ((directory->dirents_data[i]->Flags & ISO9660_DIRENT_FLAGS_DIR) || directory->dirents_data[i]->RockRidge_IsAugmentedDirectory)
+- {
+-dir:
++ {dir:;{ /* clang is stricter than gcc, no labels before variables */
+ uint32_t Location = directory->dirents_data[i]->Absolute_Location;
+ uint32_t this_directory_handle = CDFS_Directory_add (disc, parent_directory, temp);
+ if (directory->dirents_data[i]->RockRidge_IsAugmentedDirectory)
+@@ -1156,8 +1155,7 @@ dir:
+ break;
+ }
+ }
+- } else {
+-file:
++ }} else {file:;{ /* clang is stricter than gcc, no labels before variables */
+ int handle = CDFS_File_add (disc, parent_directory, temp);
+ struct iso_dirent_t *iter;
+ uint32_t Length = directory->dirents_data[i]->Length;
+@@ -1170,7 +1168,7 @@ file:
+ }
+ CDFS_File_extent (disc, handle, iter->Absolute_Location, RunLength, 0);
+ }
+- }
++ }}
+ next:
+ free (temp);
+ }
diff --git a/audio/ocp/pkg-plist b/audio/ocp/pkg-plist
index 96adaa043d83..94ac4a6fa95d 100644
--- a/audio/ocp/pkg-plist
+++ b/audio/ocp/pkg-plist
@@ -20,6 +20,7 @@ lib/ocp/autoload/30-smpbase.so
lib/ocp/autoload/30-ymtype.so
lib/ocp/autoload/35-cpiface.so
lib/ocp/autoload/40-cphlpif.so
+lib/ocp/autoload/60-cdfs.so
%%ALSA%%lib/ocp/devpalsa.so
lib/ocp/devpdisk.so
lib/ocp/devpnone.so