aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-24 10:20:25 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-24 10:58:47 +0000
commit74d3b748bc256e7f5e0190ac68994687943acbfb (patch)
tree415c3ae82634ae9fb2c763d31dd9ca0b9e157f67
parent09d2ead3fb90231d40469033e0a355e6b6e18b8d (diff)
downloadports-74d3b748bc256e7f5e0190ac68994687943acbfb.tar.gz
ports-74d3b748bc256e7f5e0190ac68994687943acbfb.zip
audio/play: Fix build with llvm16
Sponsored by: The FreeBSD Foundation
-rw-r--r--audio/play/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/play/Makefile b/audio/play/Makefile
index f58c839cbe9c..59cc796ed91e 100644
--- a/audio/play/Makefile
+++ b/audio/play/Makefile
@@ -25,6 +25,10 @@ PLIST_FILES= bin/play man/ja/man1/play.1.gz
CFLAGS+= -Wno-error=int-conversion
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
.for file in play_audio.c mixer_ctl.c encode_sun.c speed.c
@${REINPLACE_CMD} '/soundcard\.h/s,machine,sys,' ${WRKSRC}/${file}