aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2016-04-19 15:33:46 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2016-04-19 15:33:46 +0000
commit7543cdc5159da72f91151b6dd5f506d7924fe8fb (patch)
treec98ec0bf87e39991185c98980b9436efbcb8e3d2
parent9f618db9bc634fb189301adb827c792e27330f2c (diff)
downloadports-7543cdc5159da72f91151b6dd5f506d7924fe8fb.tar.gz
ports-7543cdc5159da72f91151b6dd5f506d7924fe8fb.zip
Merge the GnuTLS and libgcrypt OPTIONS into one as both are required
for decryption support. PR: 208830
Notes
Notes: svn path=/head/; revision=413652
-rw-r--r--net/wireshark/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index e2e387d01a38..942c25443976 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -54,7 +54,7 @@ PLIST_SUB+= ${x:tu}=bin/$x \
.endif
.endfor
-OPTIONS_DEFINE= RTP SNMP IPV6 GEOIP LUA GCRYPT GNUTLS
+OPTIONS_DEFINE= RTP SNMP IPV6 GEOIP LUA DECRYPT
OPTIONS_RADIO= ASYNCDNS GUI
OPTIONS_SINGLE= KERBEROS
@@ -66,8 +66,7 @@ OPTIONS_SINGLE_KERBEROS=KRB_BASE KRB_HEIMDAL KRB_MIT KRB_NONE
OPTIONS_DEFAULT?= SNMP ADNS IPV6 GEOIP KRB_BASE GTK3
RTP_DESC= Enable support for playing back RTP streams
-GCRYPT_DESC= IPsec decryption support
-GNUTLS_DESC= SSL decryption support
+DECRYPT_DESC= Decryption support for SSL and IPSec
ASYNCDNS_DESC= Asynchronous DNS lookup support
ADNS_DESC= Asynchronous DNS resolution via GNU adns
KERBEROS_DESC= Kerberos dissection support
@@ -90,8 +89,8 @@ SNMP_LIB_DEPENDS= libsmi.so:net-mgmt/libsmi
ADNS_LIB_DEPENDS= libadns.so:dns/adns
CARES_LIB_DEPENDS= libcares.so:dns/c-ares
GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
-GCRYPT_LIB_DEPENDS= libgcrypt.so:security/libgcrypt
-GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
+DECRYPT_LIB_DEPENDS= libgnutls.so:security/gnutls \
+ libgcrypt.so:security/libgcrypt
IPV6_CONFIGURE_ENABLE= ipv6
@@ -108,8 +107,7 @@ SNMP_CONFIGURE_WITH= libsmi
ADNS_CONFIGURE_WITH= adns
CARES_CONFIGURE_WITH= c-ares
GEOIP_CONFIGURE_WITH= geoip
-GCRYPT_CONFIGURE_WITH= gcrypt
-GNUTLS_CONFIGURE_WITH= gnutls
+DECRYPT_CONFIGURE_WITH= gnutls gcrypt
LUA_CPPFLAGS= -I${LUA_INCDIR}