aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2009-03-27 18:03:20 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2009-03-27 18:03:20 +0000
commit75a6657bad3c6aa6be08ef92e9486ba9500b4c23 (patch)
tree6a27e7266bd39c3fcb191001855bfe4a0dbd79e1
parentd18d6239206d1bc69b93fe5ff6599ef2d5283d43 (diff)
downloadports-75a6657bad3c6aa6be08ef92e9486ba9500b4c23.tar.gz
ports-75a6657bad3c6aa6be08ef92e9486ba9500b4c23.zip
Mark MAKE_JOBS_SAFE for parallel building.
Notes
Notes: svn path=/head/; revision=231126
-rw-r--r--audio/mpg321/Makefile1
-rw-r--r--audio/xmms-flac/Makefile1
-rw-r--r--audio/xmms-shn/Makefile1
-rw-r--r--audio/xmms-wavpack/Makefile5
-rw-r--r--comms/wy60/Makefile1
-rw-r--r--games/xsoldier/Makefile3
-rw-r--r--mail/bsmtp/Makefile1
-rw-r--r--www/man2web/Makefile1
8 files changed, 11 insertions, 3 deletions
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
index adc243f06c1d..8145412b9cb8 100644
--- a/audio/mpg321/Makefile
+++ b/audio/mpg321/Makefile
@@ -34,6 +34,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-mpg123-symlink
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
MAN1= mpg321.1
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index 424e93b08f36..9775c9742769 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -25,6 +25,7 @@ CONFIGURE_ARGS= --with-libiconv-prefix="${LOCALBASE}" \
MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
MAKE_ENV= MAKEOBJDIR=/nonexistent # ignore ${WRKSRC}/obj
MAKEFILE= ${FILESDIR}/Makefile
+MAKE_JOBS_SAFE= yes
# XXX
post-install:
diff --git a/audio/xmms-shn/Makefile b/audio/xmms-shn/Makefile
index 1a572702f31c..c983d19c3132 100644
--- a/audio/xmms-shn/Makefile
+++ b/audio/xmms-shn/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
USE_GNOME= gtk12
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
post-install:
.if !defined(NOPORTDOCS)
diff --git a/audio/xmms-wavpack/Makefile b/audio/xmms-wavpack/Makefile
index 0e7a939f7b05..9090e35a3ff8 100644
--- a/audio/xmms-wavpack/Makefile
+++ b/audio/xmms-wavpack/Makefile
@@ -17,10 +17,11 @@ LIB_DEPENDS= wavpack.1:${PORTSDIR}/audio/wavpack \
RESTRICTED= missing license
-USE_BZIP2= Yes
-GNU_CONFIGURE= Yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_SAFE= yes
post-install:
${RM} ${PREFIX}/lib/xmms/Input/libwavpack.la
diff --git a/comms/wy60/Makefile b/comms/wy60/Makefile
index 5df3a1125d67..4497e5694746 100644
--- a/comms/wy60/Makefile
+++ b/comms/wy60/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= naddy@FreeBSD.org
COMMENT= Curses-based emulator for the Wyse 60 terminal
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
MAN1= wy60.1
diff --git a/games/xsoldier/Makefile b/games/xsoldier/Makefile
index 7b38f1e67913..7404b34e42cc 100644
--- a/games/xsoldier/Makefile
+++ b/games/xsoldier/Makefile
@@ -14,9 +14,10 @@ MASTER_SITES= http://www.interq.or.jp/libra/oohara/xsoldier/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Space-based shoot-em up game for X11
-GNU_CONFIGURE= Yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
MAKE_ARGS= CC_OPTIMIZE="${CFLAGS}"
+MAKE_JOBS_SAFE= yes
USE_XORG= x11 ice xpm
MAN6= xsoldier.6
diff --git a/mail/bsmtp/Makefile b/mail/bsmtp/Makefile
index 3b7cac4cdf79..aafa6402790d 100644
--- a/mail/bsmtp/Makefile
+++ b/mail/bsmtp/Makefile
@@ -20,6 +20,7 @@ USE_PERL5= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --redo
+MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
diff --git a/www/man2web/Makefile b/www/man2web/Makefile
index 370f9cf22c71..e7b8e09edc44 100644
--- a/www/man2web/Makefile
+++ b/www/man2web/Makefile
@@ -20,6 +20,7 @@ CONFIGURE_ARGS= --bindir="${PREFIX}/${CGIDIR}" \
--sysconfdir="${PREFIX}/etc" \
--with-manpath=/usr/share/man:${LOCALBASE}/man \
--with-distro=freebsd --enable-lynx
+MAKE_JOBS_SAFE= yes
PLIST_SUB= CGIDIR="${CGIDIR}"
CGIDIR= www/cgi-bin