aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-31 18:51:20 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-31 18:51:20 +0000
commit75efa01f5ee3f492f37e32d806d4e3f910bbf228 (patch)
tree20f9e99373c49c33704783ab296c443a02b31b4b
parentdca0376383009c19cea98420455feb02ec2da8d9 (diff)
downloadports-75efa01f5ee3f492f37e32d806d4e3f910bbf228.tar.gz
ports-75efa01f5ee3f492f37e32d806d4e3f910bbf228.zip
www/yt-dlp: Remove the pandoc dependency
PR: 276034 Reported by: vvd@, diizzy@
-rw-r--r--www/yt-dlp/Makefile3
-rw-r--r--www/yt-dlp/files/patch-Makefile15
2 files changed, 16 insertions, 2 deletions
diff --git a/www/yt-dlp/Makefile b/www/yt-dlp/Makefile
index 05b72fabd259..effc1852ce5d 100644
--- a/www/yt-dlp/Makefile
+++ b/www/yt-dlp/Makefile
@@ -21,8 +21,7 @@ PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}brotli>0:archivers/py-brotli@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>=1.26.17:net/py-urllib3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}websockets>=12.0:devel/py-websockets@${PY_FLAVOR}
-BUILD_DEPENDS= ${PY_DEPENDS} \
- pandoc:textproc/hs-pandoc
+BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
USES= gmake python shebangfix
diff --git a/www/yt-dlp/files/patch-Makefile b/www/yt-dlp/files/patch-Makefile
index 2828154ce338..e2a87a36ba16 100644
--- a/www/yt-dlp/files/patch-Makefile
+++ b/www/yt-dlp/files/patch-Makefile
@@ -54,3 +54,18 @@
supportedsites:
$(PYTHON) devscripts/make_supportedsites.py supportedsites.md
+@@ -110,10 +110,10 @@ README.txt: README.md
+ README.txt: README.md
+ pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
+
+-yt-dlp.1: README.md devscripts/prepare_manpage.py
+- $(PYTHON) devscripts/prepare_manpage.py yt-dlp.1.temp.md
+- pandoc -s -f $(MARKDOWN) -t man yt-dlp.1.temp.md -o yt-dlp.1
+- rm -f yt-dlp.1.temp.md
++#yt-dlp.1: README.md devscripts/prepare_manpage.py
++# $(PYTHON) devscripts/prepare_manpage.py yt-dlp.1.temp.md
++# pandoc -s -f $(MARKDOWN) -t man yt-dlp.1.temp.md -o yt-dlp.1
++# rm -f yt-dlp.1.temp.md
+
+ completions/bash/yt-dlp: yt_dlp/*.py yt_dlp/*/*.py devscripts/bash-completion.in
+ mkdir -p completions/bash