aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 13:44:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 14:05:21 +0000
commit7608e8a5af706c6806e3c86032e61fed7a9b3c22 (patch)
tree47542d98e62784c4fb40fb4c6607d312f7d0e46b
parent07f049b22e265c356ae62e6ec413a76e25e9c28d (diff)
downloadports-7608e8a5af706c6806e3c86032e61fed7a9b3c22.tar.gz
ports-7608e8a5af706c6806e3c86032e61fed7a9b3c22.zip
devel/libpci: Update to 3.11.1
- Remove patches for FreeBSD 12 (patch-lib-ecam.c and patch-lib-mmio-ports.c) Changes: https://github.com/pciutils/pciutils/blob/master/ChangeLog
-rw-r--r--devel/libpci/Makefile2
-rw-r--r--devel/libpci/distinfo6
-rw-r--r--devel/libpci/files/patch-Makefile35
-rw-r--r--devel/libpci/files/patch-lib-ecam.c14
-rw-r--r--devel/libpci/files/patch-lib-mmio-ports.c14
-rw-r--r--devel/libpci/files/patch-lib-pci.h6
6 files changed, 20 insertions, 57 deletions
diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index 71ff576a9d7d..5d7d6fbf420e 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libpci
-PORTVERSION= 3.10.0
+PORTVERSION= 3.11.1
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/utils/pciutils \
LOCAL/sunpoet
diff --git a/devel/libpci/distinfo b/devel/libpci/distinfo
index 68aaca78013d..541d4cabc9b0 100644
--- a/devel/libpci/distinfo
+++ b/devel/libpci/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1683227581
-SHA256 (pciutils-3.10.0.tar.xz) = 238a2e27166730e53a17fe07bfad229e07fa39b618117e5944b6d7eda9fbb0e9
-SIZE (pciutils-3.10.0.tar.xz) = 444080
+TIMESTAMP = 1709390366
+SHA256 (pciutils-3.11.1.tar.xz) = 3f472ad864473de5ba17f765cc96ef5f33e1b730918d3adda6f945a2a9290df4
+SIZE (pciutils-3.11.1.tar.xz) = 470428
diff --git a/devel/libpci/files/patch-Makefile b/devel/libpci/files/patch-Makefile
index 07189e5d7cc7..c4fc1e9cdbfd 100644
--- a/devel/libpci/files/patch-Makefile
+++ b/devel/libpci/files/patch-Makefile
@@ -1,17 +1,17 @@
---- Makefile.orig 2023-05-01 12:59:54 UTC
+--- Makefile.orig 2024-02-24 23:10:18 UTC
+++ Makefile
@@ -1,8 +1,8 @@
# Makefile for The PCI Utilities
- # (c) 1998--2023 Martin Mares <mj@ucw.cz>
+ # (c) 1998--2024 Martin Mares <mj@ucw.cz>
-OPT=-O2
-CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
+#OPT=-O2
+CFLAGS+=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
- VERSION=3.10.0
- DATE=2023-05-01
-@@ -32,11 +32,11 @@ HWDB=
+ VERSION=3.11.1
+ DATE=2024-02-25
+@@ -32,11 +32,11 @@ ABI_VERSION=3
ABI_VERSION=3
# Installation directories
@@ -25,24 +25,15 @@
MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
INCDIR=$(PREFIX)/include
LIBDIR=$(PREFIX)/lib
-@@ -45,13 +45,13 @@ PKGCFDIR=$(LIBDIR)/pkgconfig
- # Commands
- INSTALL=install
- DIRINSTALL=install -d
--ifdef CROSS_COMPILE
--STRIP=--strip-program $(CROSS_COMPILE)-strip
+@@ -48,9 +48,9 @@ STRIP+=--strip-program $(CROSS_COMPILE)strip
+ STRIP=-s
+ ifdef CROSS_COMPILE
+ STRIP+=--strip-program $(CROSS_COMPILE)strip
-CC=$(CROSS_COMPILE)gcc
--else
--STRIP=-s
++CC?=$(CROSS_COMPILE)gcc
+ else
-CC=cc
--endif
-+#ifdef CROSS_COMPILE
-+#STRIP=--strip-program $(CROSS_COMPILE)-strip
-+#CC=$(CROSS_COMPILE)gcc
-+#else
-+#STRIP=-s
-+#CC=cc
-+#endif
++CC?=cc
+ endif
AR=$(CROSS_COMPILE)ar
RANLIB=$(CROSS_COMPILE)ranlib
- DLLTOOL=$(CROSS_COMPILE)dlltool
diff --git a/devel/libpci/files/patch-lib-ecam.c b/devel/libpci/files/patch-lib-ecam.c
deleted file mode 100644
index 0dab14c851c3..000000000000
--- a/devel/libpci/files/patch-lib-ecam.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- lib/ecam.c.orig 2023-03-05 13:45:24 UTC
-+++ lib/ecam.c
-@@ -924,7 +924,11 @@ ecam_init(struct pci_access *a)
- if (!validate_addrs(addrs))
- a->error("Option ecam.addrs has invalid address format \"%s\".", addrs);
-
-+#if defined(O_DSYNC)
- a->fd = open(devmem, (a->writeable ? O_RDWR : O_RDONLY) | O_DSYNC);
-+#else
-+ a->fd = open(devmem, (a->writeable ? O_RDWR : O_RDONLY));
-+#endif
- if (a->fd < 0)
- a->error("Cannot open %s: %s.", devmem, strerror(errno));
-
diff --git a/devel/libpci/files/patch-lib-mmio-ports.c b/devel/libpci/files/patch-lib-mmio-ports.c
deleted file mode 100644
index a357cc2c1406..000000000000
--- a/devel/libpci/files/patch-lib-mmio-ports.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- lib/mmio-ports.c.orig 2023-03-04 15:27:09 UTC
-+++ lib/mmio-ports.c
-@@ -298,7 +298,11 @@ conf1_init(struct pci_access *a)
- if (!validate_addrs(addrs))
- a->error("Option %s has invalid address format \"%s\".", addrs_param_name, addrs);
-
-+#if defined(O_DSYNC)
- a->fd = open(devmem, O_RDWR | O_DSYNC); /* O_DSYNC bypass CPU cache for mmap() on Linux */
-+#else
-+ a->fd = open(devmem, O_RDWR); /* O_DSYNC bypass CPU cache for mmap() on Linux */
-+#endif
- if (a->fd < 0)
- a->error("Cannot open %s: %s.", devmem, strerror(errno));
- }
diff --git a/devel/libpci/files/patch-lib-pci.h b/devel/libpci/files/patch-lib-pci.h
index 479459659a66..f72e763c1ea8 100644
--- a/devel/libpci/files/patch-lib-pci.h
+++ b/devel/libpci/files/patch-lib-pci.h
@@ -1,6 +1,6 @@
---- lib/pci.h.orig 2023-05-01 13:00:07 UTC
+--- lib/pci.h.orig 2024-02-24 23:10:31 UTC
+++ lib/pci.h
-@@ -10,11 +10,11 @@
+@@ -12,11 +12,11 @@
#define _PCI_LIB_H
#ifndef PCI_CONFIG_H
@@ -13,5 +13,5 @@
+#include "pci/header.h"
+#include "pci/types.h"
- #define PCI_LIB_VERSION 0x030a00
+ #define PCI_LIB_VERSION 0x030b01