aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2024-08-02 12:42:16 +0000
committerDimitry Andric <dim@FreeBSD.org>2024-08-02 21:59:07 +0000
commit7624cbd8af7758af64631f04930089e13fb9fcf7 (patch)
tree2d9d1dd3acb43d45dd0b4c8b3e5b89285cd8d56b
parent3b4c86ee58196188132b244feb893ea2864f704f (diff)
downloadports-7624cbd8af7758af64631f04930089e13fb9fcf7.tar.gz
ports-7624cbd8af7758af64631f04930089e13fb9fcf7.zip
devel/llvm17: fix build with libc++ 19
As noted in the libc++ 19 release notes [1], std::char_traits<> is now only provided for char, char8_t, char16_t, char32_t and wchar_t, and any instantiation for other types will fail. This causes devel/llvm17 to fail to compile with clang 19 and libc++ 19, resulting in errors similar to: /usr/include/c++/v1/string:820:42: error: implicit instantiation of undefined template 'std::char_traits<unsigned char>' 820 | static_assert(is_same<_CharT, typename traits_type::char_type>::value, | ^ /wrkdirs/usr/ports/devel/llvm17/work-default/llvm-project-17.0.6.src/lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerLLGS.cpp:634:34: note: in instantiation of template class 'std::basic_string<unsigned char>' requested here 634 | std::basic_string<uint8_t> zeros(reg_info.byte_size, '\0'); | ^ /usr/include/c++/v1/__fwd/string.h:23:29: note: template is declared here 23 | struct _LIBCPP_TEMPLATE_VIS char_traits; | ^ Upstream llvm has fixed this in commit 68744ffbdd7d [2], so add this as a PATCHFILES entry in the Makefile. [1] https://libcxx.llvm.org/ReleaseNotes/19.html#deprecations-and-removals [2] https://github.com/llvm/llvm-project/commit/68744ffbdd7d PR: 280579 Approved by: brooks (maintainer) MFH: 2024Q3
-rw-r--r--devel/llvm17/Makefile1
-rw-r--r--devel/llvm17/distinfo6
2 files changed, 6 insertions, 1 deletions
diff --git a/devel/llvm17/Makefile b/devel/llvm17/Makefile
index ee08a727c5f8..f907f6a1f575 100644
--- a/devel/llvm17/Makefile
+++ b/devel/llvm17/Makefile
@@ -9,6 +9,7 @@ DISTNAME= llvm-project-${DISTVERSION}.src
DISTFILES= llvm-project-${DISTVERSION}.src${EXTRACT_SUFX}
PATCH_SITES= https://github.com/llvm/llvm-project/commit/
+PATCHFILES+= llvmorg-18-init-1760-g68744ffbdd7d.patch:-p1 # https://reviews.llvm.org/D157589
PATCHFILES+= llvmorg-18-init-15199-gb9935bb02a50.patch:-p1 # https://github.com/llvm/llvm-project/pull/75748
PATCHFILES+= llvmorg-18-init-15680-g966d564e43e6.patch:-p1 # https://github.com/llvm/llvm-project/pull/76185
diff --git a/devel/llvm17/distinfo b/devel/llvm17/distinfo
index 9b27c6ea150d..a3690faf6fce 100644
--- a/devel/llvm17/distinfo
+++ b/devel/llvm17/distinfo
@@ -1,6 +1,10 @@
-TIMESTAMP = 1701190197
+TIMESTAMP = 1722603078
SHA256 (llvm-project-17.0.6.src.tar.xz) = 58a8818c60e6627064f312dbf46c02d9949956558340938b71cf731ad8bc0813
SIZE (llvm-project-17.0.6.src.tar.xz) = 127838860
+SHA256 (llvmorg-18-init-1760-g68744ffbdd7d.patch) = ad9ad1613491f69b010dbbd6a9d90d5dd505e46d9537a6e533f36dacd552d0f7
+SIZE (llvmorg-18-init-1760-g68744ffbdd7d.patch) = 1491
+SHA256 (llvmorg-18-init-2919-g7549cde6bd52.patch) = 3c388e7c79949ba16f8587316cfb5ef7cd4c7e231941b3513e1950260a490e5f
+SIZE (llvmorg-18-init-2919-g7549cde6bd52.patch) = 1737
SHA256 (llvmorg-18-init-15199-gb9935bb02a50.patch) = b0805cba765084c7bef426fa1235dd887c61ae0c1fd5e3fad5c8742cdd6ee8b0
SIZE (llvmorg-18-init-15199-gb9935bb02a50.patch) = 1893
SHA256 (llvmorg-18-init-15680-g966d564e43e6.patch) = 3abf92d4a788ff2f74fa9fc627a113f04d9fb72cd7e47344a8c4dce06140a163