aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2023-01-30 08:41:05 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-01-30 09:53:14 +0000
commit7625d4e4e5dd24a06c7d946d7b4328c8f17410bb (patch)
treec4f6c589955eb57c9dfd0eafc7294fc862b698df
parent006eb3b4af8a21bc3117396383fa8958d5c4aca3 (diff)
downloadports-7625d4e4e5dd24a06c7d946d7b4328c8f17410bb.tar.gz
ports-7625d4e4e5dd24a06c7d946d7b4328c8f17410bb.zip
www/writefreely: Pick patch to fix segmentation fault
Selectively picking patch from upstream to fix a segmentation fault. Adding sample configuration to workaround the problem. PR: 268809 Reported by: trash@nazileaks.eu
-rw-r--r--www/writefreely/Makefile12
-rw-r--r--www/writefreely/distinfo4
-rw-r--r--www/writefreely/files/config.ini.sample.in10
-rw-r--r--www/writefreely/pkg-plist1
4 files changed, 24 insertions, 3 deletions
diff --git a/www/writefreely/Makefile b/www/writefreely/Makefile
index 1ec485a85931..796b04652d48 100644
--- a/www/writefreely/Makefile
+++ b/www/writefreely/Makefile
@@ -1,11 +1,18 @@
PORTNAME= writefreely
DISTVERSIONPREFIX= v
DISTVERSION= 0.13.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www textproc
MASTER_SITES= https://code.as/core/socks/archive/v1.0.0.tar.gz?dummy=/:core_socks
DISTFILES= core-socks-v1.0.0.tar.gz:core_socks
DIST_SUBDIR= writeas
+
+PATCH_SITES= https://github.com/writefreely/writefreely/commit/
+PATCHFILES= 99d72881cf833326f02d86a8896bbd2b8156327b.diff:-p1
+
+ MAINTAINER= fuz@fuz.su
+ COMMENT= Clean, Markdown-based publishing platform made for writers
+ WWW= https://writefreely.org
MAINTAINER= fuz@fuz.su
COMMENT= Clean, Markdown-based publishing platform made for writers
@@ -96,7 +103,7 @@ GH_TUPLE= aymerick:douceur:v0.2.0:aymerick_douceur/vendor/github.com/aymerick/do
USE_RC_SUBR= writefreely
GO_TARGET= ./cmd/writefreely
-SUB_FILES= pkg-message
+SUB_FILES= config.ini.sample pkg-message
USERS= writefreely
GROUPS= writefreely
@@ -149,6 +156,7 @@ do-install-DOCS-on:
post-install:
${MKDIR} ${STAGEDIR}${WWWDIR}/keys
+ ${INSTALL_DATA} ${WRKDIR}/config.ini.sample ${STAGEDIR}${WWWDIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} pages ${STAGEDIR}${WWWDIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} static ${STAGEDIR}${WWWDIR}
${INSTALL_DATA} ${WRKDIR}/css/*.css ${STAGEDIR}${WWWDIR}/static/css/
diff --git a/www/writefreely/distinfo b/www/writefreely/distinfo
index 4a27251b1193..e445b7794739 100644
--- a/www/writefreely/distinfo
+++ b/www/writefreely/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1668161444
+TIMESTAMP = 1674562387
SHA256 (writeas/core-socks-v1.0.0.tar.gz) = 9d199f31b9fcaa97b4c52483f16e226fe7b40a0014b6070788f415cff29f2c32
SIZE (writeas/core-socks-v1.0.0.tar.gz) = 11604
SHA256 (writeas/writefreely-css-0.13.2.tar.gz) = 099ad7bb876e9cef2155af71df65825cd8776beb66de523430169c2eb52adf88
@@ -153,3 +153,5 @@ SHA256 (writeas/writefreely-go-nodeinfo-v1.2.0_GH0.tar.gz) = bcf74cbb4ff56cab570
SIZE (writeas/writefreely-go-nodeinfo-v1.2.0_GH0.tar.gz) = 3560
SHA256 (writeas/writefreely-documentation-v0.13.1_GH0.tar.gz) = 071263600c4aeba84f12a5794eb7c59f70b3bee6f1a7d0757ab0f50c3cc25f38
SIZE (writeas/writefreely-documentation-v0.13.1_GH0.tar.gz) = 19082
+SHA256 (writeas/99d72881cf833326f02d86a8896bbd2b8156327b.diff) = eaa803e2e34323e8e6ea90ec666b3769330fd8baf0a6f444b2275a8352f58b26
+SIZE (writeas/99d72881cf833326f02d86a8896bbd2b8156327b.diff) = 2580
diff --git a/www/writefreely/files/config.ini.sample.in b/www/writefreely/files/config.ini.sample.in
new file mode 100644
index 000000000000..a154708a2b65
--- /dev/null
+++ b/www/writefreely/files/config.ini.sample.in
@@ -0,0 +1,10 @@
+; Preliminary configuration file. Run
+;
+; %%PREFIX%%/etc/rc.d/writefreely setup
+;
+; to set up writefreely.
+[server]
+templates_parent_dir = %%WWWDIR%%
+static_parent_dir = %%WWWDIR%%
+pages_parent_dir = %%WWWDIR%%
+keys_parent_dir = %%WWWDIR%%
diff --git a/www/writefreely/pkg-plist b/www/writefreely/pkg-plist
index ace00809ad18..189cb8349328 100644
--- a/www/writefreely/pkg-plist
+++ b/www/writefreely/pkg-plist
@@ -21,6 +21,7 @@ bin/writefreely
%%PORTDOCS%%%%DOCSDIR%%/writer/static.md
%%PORTDOCS%%%%DOCSDIR%%/writer/writing.md
@dir(writefreely,writefreely,) %%WWWDIR%%
+@sample(writefreely,writefreely,) %%WWWDIR%%/config.ini.sample
%%WWWDIR%%/pages/404-general.tmpl
%%WWWDIR%%/pages/404.tmpl
%%WWWDIR%%/pages/410.tmpl