aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-03-29 06:14:13 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-03-29 06:14:13 +0000
commit7686fc035435ab069cec46152a83282cdc117a9e (patch)
treee3498beb009b660a6ed9b9f04f782521d1fc58d6
parent9482644374c18974620ef478e1d4a8e746b6e2aa (diff)
downloadports-7686fc035435ab069cec46152a83282cdc117a9e.tar.gz
ports-7686fc035435ab069cec46152a83282cdc117a9e.zip
lang/rust: switch back to base LLVM on powerpc
Base LLVM in 13.1 now can build Rust.
-rw-r--r--lang/rust/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 8d4d53160eb2..17793efc96b7 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -95,14 +95,7 @@ IGNORE= is only for FreeBSD
.if ${ARCH} == powerpc
# bfd to link rustc_driver; lld currently can't
-BUILD_DEPENDS+= ld.bfd:devel/binutils \
- clang12:devel/llvm12
-BINARY_ALIAS+= cpp=${LOCALBASE}/bin/clang-cpp12 \
- cc=${LOCALBASE}/bin/clang12 \
- c++=${LOCALBASE}/bin/clang++12 \
- ar=${LOCALBASE}/bin/llvm-ar12 \
- nm=${LOCALBASE}/bin/llvm-nm12 \
- ld=${LOCALBASE}/bin/ld.lld12
+BUILD_DEPENDS+= ld.bfd:devel/binutils
.else
MAKE_ENV+= RUST_BACKTRACE=1
# rls needs 64-bit atomics