aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-08-17 12:54:27 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-08-17 12:54:27 +0000
commit76f34ce632e97edd9f0ac31516d9cbc88f60ef1e (patch)
tree9fddd685047d2d35ad3c6b509102bed8bbcc4689
parent942dd7ff4e820ed295c08b6baba0d3533739d332 (diff)
downloadports-76f34ce632e97edd9f0ac31516d9cbc88f60ef1e.tar.gz
ports-76f34ce632e97edd9f0ac31516d9cbc88f60ef1e.zip
Fix plist at optional IPv6 configuration.
PR: ports/55301 Submitted by: Kimura Fuyuki <fuyuki@nigredo.org>
Notes
Notes: svn path=/head/; revision=87125
-rw-r--r--mail/postfix/pkg-plist2
-rw-r--r--mail/postfix/scripts/configure.postfix6
-rw-r--r--mail/postfix20/pkg-plist2
-rw-r--r--mail/postfix20/scripts/configure.postfix6
-rw-r--r--mail/postfix21/pkg-plist2
-rw-r--r--mail/postfix21/scripts/configure.postfix6
-rw-r--r--mail/postfix22/pkg-plist2
-rw-r--r--mail/postfix22/scripts/configure.postfix6
-rw-r--r--mail/postfix23/pkg-plist2
-rw-r--r--mail/postfix23/scripts/configure.postfix6
-rw-r--r--mail/postfix24/pkg-plist2
-rw-r--r--mail/postfix24/scripts/configure.postfix6
-rw-r--r--mail/postfix25/pkg-plist2
-rw-r--r--mail/postfix25/scripts/configure.postfix6
-rw-r--r--mail/postfix26/pkg-plist2
-rw-r--r--mail/postfix26/scripts/configure.postfix6
-rw-r--r--mail/postfix27/pkg-plist2
-rw-r--r--mail/postfix27/scripts/configure.postfix6
-rw-r--r--mail/postfix28/pkg-plist2
-rw-r--r--mail/postfix28/scripts/configure.postfix6
20 files changed, 70 insertions, 10 deletions
diff --git a/mail/postfix/pkg-plist b/mail/postfix/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix/pkg-plist
+++ b/mail/postfix/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix/scripts/configure.postfix b/mail/postfix/scripts/configure.postfix
index 681ec7971c25..f8bd34b223d4 100644
--- a/mail/postfix/scripts/configure.postfix
+++ b/mail/postfix/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix20/pkg-plist b/mail/postfix20/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix20/pkg-plist
+++ b/mail/postfix20/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix20/scripts/configure.postfix b/mail/postfix20/scripts/configure.postfix
index 11f6afdf9b2b..5ab252ad71de 100644
--- a/mail/postfix20/scripts/configure.postfix
+++ b/mail/postfix20/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix20/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix20/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix21/pkg-plist b/mail/postfix21/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix21/pkg-plist
+++ b/mail/postfix21/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix21/scripts/configure.postfix b/mail/postfix21/scripts/configure.postfix
index 0a3fa16de528..43bbe1d0e80e 100644
--- a/mail/postfix21/scripts/configure.postfix
+++ b/mail/postfix21/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix22/pkg-plist b/mail/postfix22/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix22/pkg-plist
+++ b/mail/postfix22/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix22/scripts/configure.postfix b/mail/postfix22/scripts/configure.postfix
index d2939fd2c957..48811f5bb26a 100644
--- a/mail/postfix22/scripts/configure.postfix
+++ b/mail/postfix22/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix23/pkg-plist b/mail/postfix23/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix23/pkg-plist
+++ b/mail/postfix23/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix23/scripts/configure.postfix b/mail/postfix23/scripts/configure.postfix
index 658da9bd85b3..5beae34c3de5 100644
--- a/mail/postfix23/scripts/configure.postfix
+++ b/mail/postfix23/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix23/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix23/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix24/pkg-plist b/mail/postfix24/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix24/pkg-plist
+++ b/mail/postfix24/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix24/scripts/configure.postfix b/mail/postfix24/scripts/configure.postfix
index a61d6ddedb6d..5743edd205aa 100644
--- a/mail/postfix24/scripts/configure.postfix
+++ b/mail/postfix24/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix24/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix24/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix25/pkg-plist b/mail/postfix25/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix25/pkg-plist
+++ b/mail/postfix25/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix25/scripts/configure.postfix b/mail/postfix25/scripts/configure.postfix
index 7d2780d34605..41cc96ff87df 100644
--- a/mail/postfix25/scripts/configure.postfix
+++ b/mail/postfix25/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix25/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix25/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix26/pkg-plist b/mail/postfix26/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix26/pkg-plist
+++ b/mail/postfix26/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix26/scripts/configure.postfix b/mail/postfix26/scripts/configure.postfix
index 4c8b62e5e757..3464c8f6c631 100644
--- a/mail/postfix26/scripts/configure.postfix
+++ b/mail/postfix26/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix27/pkg-plist b/mail/postfix27/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix27/pkg-plist
+++ b/mail/postfix27/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix27/scripts/configure.postfix b/mail/postfix27/scripts/configure.postfix
index 9890daca701b..f352bf8c8f8a 100644
--- a/mail/postfix27/scripts/configure.postfix
+++ b/mail/postfix27/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix27/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix27/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but
diff --git a/mail/postfix28/pkg-plist b/mail/postfix28/pkg-plist
index c102595ef4bf..41e126fff794 100644
--- a/mail/postfix28/pkg-plist
+++ b/mail/postfix28/pkg-plist
@@ -27,6 +27,7 @@ etc/postfix/sample-compatibility.cf
etc/postfix/sample-debug.cf
etc/postfix/sample-filter.cf
etc/postfix/sample-flush.cf
+%%SUB_IPV6%%etc/postfix/sample-ipv6.cf
etc/postfix/sample-ldap.cf
etc/postfix/sample-lmtp.cf
etc/postfix/sample-local.cf
@@ -94,6 +95,7 @@ bin/mailq
%%PORTDOCS%%share/doc/postfix/ETRN_README
%%PORTDOCS%%share/doc/postfix/FILTER_README
%%PORTDOCS%%share/doc/postfix/INSTALL
+%%PORTDOCS%%%%SUB_IPV6%%share/doc/postfix/IPV6_README
%%PORTDOCS%%share/doc/postfix/LDAP_README
%%PORTDOCS%%share/doc/postfix/LINUX_README
%%PORTDOCS%%share/doc/postfix/LOCAL_RECIPIENT_README
diff --git a/mail/postfix28/scripts/configure.postfix b/mail/postfix28/scripts/configure.postfix
index 7da993a4e29c..6d00664e4c21 100644
--- a/mail/postfix28/scripts/configure.postfix
+++ b/mail/postfix28/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix28/scripts/Attic/configure.postfix,v 1.38 2003-08-15 00:49:26 kuriyama Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix28/scripts/Attic/configure.postfix,v 1.39 2003-08-17 12:54:27 kuriyama Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -63,6 +63,7 @@ echo "PREFIX= ${PREFIX}"
SUB_TLS="@comment "
SUB_TEST="@comment "
+SUB_IPV6="@comment "
while [ "$1" ]; do
case $1 in
@@ -207,6 +208,7 @@ while [ "$1" ]; do
echo "IPv6_SUFFIX= +ipv6"
echo ""
IPv6SELECTED=YES
+ SUB_IPV6=""
;;
IPv6TLS)
if [ X$SUB_TLS = "X" -o X$IPv6SELECTED != X ]; then
@@ -223,6 +225,7 @@ while [ "$1" ]; do
echo "PATCH_DIST_STRIP= -p1"
echo "TLS_SUFFIX= +tls+ipv6"
SUB_TLS=""
+ SUB_IPV6=""
;;
*)
echo "Unknown option(s): $*" > /dev/stderr
@@ -235,6 +238,7 @@ done
echo "PLIST_SUB+= SUB_TLS=\"${SUB_TLS}\""
echo "PLIST_SUB+= SUB_TEST=\"${SUB_TEST}\""
+echo "PLIST_SUB+= SUB_IPV6=\"${SUB_IPV6}\""
# for some reason, if we alter the pkg name this way, the first build (where
# we ask the configure questions) doesn't pick up the extensions, but