aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-10-07 07:18:37 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-09 07:40:30 +0000
commit77455882b6f8c9854c788f45d9fb4abd93555647 (patch)
treef83e209a58ec2d2e6a08ca8a122efa2d5c2eab13
parent3dd02a0fe712c2b67ab0e15444d9fbb4f00b3817 (diff)
downloadports-77455882b6f8c9854c788f45d9fb4abd93555647.tar.gz
ports-77455882b6f8c9854c788f45d9fb4abd93555647.zip
devel/cargo-c: fix build on armv7
The address space does not suffice to build cargo-c on armv7 with LTO. Disable LTO on armv6/armv7 to make the build succeed. Approved by: portmgr (build fix blanket) MFH: 2023Q4
-rw-r--r--devel/cargo-c/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/cargo-c/Makefile b/devel/cargo-c/Makefile
index df6d6d36d8a7..621e276b6aab 100644
--- a/devel/cargo-c/Makefile
+++ b/devel/cargo-c/Makefile
@@ -25,8 +25,15 @@ PLIST_FILES= bin/cargo-capi \
bin/cargo-ctest \
${NULL}
+.include <bsd.port.pre.mk>
+
+# prevent address space exhaustion on armv6/armv7
+.if ${ARCH:Marmv?}
+LTO_UNSAFE= yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,libdir.join("pkgconfig,prefix.join("libdata/pkgconfig,' \
${WRKSRC}/src/install.rs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>