aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2011-11-24 16:42:57 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2011-11-24 16:42:57 +0000
commit777ea8ea02b7877b6963449b858ce6817dc0570e (patch)
treec8e5ca0eb15448b649e42ce16fde74f507b81961
parenta074e9f5ef69107cd88e2f6fa7fd7796446f6006 (diff)
downloadports-777ea8ea02b7877b6963449b858ce6817dc0570e.tar.gz
ports-777ea8ea02b7877b6963449b858ce6817dc0570e.zip
Submitted by: Abdrey Zonov <andrey@zonov.org>
Approved by: maintainer (mail@derzinn.de,implicit), gabor (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286382
-rw-r--r--databases/mongodb/Makefile5
-rw-r--r--databases/mongodb/files/patch-SConstruct15
2 files changed, 12 insertions, 8 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index 110ffb41bb27..bdad053e7f1e 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -43,11 +43,6 @@ PLIST_SUB+= DEVEL=""
PLIST_SUB+= DEVEL="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|elif "freebsd7" == os.sys.platform|elif os.sys.platform.startswith("freebsd")|' \
- -e '/not GetOption("nostrip")/ s,linux,linux or freebsd,g' \
- ${WRKSRC}/SConstruct
-
post-install:
@if [ ! -f ${PREFIX}/etc/mongodb.conf ]; then \
${TOUCH} ${PREFIX}/etc/mongodb.conf ; \
diff --git a/databases/mongodb/files/patch-SConstruct b/databases/mongodb/files/patch-SConstruct
index ac3f01d83d64..4c2bea1cf11e 100644
--- a/databases/mongodb/files/patch-SConstruct
+++ b/databases/mongodb/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- SConstruct.orig 2011-04-06 06:40:13.000000000 +0200
-+++ SConstruct 2011-04-09 10:59:56.000000000 +0200
+--- SConstruct.orig 2011-04-06 04:40:13.000000000 +0000
++++ SConstruct 2011-10-04 19:16:33.000000000 +0000
@@ -679,7 +679,10 @@
#make scons colorgcc friendly
@@ -11,4 +11,13 @@
+ env['ENV']['TERM'] = 'dumb'
if linux and has_option( "sharedclient" ):
- env.Append( LINKFLAGS=" -Wl,--as-needed -Wl,-zdefs " ) \ No newline at end of file
+ env.Append( LINKFLAGS=" -Wl,--as-needed -Wl,-zdefs " )
+@@ -1473,7 +1476,7 @@
+ fullInstallName = installDir + "/bin/" + name
+
+ allBinaries += [ name ]
+- if (solaris or linux) and (not has_option("nostrip")):
++ if (solaris or linux or freebsd) and (not has_option("nostrip")):
+ e.AddPostAction( inst, e.Action( 'strip ' + fullInstallName ) )
+
+ if linux and len( COMMAND_LINE_TARGETS ) == 1 and str( COMMAND_LINE_TARGETS[0] ) == "s3dist":