aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2022-02-01 15:11:01 +0000
committerAlex Dupre <ale@FreeBSD.org>2022-02-01 15:12:23 +0000
commit7792db3ba6e29f6db913631620918815d9d4da2f (patch)
tree141b01cd86284c569f9334e089a8a3be1f85b20f
parent117d256c411ae24dc0e1c0868a1825a59300ca4e (diff)
downloadports-7792db3ba6e29f6db913631620918815d9d4da2f.tar.gz
ports-7792db3ba6e29f6db913631620918815d9d4da2f.zip
security/oath-toolkit: fix pam_oath undefined symbol at modul load
PR: 261646 Submitted by: Matt Smith <freebsd@xtaz.uk>
-rw-r--r--security/oath-toolkit/Makefile1
-rw-r--r--security/oath-toolkit/files/patch-pam__oath_Makefile.in51
2 files changed, 50 insertions, 2 deletions
diff --git a/security/oath-toolkit/Makefile b/security/oath-toolkit/Makefile
index 8d794306bfa4..01ca333592cf 100644
--- a/security/oath-toolkit/Makefile
+++ b/security/oath-toolkit/Makefile
@@ -2,6 +2,7 @@
PORTNAME= oath-toolkit
PORTVERSION= 2.6.7
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SAVANNAH
diff --git a/security/oath-toolkit/files/patch-pam__oath_Makefile.in b/security/oath-toolkit/files/patch-pam__oath_Makefile.in
index 427bdc6233bb..354c0a7078f9 100644
--- a/security/oath-toolkit/files/patch-pam__oath_Makefile.in
+++ b/security/oath-toolkit/files/patch-pam__oath_Makefile.in
@@ -1,6 +1,25 @@
---- pam_oath/Makefile.in.orig 2022-01-31 11:17:51 UTC
+--- pam_oath/Makefile.in.orig 2022-02-01 11:49:49 UTC
+++ pam_oath/Makefile.in
-@@ -414,7 +414,7 @@ AM_CPPFLAGS = -I$(builddir)/../liboath
+@@ -149,7 +149,7 @@ am__uninstall_files_from_dir = { \
+ am__installdirs = "$(DESTDIR)$(pammoddir)"
+ LTLIBRARIES = $(pammod_LTLIBRARIES)
+ pam_oath_la_DEPENDENCIES = ../liboath/liboath.la
+-am_pam_oath_la_OBJECTS = pam_oath.lo
++am_pam_oath_la_OBJECTS = pam_oath.lo pam_modutil.lo
+ pam_oath_la_OBJECTS = $(am_pam_oath_la_OBJECTS)
+ AM_V_lt = $(am__v_lt_@AM_V@)
+ am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
+@@ -173,7 +173,8 @@ am__v_at_1 =
+ DEFAULT_INCLUDES = -I.@am__isrc@
+ depcomp = $(SHELL) $(top_srcdir)/build-aux/depcomp
+ am__maybe_remake_depfiles = depfiles
+-am__depfiles_remade = ./$(DEPDIR)/pam_oath.Plo
++am__depfiles_remade = ./$(DEPDIR)/pam_modutil.Plo \
++ ./$(DEPDIR)/pam_oath.Plo
+ am__mv = mv -f
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+@@ -414,7 +416,7 @@ AM_CPPFLAGS = -I$(builddir)/../liboath
EXTRA_DIST = README
pammoddir = $(PAMDIR)
pammod_LTLIBRARIES = pam_oath.la
@@ -9,3 +28,31 @@
# XXX add -Wl,-x too? PAM documentation suggests it.
pam_oath_la_LIBADD = ../liboath/liboath.la
pam_oath_la_LDFLAGS = -module -avoid-version
+@@ -516,6 +518,7 @@ mostlyclean-compile:
+ distclean-compile:
+ -rm -f *.tab.c
+
++@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pam_modutil.Plo@am__quote@ # am--include-marker
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pam_oath.Plo@am__quote@ # am--include-marker
+
+ $(am__depfiles_remade):
+@@ -896,7 +904,8 @@ clean-am: clean-generic clean-libtool clean-pammodLTLI
+
+ distclean: distclean-recursive
+ -rm -f $(am__CONFIG_DISTCLEAN_FILES)
+- -rm -f ./$(DEPDIR)/pam_oath.Plo
++ -rm -f ./$(DEPDIR)/pam_modutil.Plo
++ -rm -f ./$(DEPDIR)/pam_oath.Plo
+ -rm -f Makefile
+ distclean-am: clean-am distclean-compile distclean-generic \
+ distclean-hdr distclean-libtool distclean-tags
+@@ -944,7 +953,8 @@ installcheck-am:
+ maintainer-clean: maintainer-clean-recursive
+ -rm -f $(am__CONFIG_DISTCLEAN_FILES)
+ -rm -rf $(top_srcdir)/autom4te.cache
+- -rm -f ./$(DEPDIR)/pam_oath.Plo
++ -rm -f ./$(DEPDIR)/pam_modutil.Plo
++ -rm -f ./$(DEPDIR)/pam_oath.Plo
+ -rm -f Makefile
+ maintainer-clean-am: distclean-am maintainer-clean-generic
+