aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 13:25:53 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 14:45:27 +0000
commit77e6f6a8b0b23364ed22dc1e18602e6de70e5b09 (patch)
treebdafe430ec0b135345c3af1b85ea9bdf64601006
parent22e2030b6eabc631ee06eb91b0980075705a5b55 (diff)
downloadports-77e6f6a8b0b23364ed22dc1e18602e6de70e5b09.tar.gz
ports-77e6f6a8b0b23364ed22dc1e18602e6de70e5b09.zip
audio/denemo: Fix build with llvm16
- Utilize USES=localbase while I am here Sponsored by: The FreeBSD Foundation
-rw-r--r--audio/denemo/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index cdad24543b7a..4ff869e9e2a0 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -27,7 +27,7 @@ EXTRACT_BEFORE_ARGS=\
-s '!\(/Clarinet in B\).*\(\.denemo\)$$!\1b\2!p' -xf
USES= bison:alias compiler:c++11-lang desktop-file-utils gettext gmake \
- gnome pkgconfig
+ gnome localbase:ldflags pkgconfig
USE_GNOME= intltool librsvg2 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-jack \
@@ -39,8 +39,6 @@ CONFIGURE_ARGS= --enable-jack \
--enable-guile_1_8
CFLAGS+= -Wno-error=return-type
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS EXAMPLES LILYPOND PDF
OPTIONS_SINGLE= TOOLKIT
@@ -65,6 +63,12 @@ LIB_DEPENDS+= libevview3.so:graphics/evince
LIB_DEPENDS+= libatrilview.so:graphics/atril
.endif
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|-lpthread|-pthread| ; \
@@ -103,4 +107,4 @@ post-install-EXAMPLES-on:
(cd ${WRKSRC}/examples && ${INSTALL_DATA} *.denemo \
${STAGEDIR}${EXAMPLESDIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>