aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Sidorkin <osidorkin@gmail.com>2025-01-31 12:04:41 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2025-01-31 12:04:41 +0000
commit7813c72dd2771baf7a4c7e677519d7a8dfc85f26 (patch)
treeda7d962652a07cc7541a38f37fca08bb0f4e0e54
parentfc6655bd257715b2f26a99e2037640aec705288e (diff)
archivers/py-zlib-ng: Add an option to use zlib-ng from ports instead of bundled version
Our archivers/zlib-ng version is newer than bundled one so let's add an option to use it instead of bunlded version (off by default). Maybe we'll switch default to archivers/zlib-ng later. PR: 284470
-rw-r--r--archivers/py-zlib-ng/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/archivers/py-zlib-ng/Makefile b/archivers/py-zlib-ng/Makefile
index e8c707294e31..9da7a3a139b6 100644
--- a/archivers/py-zlib-ng/Makefile
+++ b/archivers/py-zlib-ng/Makefile
@@ -19,6 +19,13 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=51:devel/py-setuptools@${PY_FL
USES= cmake:indirect python
USE_PYTHON= autoplist pep517
+OPTIONS_DEFINE= SYSTEM_ZLIB_NG
+
+SYSTEM_ZLIB_NG_DESC= Use archivers/zlib-ng instead of bundled version
+
+SYSTEM_ZLIB_NG_LIB_DEPENDS= libz-ng.so:archivers/zlib-ng
+SYSTEM_ZLIB_NG_MAKE_ENV= PYTHON_ZLIB_NG_LINK_DYNAMIC=1
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME:S/-/_/}/${PORTNAME:S/-/_/}.cpython-${PYTHON_VER:S/.//}.so