aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2023-03-04 10:37:21 +0000
committerWen Heping <wen@FreeBSD.org>2023-03-04 10:37:21 +0000
commit781b4dae6fc22fc3abc1f7fd0b2ca62cf228f8d0 (patch)
treeafc9757f1c8c3c6e2b8ee364ccceec532072271f
parenta493561df9336b35f15c171a2604759ac037b7cb (diff)
downloadports-781b4dae6fc22fc3abc1f7fd0b2ca62cf228f8d0.tar.gz
ports-781b4dae6fc22fc3abc1f7fd0b2ca62cf228f8d0.zip
astro/py-astroML: Add new port
AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib, and distributed under the BSD license. It contains a growing library of statistical and machine learning routines for analyzing astronomical data in python, loaders for several open astronomical datasets, and a large suite of examples of analyzing and visualizing astronomical datasets.
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-astroML/Makefile26
-rw-r--r--astro/py-astroML/distinfo3
-rw-r--r--astro/py-astroML/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 030c70e37c40..2dc25b13dc44 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -81,6 +81,7 @@
SUBDIR += ptiger
SUBDIR += py-astlib
SUBDIR += py-astral
+ SUBDIR += py-astroML
SUBDIR += py-astropy
SUBDIR += py-astropy-helpers
SUBDIR += py-ephem
diff --git a/astro/py-astroML/Makefile b/astro/py-astroML/Makefile
new file mode 100644
index 000000000000..22692a7b4f29
--- /dev/null
+++ b/astro/py-astroML/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= astroML
+PORTVERSION= 1.0.2
+CATEGORIES= astro
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}-${PORTVERSION}.post1.tar.gz
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Tools for machine learning and data mining in Astronomy
+WWW= https://www.astroml.org/
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.19:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=3.0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.18:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}astropy>=3.0:astro/py-astropy@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist distutils
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.post1
+
+.include <bsd.port.mk>
diff --git a/astro/py-astroML/distinfo b/astro/py-astroML/distinfo
new file mode 100644
index 000000000000..46d4afef4433
--- /dev/null
+++ b/astro/py-astroML/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677925316
+SHA256 (astroML-1.0.2.post1.tar.gz) = 45188a7a88a36ca3ec5a3aa04e5fa227f42d17415a6e168fb523375c1aabe291
+SIZE (astroML-1.0.2.post1.tar.gz) = 115119
diff --git a/astro/py-astroML/pkg-descr b/astro/py-astroML/pkg-descr
new file mode 100644
index 000000000000..cbd4133440ff
--- /dev/null
+++ b/astro/py-astroML/pkg-descr
@@ -0,0 +1,6 @@
+AstroML is a Python module for machine learning and data mining built on
+numpy, scipy, scikit-learn, and matplotlib, and distributed under the BSD
+license. It contains a growing library of statistical and machine learning
+routines for analyzing astronomical data in python, loaders for several
+open astronomical datasets, and a large suite of examples of analyzing and
+visualizing astronomical datasets.