aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2025-01-28 16:49:45 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2025-01-28 17:04:07 +0000
commit783e6b334c5369198c551671ce4c2b6b4c657bba (patch)
treeadb2134991d354d46e203e0dc87a077c96ef8342
parentee84aa4877b92dbc1081cfcb3ff2ae3d85e867cb (diff)
math/p5-PDL-LinearAlgebra: Add p5-PDL-LinearAlgebra 0.432
PDL::LinearAlgebra provides a convenient interface to PDL::LinearAlgebra::Real and PDL::LinearAlgebra::Complex. Since Blas and Lapack use a column major ordering scheme some routines here need to transpose matrices before calling fortran routines and transpose back (see the documentation of each routine). If you need optimized code use directly PDL::LinearAlgebra::Real and PDL::LinearAlgebra::Complex.
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-PDL-LinearAlgebra/Makefile30
-rw-r--r--math/p5-PDL-LinearAlgebra/distinfo3
-rw-r--r--math/p5-PDL-LinearAlgebra/pkg-descr6
-rw-r--r--math/p5-PDL-LinearAlgebra/pkg-plist10
5 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 905630756c77..3a367ad0cf8e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -829,6 +829,7 @@
SUBDIR += p5-PDL-IO-GD
SUBDIR += p5-PDL-IO-HDF
SUBDIR += p5-PDL-IO-IDL
+ SUBDIR += p5-PDL-LinearAlgebra
SUBDIR += p5-Parse-Range
SUBDIR += p5-Roman
SUBDIR += p5-Set-IntSpan
diff --git a/math/p5-PDL-LinearAlgebra/Makefile b/math/p5-PDL-LinearAlgebra/Makefile
new file mode 100644
index 000000000000..19fcc3d4f183
--- /dev/null
+++ b/math/p5-PDL-LinearAlgebra/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= PDL-LinearAlgebra
+PORTVERSION= 0.432
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Linear Algebra utils for PDL
+WWW= https://metacpan.org/dist/PDL-LinearAlgebra
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/Artistic_2
+
+BUILD_DEPENDS= p5-Devel-CheckLib>=0:devel/p5-Devel-CheckLib \
+ p5-ExtUtils-F77>=1.26:lang/p5-ExtUtils-F77 \
+ p5-PkgConfig>=0:devel/p5-PkgConfig \
+ ${RUN_DEPENDS}
+RUN_DEPENDS= p5-PDL>=2.096:math/p5-PDL
+
+USES= blaslapack perl5
+USE_PERL5= configure
+
+MAKE_JOBS_UNSAFE= yes
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PDL/LinearAlgebra/Complex/Complex.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PDL/LinearAlgebra/Real/Real.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PDL/LinearAlgebra/Trans/Trans.so
+
+.include <bsd.port.mk>
diff --git a/math/p5-PDL-LinearAlgebra/distinfo b/math/p5-PDL-LinearAlgebra/distinfo
new file mode 100644
index 000000000000..fd6151b344b9
--- /dev/null
+++ b/math/p5-PDL-LinearAlgebra/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1736671153
+SHA256 (PDL-LinearAlgebra-0.432.tar.gz) = 6c819654436fcd85ae82d2ec5d12f863b5f35d64ef46e9b5393f72913be2f182
+SIZE (PDL-LinearAlgebra-0.432.tar.gz) = 159684
diff --git a/math/p5-PDL-LinearAlgebra/pkg-descr b/math/p5-PDL-LinearAlgebra/pkg-descr
new file mode 100644
index 000000000000..c68c606f0f6c
--- /dev/null
+++ b/math/p5-PDL-LinearAlgebra/pkg-descr
@@ -0,0 +1,6 @@
+PDL::LinearAlgebra provides a convenient interface to PDL::LinearAlgebra::Real
+and PDL::LinearAlgebra::Complex. Since Blas and Lapack use a column major
+ordering scheme some routines here need to transpose matrices before calling
+fortran routines and transpose back (see the documentation of each routine). If
+you need optimized code use directly PDL::LinearAlgebra::Real and
+PDL::LinearAlgebra::Complex.
diff --git a/math/p5-PDL-LinearAlgebra/pkg-plist b/math/p5-PDL-LinearAlgebra/pkg-plist
new file mode 100644
index 000000000000..f178530b6943
--- /dev/null
+++ b/math/p5-PDL-LinearAlgebra/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_ARCH%%/PDL/LinearAlgebra.pm
+%%SITE_ARCH%%/PDL/LinearAlgebra/Complex.pm
+%%SITE_ARCH%%/PDL/LinearAlgebra/Real.pm
+%%SITE_ARCH%%/PDL/LinearAlgebra/Special.pm
+%%SITE_ARCH%%/PDL/LinearAlgebra/Trans.pm
+%%SITE_ARCH%%/auto/PDL/LinearAlgebra/Complex/Complex.so
+%%SITE_ARCH%%/auto/PDL/LinearAlgebra/Real/Real.so
+%%SITE_ARCH%%/auto/PDL/LinearAlgebra/Trans/Trans.so
+%%PERL5_MAN3%%/PDL::LinearAlgebra.3.gz
+%%PERL5_MAN3%%/PDL::LinearAlgebra::Special.3.gz