aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-26 17:09:59 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-26 17:11:34 +0000
commit786872ee08c04b245a37d9dba50a4e484d462c36 (patch)
tree2fbf3c35a6c8c51f945f3abcd19d69b6a526add3
parentd709ba8de8ec14887beffe99233eec09b26b7ed1 (diff)
downloadports-786872ee08c04b245a37d9dba50a4e484d462c36.tar.gz
ports-786872ee08c04b245a37d9dba50a4e484d462c36.zip
www/php81-opcache: Fix zend extension
- Somehow the php:zend in lang/php81 Makefile is not properly read and using the default php:ext. For now fix it by adding it to the slave ports. PR: 261488 Reported by: mfburdett@gmail.com
-rw-r--r--lang/php81/Makefile1
-rw-r--r--www/php81-opcache/Makefile7
2 files changed, 5 insertions, 3 deletions
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 57d88cc1f4e9..8220c29387f4 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -412,7 +412,6 @@ CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
# This is needed by Zend extensions, keep before everything.
PHP_MOD_PRIO= 10
CONFIGURE_ARGS+= --enable-opcache
-USES+= localbase php:zend
.endif
.if ${PHP_MODNAME} == "pcntl"
diff --git a/www/php81-opcache/Makefile b/www/php81-opcache/Makefile
index 3799a62af053..5971b05f3eae 100644
--- a/www/php81-opcache/Makefile
+++ b/www/php81-opcache/Makefile
@@ -1,7 +1,10 @@
+PORTREVISION= 1
CATEGORIES= www
-MASTERDIR= ${.CURDIR}/../../lang/php81
-
PKGNAMESUFFIX= -opcache
+USES= php:zend,noflavors
+
+MASTERDIR= ${.CURDIR}/../../lang/php81
+
.include "${MASTERDIR}/Makefile"