aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-04 20:28:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-04 20:29:14 +0000
commit792d1b893dab898fcdc23817353316380d881a42 (patch)
treec217d2887476c0d65b6b23fa748a66aa4e1f446f
parentdb5eeb201b93c19c42724ec98f8ca1be9e88db15 (diff)
downloadports-792d1b893dab898fcdc23817353316380d881a42.tar.gz
ports-792d1b893dab898fcdc23817353316380d881a42.zip
math/lapackpp: New port: C++ API for the Linear Algebra PACKage
-rw-r--r--math/Makefile1
-rw-r--r--math/lapackpp/Makefile27
-rw-r--r--math/lapackpp/distinfo3
-rw-r--r--math/lapackpp/pkg-descr13
-rw-r--r--math/lapackpp/pkg-plist13
5 files changed, 57 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 536cc9c7b617..a16620fb827b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -416,6 +416,7 @@
SUBDIR += lapack++
SUBDIR += lapack95
SUBDIR += lapacke
+ SUBDIR += lapackpp
SUBDIR += laspack
SUBDIR += latte-integrale
SUBDIR += lcalc
diff --git a/math/lapackpp/Makefile b/math/lapackpp/Makefile
new file mode 100644
index 000000000000..cb3dcf7a2705
--- /dev/null
+++ b/math/lapackpp/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= lapackpp
+DISTVERSION= 2022.05.00
+CATEGORIES= math
+MASTER_SITES= https://bitbucket.org/icl/${PORTNAME}/downloads/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ API for the Linear Algebra PACKage
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lapacke>0:math/lapacke
+LIB_DEPENDS= libblaspp.so:math/blaspp \
+ libopenblas.so:math/openblas
+TEST_DEPENDS= lapacke>0:math/lapacke
+# fails to find xblas, see https://bitbucket.org/icl/lapackpp/issues/14/fails-to-find-xblas
+
+USES= cmake:testing fortran localbase:ldflags
+
+CMAKE_OFF= build_tests
+CMAKE_TESTING_ON= build_tests
+CMAKE_TESTING_TARGET= tester
+
+post-test:
+ @cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} test/tester
+
+.include <bsd.port.mk>
diff --git a/math/lapackpp/distinfo b/math/lapackpp/distinfo
new file mode 100644
index 000000000000..41235e797af9
--- /dev/null
+++ b/math/lapackpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1656964791
+SHA256 (lapackpp-2022.05.00.tar.gz) = d0f548cbc9d4ac46b1f961834d113173c0b433074f77bcfd69c7c31cb89b7ff2
+SIZE (lapackpp-2022.05.00.tar.gz) = 1080533
diff --git a/math/lapackpp/pkg-descr b/math/lapackpp/pkg-descr
new file mode 100644
index 000000000000..50431dc3c783
--- /dev/null
+++ b/math/lapackpp/pkg-descr
@@ -0,0 +1,13 @@
+The objective of LAPACK++ is to provide a convenient, performance
+oriented API for development in the C++ language, that, for the most
+part, preserves established conventions, while, at the same time,
+takes advantages of modern C++ features, such as: namespaces,
+templates, exceptions, etc.
+
+LAPACK++ is part of the SLATE project (Software for Linear Algebra
+Targeting Exascale), which is funded by the Department of Energy as
+part of its Exascale Computing Initiative (ECP). Closely related to
+LAPACK++ is the BLAS++ project, which provides a C++ API for BLAS and
+Batch BLAS.
+
+WWW: https://bitbucket.org/icl/blaspp/src/master/
diff --git a/math/lapackpp/pkg-plist b/math/lapackpp/pkg-plist
new file mode 100644
index 000000000000..eb1265ef0cd2
--- /dev/null
+++ b/math/lapackpp/pkg-plist
@@ -0,0 +1,13 @@
+include/lapack.hh
+include/lapack/config.h
+include/lapack/defines.h
+include/lapack/flops.hh
+include/lapack/fortran.h
+include/lapack/mangling.h
+include/lapack/util.hh
+include/lapack/wrappers.hh
+lib/lapackpp/lapackppConfig.cmake
+lib/lapackpp/lapackppConfigVersion.cmake
+lib/lapackpp/lapackppTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/lapackpp/lapackppTargets.cmake
+lib/liblapackpp.so