aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2019-03-25 14:03:16 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2019-03-25 14:03:16 +0000
commit793ff99596bcb1c69d95deb7ae712a8c71600280 (patch)
tree3935a51c25fa2c2e608fec13a6e52fda1258da55
parent475d777646d9715313308ca0b535560f873ad4dc (diff)
downloadports-793ff99596bcb1c69d95deb7ae712a8c71600280.tar.gz
ports-793ff99596bcb1c69d95deb7ae712a8c71600280.zip
New port: devel/deployer
A deployment tool written in PHP with support for popular frameworks out of the box. WWW: https://deployer.org/ Sponsored by: anyMOTION GRAPHICS GmbH
Notes
Notes: svn path=/head/; revision=496823
-rw-r--r--devel/Makefile1
-rw-r--r--devel/deployer/Makefile35
-rw-r--r--devel/deployer/distinfo3
-rw-r--r--devel/deployer/pkg-descr4
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9448ffab634c..fc572caee49f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -446,6 +446,7 @@
SUBDIR += deheader
SUBDIR += delta
SUBDIR += dep
+ SUBDIR += deployer
SUBDIR += derelict-sdl2
SUBDIR += derelict-util
SUBDIR += desktop-file-utils
diff --git a/devel/deployer/Makefile b/devel/deployer/Makefile
new file mode 100644
index 000000000000..044fb6f5be28
--- /dev/null
+++ b/devel/deployer/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= deployer
+DISTVERSION= 6.4.3
+CATEGORIES= devel
+MASTER_SITES= https://deployer.org/releases/v${DISTVERSION}/
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
+DISTNAME= deployer
+EXTRACT_SUFX= .phar
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= tz@FreeBSD.org
+COMMENT= Deployment tool for PHP
+
+LICENSE= MIT
+
+USES= php:flavors
+USE_PHP= curl iconv json openssl pcntl phar posix zlib
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/deployer \
+ bin/deployer.phar
+
+do-extract:
+ ${MKDIR} ${WRKSRC}/
+ ${CP} ${_DISTDIR}/deployer.phar ${WRKSRC}/
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/deployer.phar ${STAGEDIR}${PREFIX}/bin/
+ ${LN} -s deployer.phar ${STAGEDIR}${PREFIX}/bin/deployer
+
+.include <bsd.port.mk>
diff --git a/devel/deployer/distinfo b/devel/deployer/distinfo
new file mode 100644
index 000000000000..de0429514fc4
--- /dev/null
+++ b/devel/deployer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1553506033
+SHA256 (deployer-6.4.3/deployer.phar) = d0b0d4dbd834c1d5e387981042d452017dd92eb5db00c8fa1db31ad343d9bedf
+SIZE (deployer-6.4.3/deployer.phar) = 351845
diff --git a/devel/deployer/pkg-descr b/devel/deployer/pkg-descr
new file mode 100644
index 000000000000..10427d6c5f9b
--- /dev/null
+++ b/devel/deployer/pkg-descr
@@ -0,0 +1,4 @@
+A deployment tool written in PHP with support for popular frameworks out of the
+box.
+
+WWW: https://deployer.org/