aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÄlven <alster@vinterdalen.se>2024-11-05 10:26:37 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-11-05 10:27:32 +0000
commit7945736569ee6db4563ff713a70a5876d9c5d836 (patch)
tree11766fe97a46365346cc27240ea23411f26b5d65
parent3922a8598ffdd1691573dd654543e0a12c5fd1a0 (diff)
downloadports-7945736569ee6db4563ff713a70a5876d9c5d836.tar.gz
ports-7945736569ee6db4563ff713a70a5876d9c5d836.zip
devel/libqb: Improve the port
* Add EXAMPLES option * Add support for activation of tests (still failing) * Fix conditional BUILD_DEPENDS on libxml2 for doxygen2man * Fix a typo PR: 282536 MFH: 2024Q4
-rw-r--r--devel/libqb/Makefile20
-rw-r--r--devel/libqb/files/extra-DOXYGEN_OFF-patch-configure.ac11
-rw-r--r--devel/libqb/pkg-plist8
3 files changed, 34 insertions, 5 deletions
diff --git a/devel/libqb/Makefile b/devel/libqb/Makefile
index 886818ad2d40..e2c063a14175 100644
--- a/devel/libqb/Makefile
+++ b/devel/libqb/Makefile
@@ -1,20 +1,22 @@
PORTNAME= libqb
DISTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://github.com/ClusterLabs/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= alster@vinterdalen.se
-COMMENT= High performance logging, tracing, ipc, and polling library
+COMMENT= High performance logging, tracing, IPC, and polling library
WWW= https://github.com/ClusterLabs/libqb/wiki
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+# HACK, see https://github.com/freebsd/poudriere/issues/1131#issuecomment-2073099527
+BUILD_DEPENDS= ${TEST_DEPENDS}
TEST_DEPENDS= checkmk:devel/check
-USES= cpe gmake gnome libtool pkgconfig python tar:xz
+USES= cpe gmake libtool pkgconfig python tar:xz
CPE_VENDOR= clusterlabs
-USE_GNOME= libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -31,14 +33,22 @@ GROUPS= haclient
PLIST_SUB+= QB_SOCKET_DIR=${QB_SOCKET_DIR}
-OPTIONS_DEFINE= DOCS DOXYGEN
+OPTIONS_DEFINE= DOCS DOXYGEN EXAMPLES
OPTIONS_SUB= yes
DOXYGEN_IMPLIES= DOCS
-DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
+ libxml2>0:textproc/libxml2
+DOXYGEN_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-DOXYGEN_OFF-patch-configure.ac
QB_SOCKET_DIR?= /var/run/qb
+TESTING_UNSAFE= yes
+
+post-extract-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
post-configure:
${REINPLACE_CMD} -e 's/install: install-am/install:/g' ${WRKSRC}/doxygen2man/Makefile
diff --git a/devel/libqb/files/extra-DOXYGEN_OFF-patch-configure.ac b/devel/libqb/files/extra-DOXYGEN_OFF-patch-configure.ac
new file mode 100644
index 000000000000..0712f9e161b1
--- /dev/null
+++ b/devel/libqb/files/extra-DOXYGEN_OFF-patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2023-06-07 06:48:54 UTC
++++ configure.ac
+@@ -168,7 +168,7 @@ fi
+ fi
+
+ # For building doxygen2man and man pages
+-PKG_CHECK_MODULES([libxml], [libxml-2.0])
++# PKG_CHECK_MODULES([libxml], [libxml-2.0])
+
+ # if we are not cross-compiling, we can use the locally built
+ # version of doxygen2man, otherwise we can look for
diff --git a/devel/libqb/pkg-plist b/devel/libqb/pkg-plist
index d3d72c2f33ba..59c148191842 100644
--- a/devel/libqb/pkg-plist
+++ b/devel/libqb/pkg-plist
@@ -21,6 +21,14 @@ sbin/qb-blackbox
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/README.markdown
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.am
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ipcclient.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ipcserver.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mapnotify.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simplelog.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcpclient.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcpserver.c
%%DOXYGEN%%share/man/man3/qb_array_create.3.gz
%%DOXYGEN%%share/man/man3/qb_array_create_2.3.gz
%%DOXYGEN%%share/man/man3/qb_array_elems_per_bin_get.3.gz