aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2022-12-08 17:53:31 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2022-12-08 19:00:46 +0000
commit799245580a718022ce7bb96012a2720ede33a8ae (patch)
tree06497e4202b34e0b1fd7cea5e5c4cfb51f857f70
parent07b3e671fb24b8fecf06e76c84859e97508a6713 (diff)
downloadports-799245580a718022ce7bb96012a2720ede33a8ae.tar.gz
ports-799245580a718022ce7bb96012a2720ede33a8ae.zip
graphics/mesa: Do not add USE_LDCONFIG for every mesa ports
Not every mesa ports provides shared libraries intented for dynamic uses so stop running ldconfig script for those ports. Sponsored by: Beckhoff Automation GmbH & Co. KG
-rw-r--r--graphics/libosmesa/Makefile1
-rw-r--r--graphics/mesa-dri/Makefile2
-rw-r--r--graphics/mesa-dri/Makefile.common2
-rw-r--r--graphics/mesa-gallium-va/Makefile1
-rw-r--r--graphics/mesa-gallium-vdpau/Makefile1
-rw-r--r--graphics/mesa-gallium-xa/Makefile1
-rw-r--r--graphics/mesa-libs/Makefile2
-rw-r--r--lang/clover/Makefile2
8 files changed, 10 insertions, 2 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index a9feb722e252..ba511d86c6db 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -12,6 +12,7 @@ LIB_DEPENDS+= libLLVM-${LLVM_DEFAULT}.so:devel/llvm${LLVM_DEFAULT}
USES= xorg
USE_XORG= xorgproto
+USE_LDCONFIG= yes
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
diff --git a/graphics/mesa-dri/Makefile b/graphics/mesa-dri/Makefile
index ac87f4cef889..e4fe1b570261 100644
--- a/graphics/mesa-dri/Makefile
+++ b/graphics/mesa-dri/Makefile
@@ -26,6 +26,8 @@ ZSTD_DESC= Use ZSTD for shader cache
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
ZSTD_MESON_ENABLED= zstd
+USE_LDCONFIG= yes
+
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
diff --git a/graphics/mesa-dri/Makefile.common b/graphics/mesa-dri/Makefile.common
index 913e78c73650..545d2fdbb405 100644
--- a/graphics/mesa-dri/Makefile.common
+++ b/graphics/mesa-dri/Makefile.common
@@ -54,8 +54,6 @@ LIB_DEPENDS+= libelf.so:devel/libelf
USES+= compiler:c++11-lib bison meson pathfix pkgconfig \
python:3.6+,build shebangfix tar:xz
-USE_LDCONFIG= yes
-
.if ${/usr/bin/ld:L:tA} != /usr/bin/ld.lld
# --build-id isn't supported by old GNU ld.bfd in base
# Also ld.bfd have problems that seems related to --as-needed
diff --git a/graphics/mesa-gallium-va/Makefile b/graphics/mesa-gallium-va/Makefile
index 007bfcd2d437..b8b94c8ff3b1 100644
--- a/graphics/mesa-gallium-va/Makefile
+++ b/graphics/mesa-gallium-va/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mesa-gallium-va
PORTVERSION= ${MESAVERSION}
+PORTREVISION= 1
CATEGORIES= graphics
COMMENT= Mesa Gallium VAAPI drivers
diff --git a/graphics/mesa-gallium-vdpau/Makefile b/graphics/mesa-gallium-vdpau/Makefile
index 105c8d45823f..cc581fe1f3d3 100644
--- a/graphics/mesa-gallium-vdpau/Makefile
+++ b/graphics/mesa-gallium-vdpau/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mesa-gallium-vdpau
PORTVERSION= ${MESAVERSION}
+PORTREVISION= 1
CATEGORIES= graphics
COMMENT= Mesa Gallium VDPAU drivers
diff --git a/graphics/mesa-gallium-xa/Makefile b/graphics/mesa-gallium-xa/Makefile
index ed3a9b174157..f741405337d0 100644
--- a/graphics/mesa-gallium-xa/Makefile
+++ b/graphics/mesa-gallium-xa/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mesa-gallium-xa
PORTVERSION= ${MESAVERSION}
+PORTREVISION= 1
CATEGORIES= graphics
COMMENT= Mesa Gallium XA state tracker
diff --git a/graphics/mesa-libs/Makefile b/graphics/mesa-libs/Makefile
index 8e6bbcdff57d..dcc7b5422b80 100644
--- a/graphics/mesa-libs/Makefile
+++ b/graphics/mesa-libs/Makefile
@@ -30,6 +30,8 @@ ZSTD_DESC= Use ZSTD for shader cache
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
ZSTD_MESON_ENABLED= zstd
+USE_LDCONFIG= yes
+
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index 001266a3ea57..7c3d13c9be68 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -19,6 +19,8 @@ LIB_DEPENDS= libOpenCL.so:devel/ocl-icd \
RUN_DEPENDS= libclc>=0.3.0:devel/libclc \
opencl>=0:devel/opencl
+USE_LDCONFIG= yes
+
.include <bsd.port.options.mk>
.include "${.CURDIR:H:H}/graphics/mesa-dri/Makefile.common"