aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-02 21:53:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-02 21:53:41 +0000
commit7a6314056c308f38a64159648bb8378c82ef3227 (patch)
tree99bb1d2c7b3535e8e0fb18079c34a8d42e1c02d2
parent13bea7e9f9cf0588acc831f7549bc687f6fded07 (diff)
downloadports-7a6314056c308f38a64159648bb8378c82ef3227.tar.gz
ports-7a6314056c308f38a64159648bb8378c82ef3227.zip
FreeBSD port of the NetBSD db(1) command.
manipulate db(3)'s btree(3) and hash(3) databases Submitted by: edwin@mavetju.org
Notes
Notes: svn path=/head/; revision=97119
-rw-r--r--databases/Makefile1
-rw-r--r--databases/db/Makefile21
-rw-r--r--databases/db/distinfo1
-rw-r--r--databases/db/files/patch-db.c60
-rw-r--r--databases/db/pkg-descr3
-rw-r--r--databases/db/pkg-plist1
6 files changed, 87 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b638a34930cd..d24f68103a62 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -9,6 +9,7 @@
SUBDIR += cdb
SUBDIR += clip
SUBDIR += cyrus-imspd
+ SUBDIR += db
SUBDIR += db2
SUBDIR += db3
SUBDIR += db4
diff --git a/databases/db/Makefile b/databases/db/Makefile
new file mode 100644
index 000000000000..e5c43829daab
--- /dev/null
+++ b/databases/db/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: db-netbsd
+# Date created: 1 January 2004
+# Whom: Edwin Groothuis (edwin@mavetju.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= db
+PORTVERSION= 1.11
+CATEGORIES= databases
+MASTER_SITES= http://www.mavetju.org/download/
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= Manipulate db(3)'s btree(3) and hash(3) databases - NetBSD port
+
+MAN1= db.1
+MANCOMPRESSED= yes
+
+MAKE_ENV= BINDIR=${PREFIX}/bin SHAREDIR=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/databases/db/distinfo b/databases/db/distinfo
new file mode 100644
index 000000000000..f63d87784287
--- /dev/null
+++ b/databases/db/distinfo
@@ -0,0 +1 @@
+MD5 (db-1.11.tar.gz) = 2a230f51506fe313ec557a5bb07069b2
diff --git a/databases/db/files/patch-db.c b/databases/db/files/patch-db.c
new file mode 100644
index 000000000000..1cb11cfa0bcc
--- /dev/null
+++ b/databases/db/files/patch-db.c
@@ -0,0 +1,60 @@
+--- db.c.orig Sat Jan 3 08:43:09 2004
++++ db.c Sat Jan 3 08:43:43 2004
+@@ -90,7 +90,6 @@
+ DB *db;
+ char *outputsep = "\t";
+ int encflags = 0;
+-char *extra_echars = NULL;
+
+ int
+ main(int argc, char *argv[])
+@@ -120,7 +119,7 @@
+
+ /* parse arguments */
+ while ( (ch = getopt(argc, argv,
+- "CDdE:F:f:iKm:NO:qRS:T:U:VwX:")) != -1) {
++ "CDdE:F:f:iKm:NO:qRS:T:U:Vw")) != -1) {
+ switch (ch) {
+
+ case 'C':
+@@ -224,10 +223,6 @@
+ flags |= F_WRITE;
+ break;
+
+- case 'X':
+- extra_echars = optarg;
+- break;
+-
+ default:
+ usage();
+
+@@ -548,11 +543,7 @@
+ buflen = elen;
+ }
+ *edata = buf;
+- if (extra_echars) {
+- return (strsvisx(buf, data, len, encflags, extra_echars));
+- } else {
+- return (strvisx(buf, data, len, encflags));
+- }
++ return (strvisx(buf, data, len, encflags));
+ }
+
+ int
+@@ -625,7 +616,7 @@
+ const char *p = getprogname();
+
+ fprintf(stderr,
+- "Usage: %s [-KiNqV] [-E end] [-f inf] [-O str] [-S chr] [-T str] [-X str]\n"
++ "Usage: %s [-KiNqV] [-E end] [-f inf] [-O str] [-S chr] [-T str] \n"
+ " type dbfile [key [...]]\n"
+ " %s -d [-iNq] [-E end] [-f inf] [-U chr] type dbfile [key [...]]\n"
+ " %s -w [-CDiNqR] [-E end] [-F sep] [-f inf] [-m mod] [-U chr]\n"
+@@ -653,7 +644,6 @@
+ "\t-T str\toptions to control -S encoding like vis(1) options\n"
+ "\t-U chr\titems to strunvis(3) decode: 'k'ey, 'v'alue, 'b'oth\n"
+ "\t-V\tprint value\n"
+- "\t-X str\textra characters to encode with -S\n"
+ );
+ exit(1);
+ }
diff --git a/databases/db/pkg-descr b/databases/db/pkg-descr
new file mode 100644
index 000000000000..13c55d87a341
--- /dev/null
+++ b/databases/db/pkg-descr
@@ -0,0 +1,3 @@
+db allows manipulation of btree(3) and hash(3) (db(3)) databases.
+
+WWW: http://cvsweb.netbsd.org/bsdweb.cgi/src/usr.bin/db/
diff --git a/databases/db/pkg-plist b/databases/db/pkg-plist
new file mode 100644
index 000000000000..f3a7f079a736
--- /dev/null
+++ b/databases/db/pkg-plist
@@ -0,0 +1 @@
+bin/db