aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2016-09-17 18:13:34 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2016-09-17 18:13:34 +0000
commit7abe94a17f53c106c99aa391d410d254d1afa788 (patch)
treefa49c944c6dc4c11aea49b63a61939d7a4758327
parentc39965e0df3d0620299b45cc6a44cc8554ebe148 (diff)
downloadports-7abe94a17f53c106c99aa391d410d254d1afa788.tar.gz
ports-7abe94a17f53c106c99aa391d410d254d1afa788.zip
- limit python version to 2.7
- re- generate mod_python33 patch files PR: 212446 Reported by: George Michaelson
Notes
Notes: svn path=/head/; revision=422338
-rw-r--r--www/mod_python33/Makefile2
-rw-r--r--www/mod_python33/files/patch-configure7
-rw-r--r--www/mod_python33/files/patch-src__connobject.c6
-rw-r--r--www/mod_python35/Makefile2
4 files changed, 8 insertions, 9 deletions
diff --git a/www/mod_python33/Makefile b/www/mod_python33/Makefile
index 136b480deeeb..81f4780d5743 100644
--- a/www/mod_python33/Makefile
+++ b/www/mod_python33/Makefile
@@ -18,7 +18,7 @@ LICENSE= APACHE20
CONFLICTS_INSTALL= ap2[24]-mod_python3[^3]*
USE_APACHE= 22
-USES= cpe python tar:tgz
+USES= cpe python:2.7 tar:tgz
CPE_VENDOR= apache
GNU_CONFIGURE= yes
diff --git a/www/mod_python33/files/patch-configure b/www/mod_python33/files/patch-configure
index 731799fa07d2..8cec0ee6b450 100644
--- a/www/mod_python33/files/patch-configure
+++ b/www/mod_python33/files/patch-configure
@@ -1,6 +1,6 @@
---- ./configure.orig 2006-03-11 03:46:52.000000000 +0000
-+++ ./configure 2014-08-02 22:49:33.000000000 +0000
-@@ -3013,7 +3013,7 @@
+--- configure.orig 2006-03-11 03:46:52 UTC
++++ configure
+@@ -3013,7 +3013,7 @@ echo "$as_me:$LINENO: checking linker fl
echo $ECHO_N "checking linker flags used to link Python... $ECHO_C" >&6
PyLFS=`grep "^LINKFORSHARED=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
@@ -9,4 +9,3 @@
LDFLAGS="${LDFLAGS} ${PyLFS} ${PyLDFLAGS}"
LDFLAGS="${LDFLAGS} ${PY_LDFLAGS}"
echo "$as_me:$LINENO: result: $PY_LDFLAGS" >&5
-
diff --git a/www/mod_python33/files/patch-src__connobject.c b/www/mod_python33/files/patch-src__connobject.c
index aa665ffebd74..c2e8ddefe9fd 100644
--- a/www/mod_python33/files/patch-src__connobject.c
+++ b/www/mod_python33/files/patch-src__connobject.c
@@ -1,6 +1,6 @@
---- src/connobject.c.orig 2008-08-28 12:30:24.000000000 +0000
-+++ src/connobject.c 2008-08-28 12:30:35.000000000 +0000
-@@ -139,7 +139,7 @@
+--- src/connobject.c.orig 2006-12-03 04:36:37 UTC
++++ src/connobject.c
+@@ -139,7 +139,7 @@ static PyObject * _conn_read(conn_rec *c
bytes_read = 0;
while ((bytes_read < len || len == 0) &&
diff --git a/www/mod_python35/Makefile b/www/mod_python35/Makefile
index cea6a1267416..ae6436acb8f3 100644
--- a/www/mod_python35/Makefile
+++ b/www/mod_python35/Makefile
@@ -19,7 +19,7 @@ LICENSE= APACHE20
CONFLICTS_INSTALL= ap2[24]-mod_python3[^5]*
USE_APACHE= 22+
-USES= cpe python tar:tgz
+USES= cpe python:2.7 tar:tgz
CPE_VENDOR= apache
SUB_FILES= pkg-message 270_mod_python.conf.sample