aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-09-11 01:12:00 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-09-11 03:40:14 +0000
commit7b33455435ad97129eef454f31f64ba5e19fe943 (patch)
tree9d9380f0c043aa83ab9653cc5211c1740fb5c1e5
parent417b216a29a36d76e70e96d0ab0ceeda43ef1f68 (diff)
downloadports-7b33455435ad97129eef454f31f64ba5e19fe943.tar.gz
ports-7b33455435ad97129eef454f31f64ba5e19fe943.zip
devel/py-fire: New port: Library for automatically generating command line interfaces (CLIs)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-fire/Makefile21
-rw-r--r--devel/py-fire/distinfo3
-rw-r--r--devel/py-fire/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2a8495521a11..70aa3121432f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4666,6 +4666,7 @@
SUBDIR += py-find-libpython
SUBDIR += py-findlibs
SUBDIR += py-findpython
+ SUBDIR += py-fire
SUBDIR += py-first
SUBDIR += py-fixtures
SUBDIR += py-flake8
diff --git a/devel/py-fire/Makefile b/devel/py-fire/Makefile
new file mode 100644
index 000000000000..6eee696d820a
--- /dev/null
+++ b/devel/py-fire/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= fire
+DISTVERSION= 0.5.0
+CATEGORIES= devel science
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for automatically generating command line interfaces (CLIs)
+WWW= https://github.com/google/python-fire
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}termcolor>=0:devel/py-termcolor@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils flavors autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-fire/distinfo b/devel/py-fire/distinfo
new file mode 100644
index 000000000000..02598d3e580b
--- /dev/null
+++ b/devel/py-fire/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1694391774
+SHA256 (fire-0.5.0.tar.gz) = a6b0d49e98c8963910021f92bba66f65ab440da2982b78eb1bbf95a0a34aacc6
+SIZE (fire-0.5.0.tar.gz) = 88282
diff --git a/devel/py-fire/pkg-descr b/devel/py-fire/pkg-descr
new file mode 100644
index 000000000000..1f5b50903b2e
--- /dev/null
+++ b/devel/py-fire/pkg-descr
@@ -0,0 +1,10 @@
+Python Fire is a library for automatically generating command line interfaces
+(CLIs) from absolutely any Python object.
+
+* Python Fire is a simple way to create a CLI in Python.
+* Python Fire is a helpful tool for developing and debugging Python code.
+* Python Fire helps with exploring existing code or turning other people's code
+ into a CLI.
+* Python Fire makes transitioning between Bash and Python easier.
+* Python Fire makes using a Python REPL easier by setting up the REPL with the
+ modules and variables you'll need already imported and created.