aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-03-20 01:43:48 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-03-20 01:43:48 +0000
commit7b5633d04690ab0194dcbe7edcf39584f2ac2c10 (patch)
treedf17eab02f59671383b09cb1a84a78b571e6ac83
parentea02c904697c622af1e87170e1b8d139f48395d4 (diff)
downloadports-7b5633d04690ab0194dcbe7edcf39584f2ac2c10.tar.gz
ports-7b5633d04690ab0194dcbe7edcf39584f2ac2c10.zip
multimedia/xvid: fix build on powerpc with LLVM 13
../../src/image/ppc_asm/colorspace_altivec.c:434:1: error: address of register variable requested MAKE_COLORSPACE_ALTIVEC_FROM_RGB(bgra_to_yv12_altivec_c, 4, 8, 2, RGB_TO_YV12_ALTIVEC, 2, 1, 0, 0) ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ../../src/image/ppc_asm/colorspace_altivec.c:65:5: note: expanded from macro 'MAKE_COLORSPACE_ALTIVEC_FROM_RGB' shift_consts[0] = vec_add(vec_splat_u32(12), vec_splat_u32(12)); \ ^~~~~~~~~~~~ Fix similar to 0efce95397d4b53be14448a803902191ab8c1df3.
-rw-r--r--multimedia/xvid/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/multimedia/xvid/Makefile b/multimedia/xvid/Makefile
index 0451c26a09cf..575d26f9ece5 100644
--- a/multimedia/xvid/Makefile
+++ b/multimedia/xvid/Makefile
@@ -21,6 +21,7 @@ USE_LDCONFIG= yes
# PR230208 Allow relocations against read-only segments (override lld default)
LDFLAGS_i386= -Wl,-z,notext
+CFLAGS_powerpc= -Dregister=
CONFIGURE_ENV+= ac_cv_prog_ac_yasm=no
PLIST_FILES= include/xvid.h \