aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:06:40 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:06:40 +0000
commit7be404eb3fcc6b1994712ba54ceb56f81ab474e5 (patch)
treeb8e5fffaa545436e1e8a8ac129df36c07665104d
parent2677283c3d6466b85714b1d8c2277678e4aa5bb2 (diff)
downloadports-7be404eb3fcc6b1994712ba54ceb56f81ab474e5.tar.gz
ports-7be404eb3fcc6b1994712ba54ceb56f81ab474e5.zip
Add USES=xorg USES=gl, ports categories l
Add USES=xorg and USES=gl to ports in categories starting with 'l' While here, try to sprinkle other USES (mostly gnome and sdl) as needed.
Notes
Notes: svn path=/head/; revision=516915
-rw-r--r--lang/clisp/Makefile2
-rw-r--r--lang/gjs/Makefile2
-rw-r--r--lang/hugs/Makefile2
-rw-r--r--lang/icon/Makefile1
-rw-r--r--lang/ocaml/Makefile1
-rw-r--r--lang/php71/Makefile.ext7
-rw-r--r--lang/php72/Makefile.ext7
-rw-r--r--lang/php73/Makefile.ext5
-rw-r--r--lang/php74/Makefile.ext5
-rw-r--r--lang/ptoc/Makefile2
-rw-r--r--lang/py-qt5-qml/Makefile2
-rw-r--r--lang/seed7/Makefile2
-rw-r--r--lang/squeak/Makefile2
-rw-r--r--lang/swi-pl/Makefile2
-rw-r--r--lang/yabasic/Makefile2
-rw-r--r--lang/yorick/Makefile2
16 files changed, 27 insertions, 19 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index 5963a1c0107a..70739786cb89 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -105,6 +105,7 @@ LDFLAGS+= -L${LOCALBASE}/lib/db${BDB_VER}
.endif
.if ${PORT_OPTIONS:MCLX_MIT} || ${PORT_OPTIONS:MCLX_NEW}
+USES+= xorg
USE_XORG= x11
.endif
.if ${PORT_OPTIONS:MCLX_MIT}
@@ -135,6 +136,7 @@ CONFIGURE_ARGS+=--with-module=bindings/glibc
.endif
.if ${PORT_OPTIONS:MGTK2}
+USES+= gnome
USE_GNOME= gtk20 libglade2
CONFIGURE_ARGS+=--with-module=gtk2
.endif
diff --git a/lang/gjs/Makefile b/lang/gjs/Makefile
index aa2bf5088677..261b0e59500f 100644
--- a/lang/gjs/Makefile
+++ b/lang/gjs/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libmozjs-52.so:lang/spidermonkey52 \
libffi.so:devel/libffi
USES= compiler:c++11-lib gettext gmake gnome libtool \
- localbase pathfix pkgconfig python:build readline tar:xz
+ localbase pathfix pkgconfig python:build readline tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gtk30 introspection
USE_XORG= x11 xext
GNU_CONFIGURE= yes
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index 0a03785946d4..36811d138629 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= bash:shells/bash
WRKSRC= ${WRKDIR}/${DISTNAME}
HUGS_DATE= Sep2006
-USES= bison gmake openal:al,alut
+USES= bison gl gmake openal:al,alut xorg
USE_CSTD= gnu89
USE_GCC= yes
diff --git a/lang/icon/Makefile b/lang/icon/Makefile
index dd2ad42cdcc4..c9f48b9a0bd6 100644
--- a/lang/icon/Makefile
+++ b/lang/icon/Makefile
@@ -31,6 +31,7 @@ OPTIONS_DEFINE= DOCS X11
CONFIG_CMD= Configure
PLIST_SUB+= WITHOUT_X11="@comment "
.else
+USES+= xorg
USE_XORG= x11 xpm
CFLAGS+= -I${LOCALBASE}/include
CONFIG_CMD= X-Configure
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 71396e9463ca..7104cb0f1b05 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -82,6 +82,7 @@ CONFIGURE_ARGS+=-no-pthread
.if ${PORT_OPTIONS:MX11}
PLIST_SUB+= X11=""
+USES+= xorg
USE_XORG= x11
CONFLICTS+= ocaml-nox11-[0-9]*
CONFIGURE_ARGS+=-x11include ${LOCALBASE}/include -x11lib ${LOCALBASE}/lib
diff --git a/lang/php71/Makefile.ext b/lang/php71/Makefile.ext
index 45241b751a77..e1e28ee6665f 100644
--- a/lang/php71/Makefile.ext
+++ b/lang/php71/Makefile.ext
@@ -505,8 +505,6 @@ USES+= mysql
. endif
.endif
-.include <bsd.port.pre.mk>
-
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MTRUETYPE}
CONFIGURE_ARGS+=--enable-gd-native-ttf
@@ -520,12 +518,15 @@ LIB_DEPENDS+= libwebp.so:graphics/webp
CONFIGURE_ARGS+=--with-webp-dir=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MX11}
-USE_XORG= xpm
+USES+= xorg
+USE_XORG= x11 xpm
CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
.endif
+.include <bsd.port.pre.mk>
+
.if ${PHP_MODNAME} == "imap"
PHP_MOD_PRIO= 30
. if ${PORT_OPTIONS:MPANDA}
diff --git a/lang/php72/Makefile.ext b/lang/php72/Makefile.ext
index ab91404e077d..ce51af8a9420 100644
--- a/lang/php72/Makefile.ext
+++ b/lang/php72/Makefile.ext
@@ -509,8 +509,6 @@ USES+= mysql
. endif
.endif
-.include <bsd.port.pre.mk>
-
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MTRUETYPE}
CONFIGURE_ARGS+=--enable-gd-native-ttf
@@ -524,12 +522,15 @@ LIB_DEPENDS+= libwebp.so:graphics/webp
CONFIGURE_ARGS+=--with-webp-dir=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MX11}
-USE_XORG= xpm
+USES+= xorg
+USE_XORG= x11 xpm
CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
.endif
+.include <bsd.port.pre.mk>
+
.if ${PHP_MODNAME} == "imap"
. if ${PORT_OPTIONS:MPANDA}
LIB_DEPENDS+= libc-client4.so.10:mail/panda-cclient
diff --git a/lang/php73/Makefile.ext b/lang/php73/Makefile.ext
index 59fb076cd564..c6ae87849515 100644
--- a/lang/php73/Makefile.ext
+++ b/lang/php73/Makefile.ext
@@ -509,8 +509,6 @@ USES+= mysql
. endif
.endif
-.include <bsd.port.pre.mk>
-
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MTRUETYPE}
CONFIGURE_ARGS+=--enable-gd-native-ttf
@@ -524,12 +522,15 @@ LIB_DEPENDS+= libwebp.so:graphics/webp
CONFIGURE_ARGS+=--with-webp-dir=${LOCALBASE}
. endif
. if ${PORT_OPTIONS:MX11}
+USES+= xorg
USE_XORG= xpm
CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
.endif
+.include <bsd.port.pre.mk>
+
.if ${PHP_MODNAME} == "imap"
. if ${PORT_OPTIONS:MPANDA}
LIB_DEPENDS+= libc-client4.so.10:mail/panda-cclient
diff --git a/lang/php74/Makefile.ext b/lang/php74/Makefile.ext
index 043902a804a1..1d1e36bcedc1 100644
--- a/lang/php74/Makefile.ext
+++ b/lang/php74/Makefile.ext
@@ -489,8 +489,6 @@ USES+= mysql
. endif
.endif
-.include <bsd.port.pre.mk>
-
.if ${PHP_MODNAME} == "gd"
. if ${PORT_OPTIONS:MJIS}
CONFIGURE_ARGS+=--enable-gd-jis-conv
@@ -501,12 +499,15 @@ LIB_DEPENDS+= libwebp.so:graphics/webp
CONFIGURE_ARGS+=--with-webp
. endif
. if ${PORT_OPTIONS:MX11}
+USES+= xorg
USE_XORG= xpm
CONFIGURE_ARGS+=--with-xpm
. endif
.endif
+.include <bsd.port.pre.mk>
+
.if ${PHP_MODNAME} == "imap"
. if ${PORT_OPTIONS:MPANDA}
LIB_DEPENDS+= libc-client4.so.10:mail/panda-cclient
diff --git a/lang/ptoc/Makefile b/lang/ptoc/Makefile
index 3c978e6eaf1a..7fb64fc0ed45 100644
--- a/lang/ptoc/Makefile
+++ b/lang/ptoc/Makefile
@@ -12,8 +12,8 @@ COMMENT= ANSI/Turbo Pascal to C/C++ converter
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= bison xorg
USE_XORG= x11
-USES= bison
EXAMPLES= arr.pas bgidemo.pas ccall.pas coord.txt dos.h dos.pas \
func.pas hello.pas impact.pas lister.pas makefile.bsd \
diff --git a/lang/py-qt5-qml/Makefile b/lang/py-qt5-qml/Makefile
index e7436a7a4b40..c94e3f8dbb6e 100644
--- a/lang/py-qt5-qml/Makefile
+++ b/lang/py-qt5-qml/Makefile
@@ -12,7 +12,7 @@ RUN_DEPENDS= ${PY_ENUM34}
CONFIGURE_ARGS= --enable QtQml
PYQT_DIST= yes
-USES= python pyqt:5 qt:5
+USES= gl python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run network_run
USE_PYTHON= concurrent flavors py3kplist
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 838a42fcb305..23a2a98e15f5 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -21,7 +21,7 @@ ONLY_FOR_ARCHS= amd64 i386 sparc64
LIB_DEPENDS= libodbc.so:databases/unixODBC
-USES= mysql:client ncurses pgsql sqlite tar:tgz
+USES= mysql:client ncurses pgsql sqlite tar:tgz xorg
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index edee124af5f2..a7ff7210bb6d 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -31,7 +31,7 @@ LIB_DEPENDS= libaudio.so:audio/nas \
libpulse-simple.so:audio/pulseaudio \
libv4l2.so:multimedia/libv4l
-USES= pkgconfig
+USES= gl gnome pkgconfig
USE_GNOME= cairo pango
USE_GL= gl
HAS_CONFIGURE= yes
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 1f09885d2004..81936586e1d4 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -27,7 +27,7 @@ SWIPLDIR= ${PORTNAME:C/-//}-${PORTVERSION}
NOPRECIOUSMAKEVARS= yes
USES= compiler:c11 libedit gmake jpeg libarchive pathfix pkgconfig \
- readline shebangfix ssl
+ readline shebangfix ssl xorg
USE_XORG= ice sm x11 xext xft xinerama xpm xt
MAKE_JOBS_UNSAFE= yes
diff --git a/lang/yabasic/Makefile b/lang/yabasic/Makefile
index 889be899f7b7..2e370a05a68c 100644
--- a/lang/yabasic/Makefile
+++ b/lang/yabasic/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libffi.so:devel/libffi
-USES= autoreconf bison gmake localbase ncurses
+USES= autoreconf bison gmake localbase ncurses xorg
USE_GITHUB= yes
GH_ACCOUNT= marcIhm
diff --git a/lang/yorick/Makefile b/lang/yorick/Makefile
index 97cdaf78334c..2674806a9727 100644
--- a/lang/yorick/Makefile
+++ b/lang/yorick/Makefile
@@ -13,7 +13,7 @@ COMMENT= Interpreted language for scientific simulations
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= makeinfo
+USES= makeinfo xorg
USE_XORG= x11
MAKE_ARGS= Y_HOME=relocatable Y_DOCDIR=/dev/null