aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-13 07:01:20 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-13 07:05:40 +0000
commit7bec7b192cdabe3fc1ba9ddaeb4e6edc42c1be01 (patch)
tree14349e9dbd3e74af4f1e0839889f0017ea6401d2
parentb2f64c35edada1f6a6f0ae1c4b14db850f8f4578 (diff)
downloadports-7bec7b192cdabe3fc1ba9ddaeb4e6edc42c1be01.tar.gz
ports-7bec7b192cdabe3fc1ba9ddaeb4e6edc42c1be01.zip
Mk/Uses/cargo.mk: Make build scripts more verbose
Build scripts might build bundled libraries but non-error output is hiddden by cargo. Given a crate with large enough bundled library (looking at you rusty_v8) the build just sits there in silence forever and you do not know what is happening or if anything is happening at all. This also makes Poudriere build logs less useful. Pass an additional --verbose to cargo to get more noisy output. https://doc.rust-lang.org/cargo/reference/build-scripts.html#outputs-of-the-build-script
-rw-r--r--Mk/Uses/cargo.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index 226e3ebdb132..69a1ee45c8a4 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -277,6 +277,7 @@ cargo-configure:
@${CARGO_CARGO_RUN} update \
--manifest-path ${CARGO_CARGOTOML} \
--verbose \
+ --verbose \
${CARGO_UPDATE_ARGS}
.endif
@@ -285,6 +286,7 @@ do-build:
@${CARGO_CARGO_RUN} build \
--manifest-path ${CARGO_CARGOTOML} \
--verbose \
+ --verbose \
${CARGO_BUILD_ARGS}
.endif
@@ -296,6 +298,7 @@ do-install:
--path "${path}" \
--root "${STAGEDIR}${PREFIX}" \
--verbose \
+ --verbose \
${CARGO_INSTALL_ARGS}
. endfor
.endif
@@ -305,6 +308,7 @@ do-test:
@${CARGO_CARGO_RUN} test \
--manifest-path ${CARGO_CARGOTOML} \
--verbose \
+ --verbose \
${CARGO_TEST_ARGS}
.endif