aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-08 09:20:07 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-08 09:20:07 +0000
commit7bf6f023e4aa9114432deb634792563311f94d97 (patch)
tree61a2c9489071798fe8f5e77e50e05b90ab73251e
parent9dc7bcdccd620905d1f8e1690316f08f4348f026 (diff)
downloadports-7bf6f023e4aa9114432deb634792563311f94d97.tar.gz
ports-7bf6f023e4aa9114432deb634792563311f94d97.zip
security/py-bitbox02: Add new port
Python API for communicating with the BitBox02 device Sponsored by: Shift Crypto
-rw-r--r--security/Makefile1
-rw-r--r--security/py-bitbox02/Makefile25
-rw-r--r--security/py-bitbox02/distinfo3
-rw-r--r--security/py-bitbox02/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index bf78e1cf2535..98bf29a6b62a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -829,6 +829,7 @@
SUBDIR += py-azure-keyvault-secrets
SUBDIR += py-base58
SUBDIR += py-bcrypt
+ SUBDIR += py-bitbox02
SUBDIR += py-btchip-python
SUBDIR += py-cerealizer
SUBDIR += py-cert-human
diff --git a/security/py-bitbox02/Makefile b/security/py-bitbox02/Makefile
new file mode 100644
index 000000000000..b9fbe8f10ef9
--- /dev/null
+++ b/security/py-bitbox02/Makefile
@@ -0,0 +1,25 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+
+PORTNAME= bitbox02
+PORTVERSION= 6.0.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Python API for communicating with the BitBox02 device
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}base58>=2.0.0:security/py-base58@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ecdsa>=0.14:security/py-ecdsa@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}noiseprotocol>=0.3:security/py-noiseprotocol@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=3.7:devel/py-protobuf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}semver>=2.8.1:devel/py-semver@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-bitbox02/distinfo b/security/py-bitbox02/distinfo
new file mode 100644
index 000000000000..92293dacee1d
--- /dev/null
+++ b/security/py-bitbox02/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647857283
+SHA256 (bitbox02-6.0.0.tar.gz) = c136ad7a1ddd272705368ccb6906c0cd71746afaf6a1f05d8e5aaa70e04baffd
+SIZE (bitbox02-6.0.0.tar.gz) = 58777
diff --git a/security/py-bitbox02/pkg-descr b/security/py-bitbox02/pkg-descr
new file mode 100644
index 000000000000..b58caf4e285f
--- /dev/null
+++ b/security/py-bitbox02/pkg-descr
@@ -0,0 +1,3 @@
+Python code to communicate with BitBox02 cryptocurrency wallet.
+
+WWW: https://pypi.org/project/bitbox02/