aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2024-01-08 17:24:15 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2024-01-08 17:30:01 +0000
commit7c58302b41088e360559c3a3e58beb5cca89f521 (patch)
treef9cdd70e806f0e7e2dc61f633102f009c96b7b3f
parent5f0d96d150d59f1c53f7e949fb5eec86e6e6a138 (diff)
downloadports-7c58302b41088e360559c3a3e58beb5cca89f521.tar.gz
ports-7c58302b41088e360559c3a3e58beb5cca89f521.zip
ports-mgmt/portlint: Update to 2.22
This fixes some spurious errors by concatenating continued lines in the Makefile. The downside of this is that line numbers will get more askew. I thought I'd get some time to imrove this, but didn't. And this fix is important to get out now. PR: 275075
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl7
2 files changed, 7 insertions, 2 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 6cdf645fc588..c83969c45e9a 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -1,5 +1,5 @@
PORTNAME= portlint
-PORTVERSION= 2.21.0
+PORTVERSION= 2.22.0
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index f8d7185e8827..5fa4267e6065 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -51,7 +51,7 @@ $portdir = '.';
# version variables
my $major = 2;
-my $minor = 21;
+my $minor = 22;
my $micro = 0;
# default setting - for FreeBSD
@@ -1406,6 +1406,11 @@ sub checkmakefile {
}
}
$rawwhole .= $_;
+ if (/\\$/) {
+ # Concat continued lines.
+ chomp $rawwhole;
+ chop $rawwhole;
+ }
}
close(IN);