aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-09 15:32:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-09 15:37:58 +0000
commit7c7cdf2dc584772b706cf5d1473229348bc62244 (patch)
treede8363d009b691a94896665c1631595dd1186f28
parentbe52cd2d445db6673979e0779edfb8b884f2bf89 (diff)
security/py-sslyze: Allow build with py-cryptography 38.0.0+
- Bump PORTREVISION for package change
-rw-r--r--security/py-sslyze/Makefile4
-rw-r--r--security/py-sslyze/files/patch-setup.py7
2 files changed, 7 insertions, 4 deletions
diff --git a/security/py-sslyze/Makefile b/security/py-sslyze/Makefile
index f629836e7723..32f5217d6374 100644
--- a/security/py-sslyze/Makefile
+++ b/security/py-sslyze/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sslyze
PORTVERSION= 5.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,7 @@ WWW= https://github.com/nabla-c0d3/sslyze
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.6<38.0.0:security/py-cryptography@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.6<39.0.0:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nassl>=4.0.1<5.0.0:security/py-nassl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic>=1.7<1.11:devel/py-pydantic@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tls-parser>=2.0.0<3.0.0:security/py-tls-parser@${PY_FLAVOR}
diff --git a/security/py-sslyze/files/patch-setup.py b/security/py-sslyze/files/patch-setup.py
index 4a1329c64976..96adc8f743cd 100644
--- a/security/py-sslyze/files/patch-setup.py
+++ b/security/py-sslyze/files/patch-setup.py
@@ -1,8 +1,11 @@
--- setup.py.orig 2022-05-14 09:12:21 UTC
+++ setup.py
-@@ -100,7 +100,7 @@ setup(
+@@ -98,9 +98,9 @@ setup(
+ # Dependencies
+ install_requires=[
"nassl>=4.0.1,<5.0.0",
- "cryptography>=2.6,<38.0.0",
+- "cryptography>=2.6,<38.0.0",
++ "cryptography>=2.6,<39.0.0",
"tls-parser>=2.0.0,<3.0.0",
- "pydantic>=1.7,<1.10",
+ "pydantic>=1.7,<1.11",