aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:27:21 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:59:02 +0000
commit7c981661b355e387300622d6c9ccd59b832a3edf (patch)
tree4637f2e7abdd704de685628c3fbcb1458c523374
parenta963f3bf652b87c07e9fb78bb7c17f6ab9bc15e6 (diff)
downloadports-7c981661b355e387300622d6c9ccd59b832a3edf.tar.gz
ports-7c981661b355e387300622d6c9ccd59b832a3edf.zip
devel/libpci: Update to 3.9.0
-rw-r--r--devel/libpci/Makefile8
-rw-r--r--devel/libpci/distinfo6
-rw-r--r--devel/libpci/files/extra-patch-freebsd1211
-rw-r--r--devel/libpci/files/patch-Makefile10
-rw-r--r--devel/libpci/files/patch-lib-pci.h4
5 files changed, 28 insertions, 11 deletions
diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index 02ab68fb1d88..4437a5fd36c0 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libpci
-PORTVERSION= 3.8.0
+PORTVERSION= 3.9.0
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/utils/pciutils \
LOCAL/sunpoet
@@ -32,6 +32,12 @@ LIBPCI_FILES= include/pci/config.h \
lib/libpci.so.3 \
libdata/pkgconfig/libpci.pc
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 1300000
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-freebsd12
+.endif
+
post-patch:
@${LN} -s . ${WRKSRC}/lib/pci
diff --git a/devel/libpci/distinfo b/devel/libpci/distinfo
index f18f6c041041..bfcd4e97c95c 100644
--- a/devel/libpci/distinfo
+++ b/devel/libpci/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1650970037
-SHA256 (pciutils-3.8.0.tar.xz) = 91edbd0429a84705c9ad156d4ff38ccc724d41ea54c4c5b88e38e996f8a34f05
-SIZE (pciutils-3.8.0.tar.xz) = 410144
+TIMESTAMP = 1674589494
+SHA256 (pciutils-3.9.0.tar.xz) = cdea7ae97239dee23249a09c68a19a287a3f109fbeb2c232ebb616cb38599012
+SIZE (pciutils-3.9.0.tar.xz) = 431624
diff --git a/devel/libpci/files/extra-patch-freebsd12 b/devel/libpci/files/extra-patch-freebsd12
new file mode 100644
index 000000000000..23421a6b0491
--- /dev/null
+++ b/devel/libpci/files/extra-patch-freebsd12
@@ -0,0 +1,11 @@
+--- lib/mmio-ports.c.orig 2022-11-18 13:59:51 UTC
++++ lib/mmio-ports.c
+@@ -298,7 +298,7 @@ conf1_init(struct pci_access *a)
+ if (!validate_addrs(addrs))
+ a->error("Option %s has invalid address format \"%s\".", addrs_param_name, addrs);
+
+- a->fd = open(devmem, O_RDWR | O_DSYNC); /* O_DSYNC bypass CPU cache for mmap() on Linux */
++ a->fd = open(devmem, O_RDWR); /* O_DSYNC bypass CPU cache for mmap() on Linux */
+ if (a->fd < 0)
+ a->error("Cannot open %s: %s.", devmem, strerror(errno));
+ }
diff --git a/devel/libpci/files/patch-Makefile b/devel/libpci/files/patch-Makefile
index 93d0e7538725..b4ea1e23a3be 100644
--- a/devel/libpci/files/patch-Makefile
+++ b/devel/libpci/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2022-04-18 16:47:28 UTC
+--- Makefile.orig 2022-11-20 11:58:03 UTC
+++ Makefile
@@ -1,8 +1,8 @@
# Makefile for The PCI Utilities
@@ -9,10 +9,10 @@
+#OPT=-O2
+CFLAGS+=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
- VERSION=3.8.0
- DATE=2022-04-18
+ VERSION=3.9.0
+ DATE=2022-11-20
@@ -32,11 +32,11 @@ HWDB=
- ABI_VERSION=.3
+ ABI_VERSION=3
# Installation directories
-PREFIX=/usr/local
@@ -41,4 +41,4 @@
+#endif
AR=$(CROSS_COMPILE)ar
RANLIB=$(CROSS_COMPILE)ranlib
-
+ DLLTOOL=$(CROSS_COMPILE)dlltool
diff --git a/devel/libpci/files/patch-lib-pci.h b/devel/libpci/files/patch-lib-pci.h
index dd1434529b5a..addbf8787c7f 100644
--- a/devel/libpci/files/patch-lib-pci.h
+++ b/devel/libpci/files/patch-lib-pci.h
@@ -1,4 +1,4 @@
---- lib/pci.h.orig 2020-05-30 22:17:41 UTC
+--- lib/pci.h.orig 2022-11-20 11:58:19 UTC
+++ lib/pci.h
@@ -10,11 +10,11 @@
#define _PCI_LIB_H
@@ -13,5 +13,5 @@
+#include "pci/header.h"
+#include "pci/types.h"
- #define PCI_LIB_VERSION 0x030700
+ #define PCI_LIB_VERSION 0x030900