aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-17 12:55:08 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-17 13:11:38 +0000
commit7d0d0cf4403d5aedc84097a3b5a15f223702474a (patch)
treed0feb4f8d581b22bbb336625ee3cd86ad7469ad0
parent136f67e2badd647776681b87b34967aeca8ff06b (diff)
downloadports-7d0d0cf4403d5aedc84097a3b5a15f223702474a.tar.gz
ports-7d0d0cf4403d5aedc84097a3b5a15f223702474a.zip
x11-wm/wmakerconf: Mark DEPRECATED
- Last upstream release was in 2007 - Set EXPIRATION_DATE 2024-01-17 - Pet portclippy - Refresh patches - Add missing dependencies
-rw-r--r--x11-wm/wmakerconf/Makefile23
-rw-r--r--x11-wm/wmakerconf/files/patch-scripts__wget.pl6
2 files changed, 20 insertions, 9 deletions
diff --git a/x11-wm/wmakerconf/Makefile b/x11-wm/wmakerconf/Makefile
index 3f0793fcde4d..065e02c7e869 100644
--- a/x11-wm/wmakerconf/Makefile
+++ b/x11-wm/wmakerconf/Makefile
@@ -12,19 +12,30 @@ WWW= https://sourceforge.net/projects/wmakerconf/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libWINGs.so:x11-wm/windowmaker
+DEPRECATED= Last upstream release was in 2007
+EXPIRATION_DATE= 2024-01-17
+
+LIB_DEPENDS= \
+ libWINGs.so:x11-wm/windowmaker \
+ libharfbuzz.so:print/harfbuzz \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libwraster.so:x11-wm/libwraster
RUN_DEPENDS= rpm:archivers/rpm4
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= gettext pkgconfig perl5 gmake gnome localbase shebangfix xorg
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_XORG= x11
-USES= gettext pkgconfig perl5 gmake gnome shebangfix xorg
-USE_GNOME= gtk20
SHEBANG_FILES= scripts/getfile.pl.in scripts/upgrade.pl.in
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wmakerdataprefix="${LOCALBASE}/share" \
--with-wmakeretcprefix="${LOCALBASE}/share"
-USE_XORG= x11
-LIBS= -L${LOCALBASE}/lib -lintl -lX11 -lWUtil
+
+LIBS= -lintl -lX11 -lWUtil
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
post-extract:
@${FIND} ${WRKSRC} -name "*.gmo" -delete
diff --git a/x11-wm/wmakerconf/files/patch-scripts__wget.pl b/x11-wm/wmakerconf/files/patch-scripts__wget.pl
index 1956f065fd1a..2d714b0cc533 100644
--- a/x11-wm/wmakerconf/files/patch-scripts__wget.pl
+++ b/x11-wm/wmakerconf/files/patch-scripts__wget.pl
@@ -1,6 +1,6 @@
---- scripts/wget.pl.orig Mon Jan 26 07:20:31 2004
-+++ scripts/wget.pl Wed Jun 2 01:56:42 2004
-@@ -1,5 +1,5 @@
+--- scripts/wget.pl.orig 2004-01-25 22:20:31 UTC
++++ scripts/wget.pl
+@@ -1,5 +1,5 @@ quit ("Wget not installed") if $wwwget eq "";
quit ("Wget not installed") if $wwwget eq "";
-$rc = system ("$wwwget --quiet -c --tries=0 -O$tmpfile '$url'");