aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-19 04:55:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-19 05:40:34 +0000
commit7d36c5ee92e135cc693a8536c6f935748dbcf1da (patch)
tree3d23b35aa718262115e3ea3ddd68625a8872b077
parent90c9dd92650814f96b99a5db257e8b620e00b16f (diff)
downloadports-7d36c5ee92e135cc693a8536c6f935748dbcf1da.tar.gz
ports-7d36c5ee92e135cc693a8536c6f935748dbcf1da.zip
cad/verilator: Enable MAKE_JOBS_UNSAFE because the build is killed otherwise
... due to compilation processes taking too much memory. Reported by: fallout
-rw-r--r--cad/verilator/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/cad/verilator/Makefile b/cad/verilator/Makefile
index 0945ccf36c14..e8e0a6967a87 100644
--- a/cad/verilator/Makefile
+++ b/cad/verilator/Makefile
@@ -40,7 +40,7 @@ TEST_TARGET= test # tests fail, see https://github.com/verilator/verilator/issue
BINARY_ALIAS= make=${GMAKE} python3=${PYTHON_CMD} # aliasas are only for tests
-#MAKE_JOBS_UNSAFE= yes # build on 1 CPU because many compile jobs are over 10GB and they can likely cause out-of-memory issues
+MAKE_JOBS_UNSAFE= yes # build on 1 CPU because many compile jobs are over 10GB and they can likely cause out-of-memory issues
OPTIONS_DEFINE= INSTALL_DBG_EXECUTABLES LEAK_CHECKS
OPTIONS_SUB= yes