aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-17 07:30:11 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-17 07:30:11 +0000
commit7d6b6ced470a69a4c7f389376adffab6599e6f3f (patch)
treef26395651f393721d128e4c81d2882bd4b7db079
parent4bee7abc2f68e0aa6b13e1eb734d0a95bdb25383 (diff)
downloadports-7d6b6ced470a69a4c7f389376adffab6599e6f3f.tar.gz
ports-7d6b6ced470a69a4c7f389376adffab6599e6f3f.zip
- Update to 3.0.2
PR: ports/108008 Submitted by: Brad Huntting <huntting at glarp.com> (maintainer)
Notes
Notes: svn path=/head/; revision=182603
-rw-r--r--sysutils/fcron/Makefile6
-rw-r--r--sysutils/fcron/distinfo6
-rw-r--r--sysutils/fcron/files/patch-config.h.in8
-rw-r--r--sysutils/fcron/files/patch-configure.in20
-rw-r--r--sysutils/fcron/files/patch-fcrondyn.c29
-rw-r--r--sysutils/fcron/files/patch-socket.c34
-rw-r--r--sysutils/fcron/pkg-install2
7 files changed, 6 insertions, 99 deletions
diff --git a/sysutils/fcron/Makefile b/sysutils/fcron/Makefile
index df752be727df..009f5bbb9135 100644
--- a/sysutils/fcron/Makefile
+++ b/sysutils/fcron/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= fcron
-PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTVERSION= 3.0.2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://fcron.free.fr/archives/ \
@@ -21,7 +20,6 @@ COMMENT= A periodic command scheduler
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:259
USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
--with-rootname=root --with-rootgroup=wheel \
@@ -37,7 +35,7 @@ MAN5= fcron.conf.5 fcrontab.5
MAN8= fcron.8
PAMDIR?= /etc/pam.d
-PLIST_SUB+= PAMDIR=${PAMDIR}
+PLIST_SUB+= PAMDIR=etc/pam.d
PORTDOCS= *
diff --git a/sysutils/fcron/distinfo b/sysutils/fcron/distinfo
index 0a55a004cc5d..20c0c417254a 100644
--- a/sysutils/fcron/distinfo
+++ b/sysutils/fcron/distinfo
@@ -1,3 +1,3 @@
-MD5 (fcron-3.0.1.src.tar.gz) = 8e5dcb3a646c11294294895954ef0a48
-SHA256 (fcron-3.0.1.src.tar.gz) = 31288b04619bb9c7cd5fe6ff004c1e2c1340685cec2d0fa8725259c491699de9
-SIZE (fcron-3.0.1.src.tar.gz) = 536972
+MD5 (fcron-3.0.2.src.tar.gz) = f35e6af41d356ebcb38882f86a14fb94
+SHA256 (fcron-3.0.2.src.tar.gz) = ea25f4e9a78f6872c65cc97aa18c018b548e9fcd73b06d77c312e635ecf9ad48
+SIZE (fcron-3.0.2.src.tar.gz) = 540559
diff --git a/sysutils/fcron/files/patch-config.h.in b/sysutils/fcron/files/patch-config.h.in
deleted file mode 100644
index 1a396012d854..000000000000
--- a/sysutils/fcron/files/patch-config.h.in
+++ /dev/null
@@ -1,8 +0,0 @@
---- config.h.in.orig Mon Feb 6 14:44:52 2006
-+++ config.h.in Tue May 9 17:15:19 2006
-@@ -424,3 +424,5 @@
- #define O_SYNC O_FSYNC
- #endif
-
-+/* Define if (struct sockaddr) has an sa_len field. */
-+#undef HAVE_SA_LEN
diff --git a/sysutils/fcron/files/patch-configure.in b/sysutils/fcron/files/patch-configure.in
deleted file mode 100644
index 63378ef5f5cf..000000000000
--- a/sysutils/fcron/files/patch-configure.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.in.orig Mon Jan 9 17:21:24 2006
-+++ configure.in Tue May 9 17:04:30 2006
-@@ -57,6 +57,17 @@
- AC_STRUCT_TM
- AC_TYPE_UID_T
-
-+dnl Check for post-Reno style struct sockaddr
-+AC_CACHE_CHECK([for sa_len],
-+ ac_cv_sa_len,
-+[AC_TRY_COMPILE([#include <sys/types.h>
-+#include <sys/socket.h>], [int main(void) {
-+ struct sockaddr t;t.sa_len = 0;}],
-+ ac_cv_sa_len=yes,ac_cv_sa_len=no)])
-+if test $ac_cv_sa_len = yes; then
-+ AC_DEFINE(HAVE_SA_LEN)
-+fi
-+
- dnl Checks for library functions.
- AC_PROG_GCC_TRADITIONAL
- AC_FUNC_MEMCMP
diff --git a/sysutils/fcron/files/patch-fcrondyn.c b/sysutils/fcron/files/patch-fcrondyn.c
deleted file mode 100644
index b6d374d74c78..000000000000
--- a/sysutils/fcron/files/patch-fcrondyn.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- fcrondyn.c.orig Mon Feb 6 14:44:52 2006
-+++ fcrondyn.c Tue May 9 15:24:22 2006
-@@ -399,17 +399,21 @@
- int fd = -1;
- struct sockaddr_un addr;
- int len = 0;
-+ int sa_len;
-
- if ( (fd = socket(PF_UNIX, SOCK_STREAM, 0)) == -1 )
- die_e("could not create socket");
-
- addr.sun_family = AF_UNIX;
-- if ( (len = strlen(fifofile)) > sizeof(addr.sun_path) )
-- die("Error : fifo file path too long (max is %d)", sizeof(addr.sun_path));
-- strncpy(addr.sun_path, fifofile, sizeof(addr.sun_path) - 1);
-- addr.sun_path[sizeof(addr.sun_path)-1] = '\0';
-+ if ( (len = strlen(fifofile)) > sizeof(addr.sun_path) - 1 )
-+ die("Error : fifo file path too long (max is %d)", sizeof(addr.sun_path) - 1);
-+ strncpy(addr.sun_path, fifofile, sizeof(addr.sun_path));
-+ sa_len = (addr.sun_path - (char *)&addr) + len;
-+#if HAVE_SA_LEN
-+ addr.sun_len = sa_len;
-+#endif
-
-- if ( connect(fd, (struct sockaddr *) &addr, sizeof(addr.sun_family) + len) < 0 )
-+ if ( connect(fd, (struct sockaddr *) &addr, sa_len) < 0 )
- die_e("Cannot connect() to fcron (check if fcron is running)");
-
- if ( authenticate_user(fd) == ERR ) {
diff --git a/sysutils/fcron/files/patch-socket.c b/sysutils/fcron/files/patch-socket.c
deleted file mode 100644
index 8dabb2aa077b..000000000000
--- a/sysutils/fcron/files/patch-socket.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- socket.c.orig Mon Feb 6 14:44:52 2006
-+++ socket.c Tue May 9 16:33:19 2006
-@@ -134,6 +134,7 @@
- {
- struct sockaddr_un addr;
- int len = 0;
-+ int sa_len;
-
- /* used in fcron.c:main_loop():select() */
- FD_ZERO(&read_set);
-@@ -145,15 +146,19 @@
- }
-
- addr.sun_family = AF_UNIX;
-- if ( (len = strlen(fifofile)) > sizeof(addr.sun_path) ) {
-- error("Error : fifo file path too long (max is %d)", sizeof(addr.sun_path));
-+ if ( (len = strlen(fifofile)) > sizeof(addr.sun_path) - 1) {
-+ error("Error : fifo file path too long (max is %d)", sizeof(addr.sun_path) - 1);
- goto err;
- }
-- strncpy(addr.sun_path, fifofile, sizeof(addr.sun_path) - 1);
-+ strncpy(addr.sun_path, fifofile, sizeof(addr.sun_path));
- addr.sun_path[sizeof(addr.sun_path) -1 ] = '\0';
-+ sa_len = (addr.sun_path - (char *)&addr) + len;
-+#if HAVE_SA_LEN
-+ addr.sun_len = sa_len;
-+#endif
-
- unlink(fifofile);
-- if (bind(listen_fd, (struct sockaddr*) &addr, sizeof(addr.sun_family)+len+1) != 0){
-+ if (bind(listen_fd, (struct sockaddr*) &addr, sa_len) != 0){
- error_e("Cannot bind socket to '%s'", fifofile);
- goto err;
- }
diff --git a/sysutils/fcron/pkg-install b/sysutils/fcron/pkg-install
index f7a366c4e644..a4fe55d028f0 100644
--- a/sysutils/fcron/pkg-install
+++ b/sysutils/fcron/pkg-install
@@ -21,7 +21,7 @@ if [ "$2" = PRE-INSTALL ]; then
if /usr/sbin/pw usershow $user 2>/dev/null; then
echo "Using already existing user \"$user\"."
else
- if /usr/sbin/pw useradd $user -u $uid -g $group -c "fcron pseudo-user"; then
+ if /usr/sbin/pw useradd $user -u $uid -g $group -s /sbin/nologin -c "fcron pseudo-user"; then
echo "Added user \"$user\"."
else
echo "Unable to add user \"$user\"."