aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 21:39:04 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 22:16:16 +0000
commit7d78503f8b58ad11250def2d792db93ce8243e97 (patch)
tree7f25b55c9de079d9c952f3593e7c94003c345fee
parent679ae95ffdf009bdcc72e2ba5b4379cf64ccee00 (diff)
downloadports-7d78503f8b58ad11250def2d792db93ce8243e97.tar.gz
ports-7d78503f8b58ad11250def2d792db93ce8243e97.zip
math/mathgl: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--math/mathgl/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/math/mathgl/Makefile b/math/mathgl/Makefile
index 492a9f7e6ef1..7f12a432d6fb 100644
--- a/math/mathgl/Makefile
+++ b/math/mathgl/Makefile
@@ -22,10 +22,10 @@ LIB_DEPENDS= libgif.so:graphics/giflib \
libsz.so:science/libaec
USES= cmake compiler:c++11-lang dos2unix gettext-runtime gl jpeg xorg
+DOS2UNIX_GLOB= *.cpp *.h
USE_GL= gl glu glut
-USE_XORG= xi xmu
USE_LDCONFIG= yes
-DOS2UNIX_GLOB= *.cpp *.h
+USE_XORG= xi xmu
.for v in double gif glut gsl hdf5 jpeg ltdl mgl2 opengl pdf png zlib
CMAKE_ARGS+= -Denable-${v}=ON
@@ -35,18 +35,22 @@ CMAKE_ARGS+= -Denable-${v}=ON
CMAKE_ARGS+= -Denable-${v}=OFF
.endfor
+CXXFLAGS+= --std=c++14
+
+PLIST_SUB= SHLIB_VER=7.6.0
+
OPTIONS_DEFINE= PYTHON MPI
+OPTIONS_DEFAULT= QT5
OPTIONS_GROUP= GRAPHICS
OPTIONS_GROUP_GRAPHICS= QT5 FLTK WXGTK
OPTIONS_RADIO= THREADS
OPTIONS_RADIO_THREADS= PTHREADS OPENMP
-OPTIONS_DEFAULT= QT5
OPTIONS_SUB= yes
+
+FLTK_DESC= Enable fltk widget
GRAPHICS_DESC= Graphics support
-PTHREADS_DESC= Enable POSIX threads support (broken, fix pending release)
OPENMP_DESC= Parallel processing support via OpenMP (broken, cmake bug)
-FLTK_DESC= Enable fltk widget
-PLIST_SUB= SHLIB_VER=7.6.0
+PTHREADS_DESC= Enable POSIX threads support (broken, fix pending release)
PYTHON_CMAKE_BOOL= enable-python
PYTHON_BUILD_DEPENDS= swig:devel/swig \