aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2011-11-10 05:38:32 +0000
committerMark Linimon <linimon@FreeBSD.org>2011-11-10 05:38:32 +0000
commit7d8608ab13015da604725355ba888c212c9eb177 (patch)
tree74d9147b89d28cb3c65b13ef847fe70663415054
parent93cc5a0629ed3d9812bbda5c1097872843a63f14 (diff)
downloadports-7d8608ab13015da604725355ba888c212c9eb177.tar.gz
ports-7d8608ab13015da604725355ba888c212c9eb177.zip
Mark broken on powerpc as well as sparc64. (In fact, on all the tier-2s.)
Hat: portmgr
Notes
Notes: svn path=/head/; revision=285419
-rw-r--r--audio/cuberok/Makefile4
-rw-r--r--cad/pcb/Makefile4
-rw-r--r--chinese/cwtex/Makefile4
-rw-r--r--databases/dbh/Makefile4
-rw-r--r--devel/plan9port/Makefile4
-rw-r--r--devel/thrift/Makefile4
-rw-r--r--devel/upp/Makefile4
-rw-r--r--dns/curvedns/Makefile4
-rw-r--r--editors/ved/Makefile4
-rw-r--r--emulators/vba/Makefile6
-rw-r--r--emulators/xmame/Makefile7
-rw-r--r--games/bloodfrontier/Makefile4
-rw-r--r--graphics/enfle/Makefile4
-rw-r--r--graphics/grx/Makefile4
-rw-r--r--graphics/gsculpt/Makefile4
-rw-r--r--graphics/luxrender/Makefile4
-rw-r--r--japanese/mozc-server/Makefile4
-rw-r--r--lang/clisp/Makefile4
-rw-r--r--lang/gauche/Makefile4
-rw-r--r--lang/llvm-gcc4/Makefile4
-rw-r--r--mail/wmmaiload/Makefile4
-rw-r--r--math/algae/Makefile4
-rw-r--r--multimedia/mpeg4ip/Makefile4
-rw-r--r--multimedia/mpeg_play/Makefile4
-rw-r--r--net-mgmt/spectools/Makefile6
-rw-r--r--net/hostapd/Makefile4
-rw-r--r--science/cdf/Makefile4
-rw-r--r--security/cryptopp/Makefile2
-rw-r--r--sysutils/htop/Makefile2
-rw-r--r--sysutils/p5-Sys-Filesystem/Makefile2
-rw-r--r--textproc/groonga/Makefile4
-rw-r--r--textproc/sphinxsearch-devel/Makefile4
-rw-r--r--www/trafficserver/Makefile4
-rw-r--r--x11-toolkits/9libs/Makefile4
34 files changed, 67 insertions, 70 deletions
diff --git a/audio/cuberok/Makefile b/audio/cuberok/Makefile
index 8f04a7bea1e2..3a51df5a69f1 100644
--- a/audio/cuberok/Makefile
+++ b/audio/cuberok/Makefile
@@ -41,8 +41,8 @@ do-configure:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index d2edcaaa24d9..bffda293bccf 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -56,8 +56,8 @@ CONFIGURE_ARGS+= --disable-doc
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/chinese/cwtex/Makefile b/chinese/cwtex/Makefile
index 340851f1786f..e6fa9f6bbf77 100644
--- a/chinese/cwtex/Makefile
+++ b/chinese/cwtex/Makefile
@@ -37,8 +37,8 @@ do-install:
PSFONTSMAP!= ${LOCALBASE}/bin/kpsewhich -format 'dvips config' config.ps 2>/dev/null || ${ECHO_CMD} "/dev/null"
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not install on ia64 or sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/databases/dbh/Makefile b/databases/dbh/Makefile
index 8e685be3d58a..1b2d0a29df66 100644
--- a/databases/dbh/Makefile
+++ b/databases/dbh/Makefile
@@ -59,8 +59,8 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index 7b7a2f1be08f..e609f83d32f8 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -139,8 +139,8 @@ install-user:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not install on ia64 or sparc64: cleanname not found
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not install: cleanname not found
.endif
.include <bsd.port.post.mk>
diff --git a/devel/thrift/Makefile b/devel/thrift/Makefile
index 17f6a910aad2..50124b456fcd 100644
--- a/devel/thrift/Makefile
+++ b/devel/thrift/Makefile
@@ -56,8 +56,8 @@ CONFIGURE_ARGS+= \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
post-patch:
diff --git a/devel/upp/Makefile b/devel/upp/Makefile
index 6f0675162ad5..0338b9098b55 100644
--- a/devel/upp/Makefile
+++ b/devel/upp/Makefile
@@ -65,8 +65,8 @@ USE_PGSQL= yes
MACRO_FLAGS+= -DflagUSEMALLOC
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
pre-build: .SILENT
diff --git a/dns/curvedns/Makefile b/dns/curvedns/Makefile
index 48816af10426..2a774c9139b3 100644
--- a/dns/curvedns/Makefile
+++ b/dns/curvedns/Makefile
@@ -32,8 +32,8 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
post-patch:
diff --git a/editors/ved/Makefile b/editors/ved/Makefile
index 5a445dfbe30d..76e86770aab0 100644
--- a/editors/ved/Makefile
+++ b/editors/ved/Makefile
@@ -22,8 +22,8 @@ PLIST_DIRS= %%DATADIR%%
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= does not compile on ia64 or sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
post-patch:
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index 58e152d50738..b7f7647ea4d4 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -32,14 +32,10 @@ DOC_FILES= COPYING AUTHORS NEWS README ChangeLog INSTALL
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Runaway cc1plus process
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Fails to compile: internal gcc error
-.endif
-
.ifdef(WITH_GTK2)
PLIST_SUB= INSTALL_GTK2=""
CONFIGURE_ARGS+= --enable-gtk=2.4
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index a629c3adaf82..ed3c158298bd 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -31,9 +31,6 @@ WANT_SDL= yes
WANT_GNOME= yes
MAKE_JOBS_UNSAFE= yes
-# Broken on ia-64
-NOT_FOR_ARCHS= ia64
-
# Are we building MAME or MESS? (also set by slave ports)
MAMEMESS?= mame
@@ -112,6 +109,10 @@ ALLDOCS= ${GENERALDOCS} ${XMESSDOCS}
#
.include <bsd.port.pre.mk>
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
.if defined(WITH_ASM68K)
ASM_COMMENT=
.else
diff --git a/games/bloodfrontier/Makefile b/games/bloodfrontier/Makefile
index 12bd4f92adde..11cef870430f 100644
--- a/games/bloodfrontier/Makefile
+++ b/games/bloodfrontier/Makefile
@@ -33,8 +33,8 @@ OPTIONS= CLIENT "Build client" on \
.include <bsd.port.options.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= does not build on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED)
diff --git a/graphics/enfle/Makefile b/graphics/enfle/Makefile
index 7421938b6746..38181ce8be9f 100644
--- a/graphics/enfle/Makefile
+++ b/graphics/enfle/Makefile
@@ -54,8 +54,8 @@ CONFIGURE_ARGS+= --disable-mmx --disable-sse
.endif
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.if ${OSVERSION} < 700000
diff --git a/graphics/grx/Makefile b/graphics/grx/Makefile
index ddfa66238578..e0eceb7e7a1f 100644
--- a/graphics/grx/Makefile
+++ b/graphics/grx/Makefile
@@ -90,8 +90,8 @@ CONFIGURE_ARGS+=--disable-zlib
CONFIGURE_ARGS+=--enable-x86_64
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
post-patch:
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index 8c537686e34f..9501a59c5c2d 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -32,8 +32,8 @@ DATADIR= ${PREFIX}/share/gSculpt
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
post-patch:
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index e46ac4a12c37..b68f7b1570f1 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -63,8 +63,8 @@ post-patch:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64: uses i386-specific options
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile4: uses i386-specific options
.endif
.include <bsd.port.post.mk>
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 689b6c32e6f4..4aa2c15daa52 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -34,8 +34,8 @@ USE_PYTHON= yes
BROKEN= Does not compile on FreeBSD 7.X
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64: segfault
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile: segfault
.endif
.if defined(WITH_DEBUG_CODE)
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index d68db524dea8..684b8f0f0071 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -68,8 +68,8 @@ CONFIGURE_ARGS+=--disable-mmap
BROKEN= Does not build on FreeBSD 6.x
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
MODULES= BDB CLX_NEW CLX_MIT DBUS FASTCGI GDBM GTK2 PARI PCRE PGSQL \
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index 5de10a35fc07..da69a5e38321 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -50,8 +50,8 @@ INFO= gauche-refe gauche-refj
.include <bsd.port.pre.mk>
-.if (${ARCH} == "ia64") || (${ARCH} == "sparc64")
-BROKEN= Does not compile on ${ARCH}
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.if ${ARCH} == "amd64" && ${OSVERSION} >= 900000
diff --git a/lang/llvm-gcc4/Makefile b/lang/llvm-gcc4/Makefile
index 8affd42d48e9..ea682ecda5f3 100644
--- a/lang/llvm-gcc4/Makefile
+++ b/lang/llvm-gcc4/Makefile
@@ -64,8 +64,8 @@ CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --disable-shared
.endif
-.if ${ARCH} == "sparc64"
-IGNORE= does not install: not yet supported on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+IGNORE= does not install: not yet supported on this architecture
.endif
post-extract:
diff --git a/mail/wmmaiload/Makefile b/mail/wmmaiload/Makefile
index 3e5ef759989b..c6e6ec62c8d0 100644
--- a/mail/wmmaiload/Makefile
+++ b/mail/wmmaiload/Makefile
@@ -72,8 +72,8 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not install on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/math/algae/Makefile b/math/algae/Makefile
index 6e0750bdf267..a7033f0ed039 100644
--- a/math/algae/Makefile
+++ b/math/algae/Makefile
@@ -41,8 +41,8 @@ pre-configure:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" || ${ARCH} == "sparc64"
-BROKEN= Configure fails on alpha and sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index e8408e0d84cf..6539c63341f4 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -140,8 +140,8 @@ PLIST_SUB+= XVID=""
PLIST_SUB+= XVID="@comment "
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
#post-patch:
diff --git a/multimedia/mpeg_play/Makefile b/multimedia/mpeg_play/Makefile
index 31cbb84908a6..7e7ea6a6e51b 100644
--- a/multimedia/mpeg_play/Makefile
+++ b/multimedia/mpeg_play/Makefile
@@ -24,8 +24,8 @@ PLIST_FILES= bin/mpeg_play
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
-BROKEN= Does not compile on ia64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc"
+BROKEN= Does not compile on ia64 or powerpc: uses i386-specific code
.endif
pre-patch:
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 53737d08edc4..a910ed35dc28 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -58,11 +58,11 @@ IGNORE= is unsupported on systems prior to FreeBSD v700027
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
.endif
-.if ${ARCH} == "sparc64"
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
.if ${OSVERSION} > 800000
-BROKEN= Does not build on sparc64-8: duplicate definition of malloc
+BROKEN= Does not build: duplicate definition of malloc
.else
-BROKEN= Does not compile on sparc64: fails to build wispy_hw_dbx.c
+BROKEN= Does not compile: fails to build wispy_hw_dbx.c
.endif
.endif
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index 3c0a31bcbfb3..a3c46954a196 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -42,8 +42,8 @@ LICENSE_COMB= dual
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/science/cdf/Makefile b/science/cdf/Makefile
index b36f0283bede..88f60cbf8f7f 100644
--- a/science/cdf/Makefile
+++ b/science/cdf/Makefile
@@ -35,8 +35,8 @@ PORTDOCS= CDF_copyright.txt CHANGES.txt Release.notes Welcome.txt
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on ${ARCH}
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
pre-configure:
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 621c77360721..11bfa9e73fff 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -44,7 +44,7 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64: unrecognized C++ options
.endif
diff --git a/sysutils/htop/Makefile b/sysutils/htop/Makefile
index 9ea7f5895203..5e3e6a9ca5ac 100644
--- a/sysutils/htop/Makefile
+++ b/sysutils/htop/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
OPTIONS= LSOF "Enable lsof support" On
-NOT_FOR_ARCHS= sparc64
+NOT_FOR_ARCHS= ia64 powerpc sparc64
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/p5-Sys-Filesystem/Makefile b/sysutils/p5-Sys-Filesystem/Makefile
index 6caf1a688fac..4a62552421e1 100644
--- a/sysutils/p5-Sys-Filesystem/Makefile
+++ b/sysutils/p5-Sys-Filesystem/Makefile
@@ -35,7 +35,7 @@ MAN3= Sys::Filesystem::Mswin32.3 \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
MANUAL_PACKAGE_BUILD= accesses /etc/fstab during configure phase
.endif
diff --git a/textproc/groonga/Makefile b/textproc/groonga/Makefile
index d5bbf14bdbd8..69bfbefd2fa0 100644
--- a/textproc/groonga/Makefile
+++ b/textproc/groonga/Makefile
@@ -26,8 +26,8 @@ MAN1= groonga.1
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.if defined(WITH_MECAB) || exists(${LOCALBASE}/lib/libmecab.so)
diff --git a/textproc/sphinxsearch-devel/Makefile b/textproc/sphinxsearch-devel/Makefile
index 9b8d7341da1b..6c5983c83506 100644
--- a/textproc/sphinxsearch-devel/Makefile
+++ b/textproc/sphinxsearch-devel/Makefile
@@ -115,8 +115,8 @@ PORTEXAMPLES= *
DOCS= doc/sphinx.css doc/sphinx.html doc/sphinx.txt doc/sphinx.xml
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not build on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
# Fix up the sample configuration file to correspond to FreeBSD norms
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index cd5e6510ad11..5d21b2b2c141 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -43,8 +43,8 @@ RUN_DEPENDS= xz>0:${PORTSDIR}/archivers/xz
BROKEN= does not compile on 7.X/amd64
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not configure on sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
post-configure:
diff --git a/x11-toolkits/9libs/Makefile b/x11-toolkits/9libs/Makefile
index 70e5f12ca08a..39af7a117cd0 100644
--- a/x11-toolkits/9libs/Makefile
+++ b/x11-toolkits/9libs/Makefile
@@ -24,8 +24,8 @@ MAN6= bitmap.6 regexp.6
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" || ${ARCH} == "amd64"
-BROKEN= Does not compile on alpha or amd64
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "powerpc"
+BROKEN= Does not compile
.endif
.include <bsd.port.post.mk>